Author Topic: Aspect ratio problem ripping DVD to MKV  (Read 2487 times)

May 16, 2009, 10:55:10 AM
Read 2487 times

jabster

  • Jr. Member

  • Offline
  • **

  • 77
Hi.

I've ripped most of my DVDs to VOB onto my HD using mplayer, and am now looking to convert them into MKV containers, primarily so that I can add chapters to the movies for easier navigation.

I am having one problem with one DVD in particular, Monsters Inc. The movie is 1.85:1 (per the box), and on the WD TV, the VOB plays back correctly, with black bars on the top and bottom. However, the MKV is playing at 16:9, filling up the entire TV screen.

Here's the most recent mkvmerge command I used:
Code: [Select]
mkvmerge -o Monsters-notsynced.mkv --aspect-ratio 0:1.78 --chapters CHAPS.txt --title "Monsters, Inc." --attachment-description "Monsters Inc Image" --attachment-mime-type image/jpeg --attach-file Monsters\ Inc.jpg -d 0 -A -S Monsters\ Inc.vob -a 1 -D -S Monsters\ Inc.vobI've also tried other aspect ratios (2.35, 1.85), and leaving that option out as well, and it always fills up the screen (no black bars).

Here's video output from mediainfo:
VOB:
Code: [Select]
Video
ID                               : 224 (0xE0)
Format                           : MPEG Video
Format version                   : Version 2
Format profile                   : Main@Main
Format settings, Matrix          : Default
Bit rate mode                    : Variable
Bit rate                         : 8 602 Kbps
Width                            : 720 pixels
Height                           : 480 pixels
Display aspect ratio             : 2.35
Frame rate                       : 29.970 fps
Standard                         : NTSC
Colorimetry                      : 4:2:0
Bits/(Pixel*Frame)               : 0.830
MKV:
Code: [Select]
Video
ID                               : 1
Format                           : MPEG Video
Format version                   : Version 2
Format profile                   : Main@Main
Format settings, Matrix          : Default
Codec ID                         : V_MPEG2
Codec ID/Info                    : MPEG 1 or 2 Video
Duration                         : 1h 32mn
Bit rate mode                    : Variable
Bit rate                         : 5 206 Kbps
Nominal bit rate                 : 8 602 Kbps
Width                            : 720 pixels
Height                           : 480 pixels
Display aspect ratio             : 16/9
Frame rate                       : 29.970 fps
Standard                         : NTSC
Colorimetry                      : 4:2:0
Scan type                        : Progressive
Scan order                       : Top Field First
Bits/(Pixel*Frame)               : 0.503

Playing each in mplayer:
VOB:
Code: [Select]
Playing Monsters Inc.vob.
MPEG-PS file format detected.
VIDEO:  MPEG2  720x480  (aspect 3)  29.970 fps  8601.6 kbps (1075.2 kbyte/s)
========================================================================== 
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough                 
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)       
Could not find matching colorspace - retrying with -vf scale...             
Opening video filter: [scale]                                               
The selected video_out device is incompatible with this codec.             
Try appending the scale filter to your filter list,                         
e.g. -vf spp,scale instead of -vf spp.                                     
VDecoder init failed :(                                                     
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family           
Unsupported PixelFormat -1                                                 
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
Starting playback...
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 854x480 Planar YV12  [zoom]

Code: [Select]
Playing Monsters Inc.mkv.
[mkv] Track ID 1: video (V_MPEG2), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Will play video track 1.                     
Matroska file format detected.                     
VIDEO:  [mpg2]  720x480  24bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough               
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)     
Could not find matching colorspace - retrying with -vf scale...           
Opening video filter: [scale]                                             
The selected video_out device is incompatible with this codec.           
Try appending the scale filter to your filter list,                       
e.g. -vf spp,scale instead of -vf spp.                                   
VDecoder init failed :(                                                   
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family         
Unsupported PixelFormat -1                                               
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
Starting playback...
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 854x480 Planar YV12  [zoom]

The mplayer windows are the same size for each during playback.

Any ideas on what's going on here? What setting/s is/are off? Hopefully something obviouos I'm just overlooking?

Running 1.02.07 firmware. Computer is Mandriva 2009.1.

thanks,
john



p.s. Unrelated but I also have to do a second mkvmerge in order to get audio in sync with video: mkvmerge -o Monsters-in_sync.mkv -y 2:400 Monsters-out_of_sync.mkv
400ms seems to be consistent among all my DVD->VOB->MKV so far. Any ideas on that on as well? Putting "-y" in my first mkvmerge apparently has no affect on the resulting file, and it's still out of sync by 400ms.