Author Topic: WDTV LIVE New Official Firmware Update 1.04.10_V  (Read 122323 times)

April 16, 2011, 02:30:31 PM
Reply #90

Stick

  • Newbie

  • Offline
  • *

  • 22
There is now another FW update on the official website, 1.04.31...... I don't see any mention of it here, but I'm interested to see if it really fixes all these problems people have been talking about.

April 16, 2011, 10:47:31 PM
Reply #91

Topdog

  • Newbie

  • Offline
  • *

  • 15
Done mine and all is still working OK...

April 22, 2011, 06:42:24 AM
Reply #92

TheShinobiChef

  • Newbie

  • Offline
  • *

  • 15
you can download video's from youtube with the website http://www.keepvid.com
it works great and even works for HD stuff!

May 01, 2011, 08:06:37 AM
Reply #93

nunupica

  • Newbie

  • Offline
  • *

  • 20
The latest firmware update (as of 4/6/11) is version 1.04.31. Why isn't this page being updated? Or are the changes between Firmware Update 1.04.10 and 1.04.31 minimal?

May 13, 2011, 03:41:43 AM
Reply #94

nunupica

  • Newbie

  • Offline
  • *

  • 20
Firmware update 1.05.04 released (5/12/2011).

Changelog:
Supports USB hard drives greater than 2TBs.
Resolved user interface brightness issue introduced with last release.
Resolved Hebrew subtitles not displaying correctly.
Resolved several Facebook user interface issues.
Resolved several Tunein user interface issues.
Resolved arrow keys on keyboard do not work in Network Setup.
Resolved Scrolling text is not smooth.

May 13, 2011, 04:21:01 PM
Reply #95

marlintrdg

  • Newbie

  • Offline
  • *

  • 3
Firmware update 1.05.04 released (5/12/2011).

Changelog:
Supports USB hard drives greater than 2TBs.
Resolved user interface brightness issue introduced with last release.
Resolved Hebrew subtitles not displaying correctly.
Resolved several Facebook user interface issues.
Resolved several Tunein user interface issues.
Resolved arrow keys on keyboard do not work in Network Setup.
Resolved Scrolling text is not smooth.
Does anyone know why every time theirs a new update stuff breaks or otherwise stops working?

One update, 2 updates ago, Live365 went nuts, fixed in the following update, that update some movies stop working in AVI format, Now this Update the MLK video files stop working, many more AVI video now say not supported and my WD 1.5TB USB hard-drive now says "cannot create media library. Please check your storage device", luckily after losing 3 1TB plus WD drives I have backups but the videos still won't play. Also the video no longer fills the whole screen.

Any ideas please?

Can we just not flash VLC media player and be done with it?

I think the WD live Plus is a brilliant idea and I realize its only 99.00 but I'd gladly pay 10 x's for something more stable and doesn't overheat all the time.

Update: Did another factory reset and deleted the ď.wd_tvĒ folder from my USB attached 1.5GB WD Hard Drive, that's resolved the  "cannot create media library. Please check your storage device", error.

But the MLK & many AVI files no longer play, the screen is still small and does not use the entire screen.

Still runs very hot and will cut off halfway through a movie and reboot. (I now have a cooling fan now at one end of the unit, this helps.)

I tried to RollBack to Version 1.04.22_V the last version to work reasonably well but it did not work.

This sucks... Please Help. :'(
« Last Edit: May 14, 2011, 04:43:23 AM by marlintrdg »

May 13, 2011, 05:09:08 PM
Reply #96

gilligan

  • Newbie

  • Offline
  • *

  • 1
I am also having the issue of the video no longer fitting the screen properly, after updating to 1.05.04.

I have it hooked up to an old TV via composite.  Now I have nice black bars on either side of my regular content, and a distorted picture.  Widescreen content might be somewhat distorted as well - it fits to the edges but I think ii is "taller" than it should be.

First time I've had trouble with a firmware update.

I could try putting it on my monitor with HDMI, just to see if it is messing up on a widescreen display or not.

May 14, 2011, 05:16:55 PM
Reply #97

simate

  • Newbie

  • Offline
  • *

  • 5
Since "upgrading" to 1.05.04 my WD TV Live has started to reboot when it feels like it.

Please test firmware upgrades properly before releasing them. If I want Beta software I'll ask for it, if I want a broken WD TV Live I'll smash it up myself, I don't need you to break it for me!

May 14, 2011, 11:34:34 PM
Reply #98

spazhead

  • Newbie

  • Offline
  • *

  • 7
I am also having the issue of the video no longer fitting the screen properly, after updating to 1.05.04.

I have it hooked up to an old TV via composite.  Now I have nice black bars on either side of my regular content, and a distorted picture.  Widescreen content might be somewhat distorted as well - it fits to the edges but I think ii is "taller" than it should be.

First time I've had trouble with a firmware update.

I could try putting it on my monitor with HDMI, just to see if it is messing up on a widescreen display or not.

Do a factory reset, solve the problem for me.

May 15, 2011, 05:55:03 AM
Reply #99

marlintrdg

  • Newbie

  • Offline
  • *

  • 3
I did the hard reset, (paper clip in the reset hole), and the software factory reset, all the problems remain.
Does anyone know how to do a rollback?

UPdate:
After many hours with Google, I found this post:

Re: Downgrade firmware. How?
Options
02-17-2010 12:29 PM


    Ronald wrote:

    I recently  downgraded the firmware of my WD TV Live Media player. The firmware 1.01.24 doesnít work with iso-files verry well so I decided to downgrade the firmware to 1.01.17.

      Follow the next steps:
      0. download the old firmware:  http://download.wdc.com/wdtv/wdtvlive_1.04.31_040511.zip (NOTE: I updated this link as it was hard to find)

       1.Use USB FLASH KEY from 64mb upto 2GB. I recommend upto 2GB but you could also use bigger ones but they using different adressing model this could be issue for some models.
   
    2.Format the USB FLASH key to FAT16 or FAT32 filesystem donít be lazzy and DONíT use NFTS for this case 1)use USB FORMATER 2)or any others formatting tools.
   
    3.Go to WDTV menu System→About there is version notice it you will need this number later.
     
    4.Unpack firmware package to USB FLASH KEY to root directory there have to be 2 files WDTV.BIN and WDTV.VER.
     
    5.Open with notepad or any textplain3) editor and change version in WDTV.VER to higher then you have in WDTV now if you donít change this new firmware will not detected as new one. Save the file.

    6.De-attach all USB devices from WDTV unplug power supply wait 5-10sec plug-in USB prepared USB FLASH KEY and plug-in power supply.
     
    7.Wait and donít reboot WDTV during flashing process

NOTE I added this bit: Pull your usb drive out AFTER it shows 1.04.31 as it going to show you it has a new update again ALSO if youíre connected to the internet it will want to upgrade again, just say no!!

This worked for me BUT I would be very careful you don't end up with a brick!!!

Don't blame me if you kill your device doing this please, you could of course wait a few months for the next upgrade to fix this upgrade.
« Last Edit: May 15, 2011, 10:55:52 AM by marlintrdg »

May 16, 2011, 09:53:08 PM
Reply #100

Topdog

  • Newbie

  • Offline
  • *

  • 15
Don't seem to have any problems with 1.05.04 as yet..
On the subject of Rollback, back some time ago I downloaded a copy of wdtvlive_rollback_ 1.02.21, comes in real handy if I need to go back to a previous version for ay reason..Might be worth a search and see if there are any Rollback versions around..

May 18, 2011, 04:00:40 AM
Reply #101

nunupica

  • Newbie

  • Offline
  • *

  • 20
After updating to 1.05.04, I also got the issue of the video no longer fitting the screen properly.
Even after a factory reset the problem continues.

May 18, 2011, 01:25:17 PM
Reply #102

simate

  • Newbie

  • Offline
  • *

  • 5
I forgot to mention that when you press the options button, the text below the on screen options is way off to the left on my tv now, it was fine before the update.

I'm going to either roll back the fw or go with B-Rad's fw, the only thing I don't like about B-Rad's fw is that the hdd's stay on all the time.

May 23, 2011, 12:23:31 PM
Reply #103

gab73

  • Newbie

  • Offline
  • *

  • 20

Same problem here with the options button during playback. Text under OSD is not only off, subtitle and audio selection is not working properly. Please, quick-fix it with the other unnecessary bugs, it's annoying and it worked perfectly in every other FW version since the first one. Otherwise good job, thanks.

June 01, 2011, 09:28:23 AM
Reply #104

msujdog

  • Newbie

  • Offline
  • *

  • 9
Having trouble with 1.05.04.  The player gets hung up playing any and all kinds of video, whether it's from YouTube, network, or attached USB drive.  I get the "thinking" circle endlessly.

I did a "reset to factory defaults" which worked for awhile, then the same problem the next time I turned on the machine.