Author Topic: Did a firmware upgrade brick my device (fixed)  (Read 5301 times)

August 03, 2009, 06:18:18 AM
Read 5301 times

mareg

  • Newbie

  • Offline
  • *

  • 7
Hi all.

I've been enjoying 3 full weeks of flawless WDTV awesomness.  :D

When I first receive my HDTV, I flashed the installed firmware (it was pretty old) with the version from the official website (1.02.07). Everything went fine.
This morning, I found out there was a new one (1.02.10) and there were a couple features that would improve my experience with the device.
So I went ahead and did the exact same sequence as with updating to 1.02.07. Everything was looking good until the WDTV went into a reboot (presumably to flash itself to 1.02.10). It went with the official WD logo.... and stayed there.

My innitial tought was that it was upgrading in "silent mode", so I let the logo stay on my screen for a full 15minutes !!! From that amount of time I knew something was up. I tried to stimulate something out of the device with the remote but it wasn't responding to that. Since nothing else seemed to work, I pulled the plug. I then waited a full 5min and plugged it back. Logo... logo. Just the damn logo. Tried the reset button. Tried AC out for 5min then plug back while holding reset (like for routers), logo.

My WDTV is now a glorified WD LOGO display box. I think the device might have bricked itself...
If anyone knows how I could unbrick it (if its even possible), please let me know. I don't want to RMA that thing as I use it everyday.  :'(
« Last Edit: August 04, 2009, 10:48:05 AM by jayallan »

August 03, 2009, 06:27:38 AM
Reply #1

mareg

  • Newbie

  • Offline
  • *

  • 7
Woah sorry to reply to my own thread with the answer to my problem. I innitially worked 2 hours on a solution before I wrote here to try and get some idea.

Well guess what, I just found out the solution myself ! :o

So I had forgoten to say, in my original post, that before plugging back the device, I had removed the memory key containing the firmware. I guess the device must have been in a state were it was trying to upgrade its firmware but it was nowhere to be found anymore. So just unpluggin and plugging it back with the firmware available made worked :)

Still, its very strange that it got stuck in the first place, with the memory key firmly in place. I wouldn't have removed it if everything worked as intended.

August 04, 2009, 10:47:44 AM
Reply #2

jayallan

  • Administrator
  • Hero Member

  • Offline
  • *****

  • 1175
    • Jay Allan Photo
WDTV LIVE with current official FW > HDMI > DVDO > Sony CRT Projector 150" 16/9 screen.  Toslink audio to Yamaha DTS receiver. No Network set up yet.