Author Topic: Audio Issues Optical to Onkyo Amp/Reciever  (Read 5385 times)

July 29, 2010, 07:33:13 AM
Read 5385 times

mctomas

  • Newbie

  • Offline
  • *

  • 1
Hello,

Yesterday I bought a WDTV Live, and I am somewhat happy, it plays my FLAC's without any problem and with great quality, and the picture is great playing 1080p without any problems or delays. Although I have som issues with the sound when playing certain video files...

Some dvd images, both .ISO and Video_TS VOB's, don't put out any sound at all, only high-volume-static noices. And when I play some .mkv there are no "voices-sound", like if that track is missing. Although the voices-soundtrack is somewhat hearable when I change my Onkyo Amp to "All Ch Stereo"

My problems... Are they Amplifier-related, or WDTV-related? And if they are Amplifier-related, what settings should I make on my Amp to make it right?

My setup is as following;

WDTV connected with HDMI directly to TV
Optical sound cable connected to Onkyo Amp
Sound option in WDTV set to Digital.

I am glad to recieve any answer so feel free to write whatever comes to mind, I am thankful for all the help I can get!

Regards

Martin

September 15, 2010, 07:23:44 PM
Reply #1

dejavu007

  • Newbie

  • Offline
  • *

  • 1
I am having a very similar problem. Most of the videos play well, both audio and video. Some of the MKV files though have no audio working. Wonder what the issue is. Would request WD to please look into this and sort it out in the next firmware upgrade. The other thing is some of the mp4 files I have do not play either.

September 16, 2010, 03:01:04 AM
Reply #2

Pangadaywalker

  • Sr. Member

  • Offline
  • ****

  • 349
I bet first in file. There is something wrong with the file.

And the MKV I am almost 100% sure it is the header compact.

Download the MKVToolNix and remove the header compression.

Search in the forum there is a lot of topics about it.

Then try the file again. Now for the ISO I really think it might be support from Live thing.

I never really used the ISO files so I can't really help there:
http://forum.wdlxtv.com/viewtopic.php?f=3&t=1036


Cheers.
My set:

April 01, 2011, 11:17:34 AM
Reply #3

calin1975

  • Newbie

  • Offline
  • *

  • 5
I'm having too the same pb with the lack of the voices with my WD TV LIVE optical out to a Harman Kardon avr-132 receiver
The ambiance music is somehow ok (maybe too much bass) but the voices are very very low.
Did you find a solution to this pb?

April 03, 2011, 08:44:33 AM
Reply #4

thepanoguy

  • Newbie

  • Offline
  • *

  • 40
The static noise is the high definition audio track. WD does not have a license to decode high definition audio via Toslink. The Toslink has an inherent design problem with too much bass. There is no cure; it is part of the original Toslink specifications. The other problems are related to 5.1 / 7.1 decoding. Some DSP chips cannot channel separate the digital audio properly from the WDTV Live box. Try using analogue audio out and let the amplifierís DSP do the channel separation.  The WDTV Live box analogue audio out is a lot cleaner audio signal to the WDTV Live box Toslink. Try the Corrs Unplugged DVD as an audio quality test.     

August 13, 2011, 05:08:27 AM
Reply #5

ibleedspeed

  • Jr. Member

  • Offline
  • **

  • 87
problem for me too! I have the wdtv connected through hdmi to the tv. and then toslink out from the tv to the audio receiver. its a wierd problem though. at first the audio works fine. but if i switch channels to another source on the tv when i come back to the wdtv it will not output audio ::) in fact changing pretty much anything on the tv results in no audio from the wdtv ::) to get audio back i have to power cycle the wdtv. which results in losing my place in the movie i was watching ::) and then if i try to ffwd back to my place it will only ffwd so far then the screen freezes ::) it wont play. if i hit stop it will go back to the main menu and then i try to play again and it freezes. so i have to power cycle again. and then i end up losing audio again ::).........lol I absolutely hate the wdtv. as soon as i can replace it with a better player i am going to throw it off  a very tall bridge then walk down to pee on it and mail it back to wd.  seriously this thing is the most unrefined piece of junk electronic device i have ever had the great displeasure to own. i use to recommend it to people and now i need to call them all apologize and beg for their forgiveness then commit sepuku to pay for my dishonor. do your selves a huge favor and get rid of this piece of crap asap.  I can respect what b-rad and everyone has done with the wdtv. but its time to move on to greener pastures. this site and all other related wdtv sites need to fade into obscurity. because lets face it the wdtv is the ford pinto of media players. seriously these sites are only duping more people into wasting money,time spent modding, and suffering needlessly from frustration. let it die already.

signed: militant wdtv hater......