Author Topic: "This file does not support trick mode"???I'm stumped...  (Read 11388 times)

June 13, 2010, 07:43:51 PM
Read 11388 times


  • Newbie

  • Offline
  • *

  • 2
Has anyone ever tried to fast forward a file and it won't, but instead a message comes up which says "this file does not support trick mode"? Does anyone know what this means, or why the file won't fast forward? It also won't continue the movie from where you left off if you stop playback. It's only happened to me two times now, the first time I just figured it was a faulty file, now it's happened again on a movie I just got. Any fixes or suggestions? Thanks.

June 13, 2010, 08:21:10 PM
Reply #1


  • Sr. Member

  • Offline
  • ****

  • 282
    • Tech Flaws - Things Can Only Get Better
Excessive FF in VOBs/ISOs occasionally locks up the LIVE so that you gotta disconnect power from the device. Never heard of trick mode though.

June 14, 2010, 02:51:54 AM
Reply #2


  • Jr. Member

  • Offline
  • **

  • 63
I've had that on a couple of movies. I can only assume its down to how its been converted from the original.

June 14, 2010, 03:11:12 AM
Reply #3


  • DeSpammer
  • Hero Member

  • Offline
  • ****

  • 1728
That's what trick mode is....FF, rewind, etc....

I had that once.  Can't remember the format of the movie now.  It wasn't a vob.  AMOF it wasn't anything out of the ordinary.  Could have been a AVI.
Windows 7 Ultimate with SP1
1.02.21 WDLXTV (Beta)
Linksys - WUSB600N USB Adapter
DLink - Dir-655 Router
Atheros - AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
XBMC - The Future of Television

October 05, 2010, 05:37:07 PM
Reply #4


  • Full Member

  • Offline
  • ***

  • 157
As RavRob says, that's what "trick mode" is, in the video world (dating way back to early video tape).

It's the ability to pause, fast forward, rewind... basically it's random-access into the video stream.

If the file has not been encoded to support trick mode, then there's nothing you can do to the WDTV or to the file to add trick mode functionality.  All you can do is make a whole new encode of the video stream with the proper sequence headers, to support trick mode.

Even some of the original VCD video files just had one sequence header at the beginning of the file, and thus had no trick mode capability.  You could just play them straight through.

The container (and even the video codec, essentially) are rather irrelevant.  If the video file doesn't have the correct sequence headers, then it loses random-access into the video stream.  A whole new stream with proper headers must be encoded.  It's not limited to one file type, per se.

March 14, 2011, 07:35:14 AM
Reply #5


  • Newbie

  • Offline
  • *

  • 3
Hi Guys.

I have this same problem but don't really buy the fact that this has anything to do with the way the film is encoded this must be a sw issue with the WDTV. My situation is this, I can play an .mkv file without proplems from a network share on my pc rewind, forward and search works 100%. When copying the same file to the WDTV HD rewind, fastforward and search dosn't work and also on when trying to ff etc sometimes the message about "This file does not support trick mode". Im all other players I have tried that support .mkv including A.C.Ryan, pocorn Hour, PS3 Media Server etc there are no issues so seems to be a WDTV SW problem. Any chance we get to see a fix for this ? Would really appreciate it

June 07, 2011, 05:36:20 AM
Reply #6


  • Newbie

  • Offline
  • *

  • 1
possible, need to remux- easy!

hi, i had the same thing as described in first post. i remuxed the mkv and now its playable.
i used mkvtoolnix-unicode-4.8.0
i think you dont need to do settings, the resulting file should support trick mode
it works quite quickly, like 5 minutes

July 26, 2011, 08:26:28 PM
Reply #7


  • Newbie

  • Offline
  • *

  • 8
thought i would chime in... yes.. remuxing the file would fix the file. but i takes me hours on my dual core 3ghz pc....

August 22, 2015, 10:12:55 PM
Reply #8


  • Newbie

  • Offline
  • *

  • 2
I know this is an old post, but lately I ve been having this problem more and more on MKV files playing in my WDTV, specially with YIFY sourced files.

The simptoms are:
The file starts playing normally.
But if you want to do fast forward or rewind on the file the WDTV player displays: "Trick Mode Not Supported" and play is interrupted.
Also, you cannot use the skip to desired time option.
And you have to start again from the begining.

I tried several methods to fix the files, one of them was Meteorite, but still after using this program some files still have the problem.

I thoght that maybe recent versions of MKVmerge were causing this problem since old MKV muxed files work OK and then downloaded an old version of MKVmerge but that didnīt work.

What worked in the end was: dropping the MKV file in MKVtoolnix GUI, select the video track and check the Fix bitstream timing info option.
Also, to avoid WDTV play compatibility problems, I checked the Disable additional lossless compression for all track types option in the Merging section of the Preferences.
After remuxing, the file can do rev and ff and also you can skip to your chosen play time.

I hope this can work for you also.
« Last Edit: August 22, 2015, 10:22:58 PM by Ralfberserk »

October 18, 2015, 12:26:33 PM
Reply #9


  • Newbie

  • Offline
  • *

  • 2
I found another setting that enabled the trick mode in WDTV:

So far I tried this  and enabled: Fix bitstream timing info; with several .mp4 files that after remux didnīt fast forward or rewind. After remuxing the original files (not re remux a mkv) everything played OK in my WDTV:

I will paste this here:
There were two recent additions to the Matroska specs, CueDuration and CueRelativePosition. They're meant to make the life of demuxers easier by providing additional information about the exact location and duration of certain elements in their respective clusters via the index (the "cues" in Matroska terms). As has been said those elements are additional elements, and they're purely optional; both playback and seeking can work just fine without them.

The Matroska specs intention is for players to simply skip elements they don't know if they encounter any. Unfortunately not all players do that.

The symptoms of a player having problems with those two additions include not being able to seek at all in a file or only with very long wait times inbetween, especially with seeks to far-away positions; problems with fast-forwarding or rewinding; or even the player not playing the file in the first place.

You can prevent mkvmerge from writing these two elements with the command line options "--engage no_cue_duration,no_cue_relative_position". In mmg you can add those options via the "Add command line options" dialog from the "Muxing" menu. Select the two options "--engage no_cue_duration" and "--engage no_cue_relative_position" and press the "Add" button for each.

this is a link to the source: