WDTV 1 Forum Groups > Homebrew / Custom Firmware

*experimental* wireless usb support package

(1/111) > >>

Zorander:
Here's a first attempt at a wireless usb network support package.

wireless-mod.app.bin (0.0.1)

It attempts to load the usb network driver for the following chipsets:
[*]Zydas 1201 (11b)
[*]Zydas 1211/1211b
[*]RaLink 2870
[*]RaLink rt73
[*]Atheros Otus
[/list]

The normal net.config options apply (dhcp/static IP).  The drivers should default to searching for the best open wireless point.

You can try adding specific configuration into net.config such as:

  iwconfig $MDEV essid MyHomeNetwork

No idea if wpa_supplicant works. (it's probably tied to the Otus driver explicitly)

This app.bin may work on older ext3-boot firmwares, as well as WDLXTV firmware releases. (UNTESTED)

waterlooscp:
Hello Zorander,

If I use encryption i have to put like this?

wconfig $MDEV essid MyHomeNetwork key xxxx-xxxx-x

Sorry but I'm Linux newbie.

Thanks for the package.

Regards

waterlooscp

b-rad.cc:
I have a rt2500 wireless adapter to play with. I compiled the kernel modules a while ago, so I'll see about getting WDLXTV compatible with this package very soon.

Zorander:
wireless-mod experimental support package 0.0.2

Uploaded here

This version (attempts to) fix the /etc/mdev.conf for all the funky device names that they like to use.

Here's the list of network device names:
arusb_lnx uses ath0
rt2870sta uses ra0
rt73 uses rausb0
zd1201 uses wlan0
and, not to be outdone, zd1211b uses eth1 (or eth0)

I even threw in usb0 in case any of the regular usb network devices uses it (I think one or two of the usb-usb cables use usb0 as a device name)

b-rad.cc:  You need to update the /etc/mdev.conf in your distro to this:

--- Code: ---# /etc/mdev.conf
eth[01] 0:0 755 *(/etc/hotplug/net.agent)
sd[a-z].* 0:0 755 @(/etc/hotplug/disk.agent)
sr[0-9] 0:0 0 *(/etc/hotplug/cd.agent)
#
# wireless drivers like to use strange device names
usb0    0:0 755 *(/etc/hotplug/net.agent)
ra0     0:0 755 *(/etc/hotplug/net.agent)
rausb0  0:0 755 *(/etc/hotplug/net.agent)
ath0    0:0 755 *(/etc/hotplug/net.agent)
vlan0   0:0 755 *(/etc/hotplug/net.agent)
--- End code ---
(this is required since WDLXTV is perma-flashed, including the /etc directory where mdev resides, and therefore read only)

shadow:
1st, thanks for the rt73 port on wdtv!!

I have a D-link DWA-110 wireless adapter (rt73 chipset), and installed the 8.7.2 and wireless-mod 0.0.2.

Apparently the kernel module does not detect the device, as follows:

 - Messages.txt during boot:
wdtv user.notice root:  [07d1:3c07] 1-1( 2.00,480m) 802.11 bg WLAN
(...)
wdtv user.info kernel: usbcore: registered new driver rt73
no further mention of rt73 nor WLAN

 - lsusb -v shows:
Displaying detected USB devices...
 [07d1:3c07] 1-1( 2.00,480m) 802.11 bg WLAN
 [0781:5203] 1-2( 2.00,480m) Flash Memory/200524446007F5F2E8BA
 [0000:0000] usb1( 2.00,480m) TangoX USB 2.0/tangox-ehci-hcd
 [0000:0000] usb2( 1.10,12m) USB Host Controller/TANGOX OHCI

The ifconfig and /proc/net/dev shows only the "lo" interface.
iwconfig shows no interfaces.

Tried to force load of rt73 on net.config, or others things...  but none worked.

If I unplug the wireless dongle and plug it again, the message.txt shows only:
wdtv user.info kernel: usb 1-1: USB disconnect, address 2
wdtv user.info kernel: usb 1-1: new high speed USB device using tangox-ehci-hcd and address 4

Any Ideas?

Navigation

[0] Message Index

[#] Next page

Go to full version