Author Topic: BUG 1.02.07 DTS music only files go crazy after 4:09  (Read 2618 times)

May 01, 2009, 04:33:10 AM
Read 2618 times

LuisGC

  • Newbie

  • Offline
  • *

  • 3
I've got some DTS music albums which WDTV is able to decode properly (as long as they're in a matroska container, if they're not you just hear the music garbled).

In both firmware 1.02.06 and 1.02.07,  everything is playing OK, BUT as soon as the song reaches aprox 4:09 of continuous play, the sound gets garbled. I'm able to fix it by pressing pause/unpause but it's really annoying.

In firmware 1.01.01 it was OK, never tested on the others.

Here's mediainfo for one of the files, though it happens with any dts file that has more than 4:09 time length:
Code: [Select]
*** MediaInfo Mac // Plain text file report
2009-05-01 14:31:46 +0200
Information for File: 01 harmony korine.mka

General / Container Stream # 1
Total Audio Streams for this File -> 1
Audio Codecs Used -> DTS
File Format -> Matroska
Play Time -> 5mn 9s
Total File Size -> 55.7 MiB
Total Stream BitRate -> 1 511 Kbps
Encoded with -> mkvmerge v2.3.0 ('Freak U') built on Sep  9 2008 17:43:22
Encoding Library -> libebml v0.7.8 + libmatroska v0.8.1
Audio Stream # 1
Codec -> DTS
Codec (FourCC) -> A_DTS
Audio Stream Length -> 5mn 9s 77ms
Audio Stream BitRate -> 1 536 Kbps
Audio Stream BitRate Mode -> CBR
Number of Audio Channels -> 6
Audio Channel's Positions -> Front: L C R, Surround: L R, LFE
Sampling Rate -> 48.0 KHz
Bit Depth -> 24 bits

May 28, 2009, 06:25:54 AM
Reply #1

LuisGC

  • Newbie

  • Offline
  • *

  • 3
Still there on 1.02.08.

Can anyone else verify this on their WD TV?
Just play a DTS music file for more than 4:09 straight and see if it plays OK all the way.

On a related note, now the music doesn't need to be in a matroska container. The DTS wav file will play directly. Cool.

June 04, 2009, 01:12:45 AM
Reply #2

DerFranz

  • Newbie

  • Offline
  • *

  • 6
I would like to verify it, but DTS playback is not working here. I have some DTS coded WAV files but they are not played, no matter of the extension (.DTS, .WAV).

How did you manage to play it?

June 13, 2009, 05:16:21 AM
Reply #3

LuisGC

  • Newbie

  • Offline
  • *

  • 3
As of firmware v1.02.08 your dts files (with .wav extension) should play fine.
However, if you have a previous version you need to put the dts files in a matroska container.
Just rename your .wav file to .dts and then use mkvmerge from mkvtoolnix to put it in a matroska container.

June 15, 2009, 04:59:12 AM
Reply #4

DerFranz

  • Newbie

  • Offline
  • *

  • 6
Can NOT confirm it. All my DTS files are playing fine from beginning to end. I used .WAV as extension btw and FW1.02.08.

June 24, 2009, 06:47:07 PM
Reply #5

wang2222xiao

  • Newbie

  • Offline
  • *

  • 7
I suffered same problem to play mka with DTS audio. it's snatch from 4:09, and resumes after 4:30.
my firmware is 1.02.07. Hope WD TV team could see this topic and fix soon.

May 13, 2010, 01:52:52 PM
Reply #6

remark3d

  • Newbie

  • Offline
  • *

  • 5
I have same proble dts in mka, when I am playing this container, about 4 min crash sound and after some while continue corectly on. If I pause in this moment and immediately push play, all is ok, but again after 4min crash is again. Somewhere i red that short rewind help. Anyway as I can see, it is not only my problem. Is some plan search this bug an correct it in a new version of future firmware? i am using last 1.03 firmware...