Author Topic: ISSUE: Empty NFS mounted folder  (Read 8825 times)

March 30, 2009, 11:32:14 AM
Reply #15

Hades666

  • Newbie

  • Offline
  • *

  • 35
Dunno why, but changing the my guest accout "originaly named Gæst" to Guest did the trick for me.
NFS works like a charm now.

Nice news, iŽll try it after work... hope it work for me too...

:( no luck... i give up... iŽll try again someday ;)

March 31, 2009, 07:34:18 AM
Reply #16

Hades666

  • Newbie

  • Offline
  • *

  • 35
finally it works!!!!!
I have to use Hanewin NFS server.... now i can stream from my computer...

:)

March 31, 2009, 07:59:01 AM
Reply #17

Hades666

  • Newbie

  • Offline
  • *

  • 35
finally it works!!!!!
I have to use Hanewin NFS server.... now i can stream from my computer...

:)

Adapter: EDUP wireless USB Adapter 11g (atheros chipset).

Speed in NFS with muzzy.avi (162.156.544 bytes):

# time cat muzzy.avi > /dev/null
real 10m 22.36s
user 0m 0.26s
sys 0m 8.23s

15.8 Mbps

:)

April 01, 2009, 01:20:19 PM
Reply #18

Starstream

  • Jr. Member

  • Offline
  • **

  • 64
Anyone ever get a synology NAS to work, I have a 209+ unit which supports NFS but the folders all show up as empty, cant figure it out.

April 01, 2009, 01:31:09 PM
Reply #19

b-rad.cc

  • Hero Member

  • Offline
  • *****

  • 833
  • Personal Text
    FW Hacker
    • B-RAD
Anyone ever get a synology NAS to work, I have a 209+ unit which supports NFS but the folders all show up as empty, cant figure it out.

I imagine you've set up /etc/exports correctly on your synology to allow your wdtv's ip to mounts its nfs...right?

April 02, 2009, 04:12:40 AM
Reply #20

Starstream

  • Jr. Member

  • Offline
  • **

  • 64
Anyone ever get a synology NAS to work, I have a 209+ unit which supports NFS but the folders all show up as empty, cant figure it out.

I imagine you've set up /etc/exports correctly on your synology to allow your wdtv's ip to mounts its nfs...right?

All you can configure in the synology are found under NFS privileges and I set those to allow any IP access, read/write enabled and the last setting is root squash with three options
no mapping
map to guest
map to admin

Guest and admin both have read/write regular privileges on the folder.

No matter which one I pick it sees the folders no problem but they all show up empty. Synologys forum is filled with people having problems with NFS in general so I'm guessing the problem is on their end. Cifs works fine but of course their is the speed problem as does UPnP but annoyingly Synology don't support MKV in their UPnP server.

April 05, 2009, 11:57:01 PM
Reply #21

Starstream

  • Jr. Member

  • Offline
  • **

  • 64
After some further testing I managed to get NFS working with the Synology NAS here is how for anyone interested;

1) Make sure jumbo frames are disabled on your Synology NAS
2) You must have media library mode enabled on the WDTV

In Synology management UI
1) Enable NFS.
2) Go to shared folders - privileges setup and for the folder you wish to share enable the guest account under local users to have read/write access.
3) Go to NFS privileges and select;
Hostname or IP = *
Privilege = Read/Write
Root Squash = Map to guest
4) With the changes made reboot your NAS.
5) In your WDTV NET.mounts file add the line (video being the name of the shared folder with the privileges set)
xmount 192.168.1.100:/volume1/video videos nfs

Now reboot your WDTV and if all goes well you should able to see and read videos from the NFS share.

April 19, 2009, 01:32:08 AM
Reply #22

richking

  • Newbie

  • Offline
  • *

  • 3
Hi Starstream,

I am intending to use the same setup as you, I have a Synology DS209+.

Just curious as to what else you used for connectivity? wireless or wired adapter, which model?

Are you connected directly to your router or are you using a wireless bridge, or Powerline adapters or some other configuration.

Cheers.


After some further testing I managed to get NFS working with the Synology NAS here is how for anyone interested;

1) Make sure jumbo frames are disabled on your Synology NAS
2) You must have media library mode enabled on the WDTV

In Synology management UI
1) Enable NFS.
2) Go to shared folders - privileges setup and for the folder you wish to share enable the guest account under local users to have read/write access.
3) Go to NFS privileges and select;
Hostname or IP = *
Privilege = Read/Write
Root Squash = Map to guest
4) With the changes made reboot your NAS.
5) In your WDTV NET.mounts file add the line (video being the name of the shared folder with the privileges set)
xmount 192.168.1.100:/volume1/video videos nfs

Now reboot your WDTV and if all goes well you should able to see and read videos from the NFS share.