Author Topic: ISSUE: Empty NFS mounted folder  (Read 8892 times)

March 27, 2009, 02:57:31 AM
Read 8892 times

3dxr

  • Global Moderator
  • Sr. Member

  • Offline
  • *****

  • 411
All about default mounting NFS and Empty Folder.

March 28, 2009, 01:19:29 AM
Reply #1

IzNoGooD

  • Newbie

  • Offline
  • *

  • 27
Hey, is there a solution to this problem?

I'm using NFS on XP pro, firmware "ext3 boot release 0.8.7.2".
I obtain an IP address without any problems, but the folder is empty.  :-\

March 28, 2009, 02:23:34 PM
Reply #2

gothi

  • Newbie

  • Offline
  • *

  • 16
I get this error when I have Media Library enabled, disabling it allows me to use NFS shares fine

March 28, 2009, 02:40:48 PM
Reply #3

3dxr

  • Global Moderator
  • Sr. Member

  • Offline
  • *****

  • 411

March 28, 2009, 02:59:30 PM
Reply #4

gothi

  • Newbie

  • Offline
  • *

  • 16

Here is Simple HOWTO

Not sure what part of that page is meant to relate to the issue 3dxr?  NFS works fine for me as long as Media Library is disabled, am I missing a way to get it working with it enabled?

March 28, 2009, 03:50:40 PM
Reply #5

IzNoGooD

  • Newbie

  • Offline
  • *

  • 27
Posted by vladimir7 @ AVS Forum
Quote
Right click on start menu, and go to explore.
Expand My Network Places
Expand Entire Network (you may need to refresh if you don't see it. Hit F5 to do so)
Expand NFS Network
Expand Default Lan
You should now see your computer.. Expand it, and you should see your shared folders. Open it to see if you see your files.
If the folder is empty, and you cannot see any files you need to add a password to your account. (Go to control panel, User Accounts, Click on your account, change password).

My answer.
Quote
Followed your NFS guide, but still end up with empty folder in "Default Lan ~User ~ test_folder, when checking in windows.
I also tried suggested step with password on my windows user.

Any tips?

Just to inform your guys about my current problem.

March 29, 2009, 07:55:28 AM
Reply #6

Hades666

  • Newbie

  • Offline
  • *

  • 35
Posted by vladimir7 @ AVS Forum
Quote
Right click on start menu, and go to explore.
Expand My Network Places
Expand Entire Network (you may need to refresh if you don't see it. Hit F5 to do so)
Expand NFS Network
Expand Default Lan
You should now see your computer.. Expand it, and you should see your shared folders. Open it to see if you see your files.
If the folder is empty, and you cannot see any files you need to add a password to your account. (Go to control panel, User Accounts, Click on your account, change password).

My answer.
Quote
Followed your NFS guide, but still end up with empty folder in "Default Lan ~User ~ test_folder, when checking in windows.
I also tried suggested step with password on my windows user.

Any tips?

Just to inform your guys about my current problem.

I´m having exactly the same issue... try with password but nothing...

someone has any idea?

thanks

March 29, 2009, 08:11:13 AM
Reply #7

gothi

  • Newbie

  • Offline
  • *

  • 16
I assume you've both tried turning Media Library to Off?

March 29, 2009, 11:57:18 AM
Reply #8

IzNoGooD

  • Newbie

  • Offline
  • *

  • 27
I assume you've both tried turning Media Library to Off?
Been there done that  :-\
Now I am using windows shares, but it has very limited bandwidth, like wiki says. :(

March 29, 2009, 02:03:03 PM
Reply #9

gothi

  • Newbie

  • Offline
  • *

  • 16
I assume you've both tried turning Media Library to Off?
Been there done that  :-\
Now I am using windows shares, but it has very limited bandwidth, like wiki says. :(


I saw your maps over at AVSForum, you don't have the PC Administrator account mapped to root in the user maps, could this an issue?

March 29, 2009, 02:47:25 PM
Reply #10

IzNoGooD

  • Newbie

  • Offline
  • *

  • 27
I saw your maps over at AVSForum, you don't have the PC Administrator account mapped to root in the user maps, could this an issue?
[/quote]
Could it be that simple, will definitely try changing user maps.
But what about the guest account, it seems like every guide about setting up NFS states that it should be guest under user maps ?

March 29, 2009, 05:06:02 PM
Reply #11

Zorander

  • Newbie

  • Offline
  • *

  • 36
I saw your maps over at AVSForum, you don't have the PC Administrator account mapped to root in the user maps, could this an issue?
Could it be that simple, will definitely try changing user maps.
But what about the guest account, it seems like every guide about setting up NFS states that it should be guest under user maps ?
[/quote]
The windows Guest account should be mapped to the -2/undefined unix user.  It seemed to be required at least on my setup.

(the -2 user should be mapped SOMEWHERE at least....)

March 29, 2009, 06:59:49 PM
Reply #12

IzNoGooD

  • Newbie

  • Offline
  • *

  • 27
Thanks Zorander..

I've activated the user account again, i changed the name Gæst to Guest..

Gonna report back later :D

March 29, 2009, 09:31:58 PM
Reply #13

IzNoGooD

  • Newbie

  • Offline
  • *

  • 27
Dunno why, but changing the my guest accout "originaly named Gæst" to Guest did the trick for me.
NFS works like a charm now.

March 30, 2009, 12:34:29 AM
Reply #14

Hades666

  • Newbie

  • Offline
  • *

  • 35
Dunno why, but changing the my guest accout "originaly named Gæst" to Guest did the trick for me.
NFS works like a charm now.

Nice news, i´ll try it after work... hope it work for me too...