Author Topic: Can't copy files larger than ~250 MB - master browser related?  (Read 3580 times)

March 18, 2010, 04:47:57 AM
Read 3580 times

4r0m4s0pp

  • Newbie

  • Offline
  • *

  • 9
I decided to rewrite this whole post in order to maybe get some answers..

My network consists of this:
192.168.1.1 - NetGear WNDR3300 router
192.168.1.2 - My computer, Windows XP
192.168.1.3 - My cell phone, Nokia E65
192.168.1.4 - My girlfriend's computer, Windows 7
192.168.1.5 - My girlfriend's phone, HTC Hero
192.168.1.6 - WDTV Live, when using Linksys WUSB600N
192.168.1.7 - WDTV Live, when using cable/wire

The USB attached to WDTV Live is a SanDisk Cruzer 16GB. I have also used the Corsair Mini Voyager 16GB. Both FAT32.

I got the WDTV Live a few days before I got the WUSB600N. When I got it I updated WDTV Live to firmware 1.01.24. I successfully copied files of all sizes to and from WDTV by browsing \\192.168.1.6 with Windows Explorer on my computer with Windows XP. My girlfriend could not copy files to the WDTV from her computer with Windows 7.

Then I got some problems on my computer, unrelated to WDTV. I had to send the SSD I had Windows XP installed on back, because it was faulty, in order to get a new one. The 7-10 days I was without Windows XP, I used some linux version called "Slax" on my computer, which I booted from a USB memory stick. Using this I could copy files of all sizes to and from WDTV Live. My girlfriend still could not copy files to WDTV using Windows 7.

When I got my new SSD, I installed Windows XP. But now the real problems started. Neither me, nor my girlfriend could copy files to the WDTV Live. At first I believed that linux had changed the owner/permissions of the files. But now I don't think that's the case anyways.

I currently have the newest prerelease firmware (1.02.19) on my WDTV Live.

Let's say I try to copy one file of 550 MB - using WLAN or wired. It always crashes with this message:
Code: [Select]
Error Copying File or Folder
Cannot copy _filename_: The specified network name is no longer available.
When I click OK, the WDTV Live network folder is really avaiable, and the file I tried to copy is listed - but with a size of around 250 MB. If I refresh, the file size seem to be increasing steadily, with like 2 MB/s. But according to the software "DU Meter" which log my network traffic, no data were copied at all. If I try to play the file, it never works, I assume it's unplayable because it has no real contents.

But I can successfully copy multiple files of sizes less than 250 MB. Yesterday I copied 20 files, each of 180 MB, at the same time - using WLAN. Not one by one. No errors, no unplayable files. Today I copied two files of 180 MB using cable. See the graph from "DU Meter" below. The maximum value of the graph is like 4,5 - 5 MB/s. I'd say it takes a pretty long break in between the copying of the two files - although I copied them at the same time.

I feel I've tried everything:
  • restarting router
  • reset WDTV to factory defaults
  • changed USB memory stick
  • reformat USB stick
  • using cable instead of wireless
  • changing workgroup on all computer to something else than WORKGROUP
  • added username/password to the WDTV share in the newest prerelease firmware

Why is this happening? Could it be master browser related? How can I avoid it? How can I get it to accept large files from both me and my girlfriend, or at least just me, as it did in the beginning?


EDIT: all the failed files have a "date modified" of 01.01.2000, or 02.01.2000. The same with folders I make. Could this have anything to do with it?
« Last Edit: March 22, 2010, 01:39:48 AM by 4r0m4s0pp »

April 07, 2010, 08:23:34 AM
Reply #1

4r0m4s0pp

  • Newbie

  • Offline
  • *

  • 9
Nobody have a slightest idea what's the problem, or how to fix/avoid it?

April 07, 2010, 09:55:44 AM
Reply #2

RavRob

  • DeSpammer
  • Hero Member

  • Offline
  • ****

  • 1728
Try and log in to your router and revoke the IP for the WDTV Live.  Then on the WDTV Live do a factory reset (again).  Then redo your connection.  It might have changed IP with your Linux.

Worth a try. 
Windows 7 Ultimate with SP1
WDTV Live
1.02.21 WDLXTV 0.5.1.4 (Beta)
Linksys - WUSB600N USB Adapter
DLink - Dir-655 Router
Atheros - AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
XBMC - The Future of Television

April 09, 2010, 02:04:24 PM
Reply #3

s3verian

  • Newbie

  • Offline
  • *

  • 6
For what it's worth, I see the exact same issue with the latest b-rad firmware.  If I directly attach the USB HD to another win7 computer, I can copy large files from another win7 PC at around 10 MB/s across a wireless N connection.  Plug it back into the wdtv, and it's never able to calculate the time to transfer and eventually bombs out (wired or wireless via a wrt610n).  Though as you mentioned, a background file transfer seems to continue.

I have 2 external USB HD's - a 1.5 TB and a 2.0 TB, they both are slow formatted (by win7) as NTFS.  The files I'm transferring are several gigs in size.

May 28, 2010, 12:02:32 PM
Reply #4

4r0m4s0pp

  • Newbie

  • Offline
  • *

  • 9
It kinda looks like it works now. All I had to do was format the USB stick as NTFS instead of FAT32! Why didn't I try that before?!  :P

July 04, 2010, 02:32:45 AM
Reply #5

sTu_Deimus

  • Newbie

  • Offline
  • *

  • 12
Hate to say it 4r0m4s0pp, but I wish it hadn't started working for you... ;)

'cause I still have the same problem, and your fix won't work for me  :(  - driving me nuts  :'(.

- Same result whether from WinXP or Win7 - two different machines.
- Can transfer smaller files... of the order of 100's of MB. Only getting stuck with larger ones being transferred recently - around 4.xGB.
- Can copy no probs between the two computers.
- Can load onto USB HDD no probs when connected direct via USB.
- I also can immediately browse the share once this failure occurs - it seems to be the copy operation that is broken, rather then the share itself.
- All machines on 100Mbit (or better) LAN.

I am running 1.02.21.


« Last Edit: July 04, 2010, 02:51:53 AM by sTu_Deimus »