Author Topic: WDLXTV_G2 - WIFI ZYDAS 1201 /1211 / 1211B - Successful Integration - Working!  (Read 15748 times)

March 17, 2010, 04:56:26 PM
Reply #15

d3udp

  • Newbie

  • Offline
  • *

  • 10
b-rad.cc,

I noticed that you echoed mdev as the hotplug device in your init although I didn't know at which stage it was being hijacked and removed as the hotplug device. Now that you mention it, it makes sense and therefore might not be needed in my init script. As for the modules.dep thank for mentionning I didn't noticed that you where cat'in it within crazymount. Also keep in mind that I was debugging the ZYDAS modules once the firmware was booted. Therefore it totally made sense for me to add mdev as the hotplug device and indeed it was why the module firmware werent loading at first...

As for S90net.mount I think it's fine where it is in the staging but net.config get's called too early for wireless or ethernet app.bin package. It's not really starting too early but keeping the net.config simple as possible without having tons of unknown init shell script line is the best for the firmware users ... Another idea is that the net.agent would be reviewed to support wpa_supplicant since iwpriv is incompatible with ZYDAS. Also, I haven't been able to really have a smooth static IP assignement...

If you are to add theses ZYDAS drivers into the next build of WDLXTV_G2 please don't forget to replace the Wireless Tools as well since I've compiled the latest v29 and are required by the driver. The WirelessTools v16 currently in place in 0.4.8.1 are outdated and don't function well with it.

I am glad you want to integrate the zydas modules into your next build. Keep up your good work and keep in mind I just wanted to have my ZYDAS working on Gen2 I served myself for myself and now sharing it out loud  ;)

« Last Edit: March 17, 2010, 05:25:18 PM by d3udp »

March 17, 2010, 05:29:13 PM
Reply #16

b-rad.cc

  • Hero Member

  • Offline
  • *****

  • 833
  • Personal Text
    FW Hacker
    • B-RAD
i'm unsure anymore how many times I've told people that if they want something done &/or included the best way is to do it themselves. ;)

lame that zydas doesnt have 'set' private ioctl. that makes them the only adapters that needs wpa_supplicant :-\

wireless tools 31 is included in my current dev version.

March 18, 2010, 10:44:46 AM
Reply #17

cybercam

  • Newbie

  • Offline
  • *

  • 8
I got this message:
zd1211rw 1-1:1.0: RF UW2453_RF 0x9 is not supported

I found this possible explanation:
http://linuxwireless.org/en/users/Drivers/zd1211rw/RFtypes


...and HD does not turn off (app.bin active) How disactivate app.bin?

Any solution to RF?
« Last Edit: March 18, 2010, 10:59:56 AM by cybercam »

March 18, 2010, 10:53:09 AM
Reply #18

choekstr

  • Sr. Member

  • Offline
  • ****

  • 269
wireless tools 31 is included in my current dev version.

Nice.  Thanks for updating this.  I had wished for this a week or so ago!  Hopefully iwlist scan won't seg fault anymore.

Thanks for taking care of the minute details as well!
--
Chris

March 18, 2010, 05:48:54 PM
Reply #19

d3udp

  • Newbie

  • Offline
  • *

  • 10
I got this message:
zd1211rw 1-1:1.0: RF UW2453_RF 0x9 is not supported

I found this possible explanation:
http://linuxwireless.org/en/users/Drivers/zd1211rw/RFtypes


...and HD does not turn off (app.bin active) How disactivate app.bin?

Any solution to RF?

CyberCam,

The ZYDAS modules we're compiled for the WDLXTV firmware which runs under 2.6.22.19-19. The UW2453 RF support will be added to zd1211rw as of Linux 2.6.23.

Now that's what I call unlucky! ;(

March 19, 2010, 01:23:31 AM
Reply #20

cybercam

  • Newbie

  • Offline
  • *

  • 8
http://www.hfield.com/PDF/Linux.pdf

http://sourceforge.net/projects/zd1211/files/

So....I have to buy a new one? Or it is spected a new release of linux on WDTVG2?

lsusb: 0ace:1215 ZyDas WLA-54L

0ace:1215 is in your README file...
« Last Edit: March 19, 2010, 10:31:15 AM by cybercam »

May 20, 2010, 11:09:06 PM
Reply #21

mankidavu

  • Newbie

  • Offline
  • *

  • 32
Hi d3udp,

Thanks for this short tutorial and your efforts for the zydas support.

Somehow I'm not able to get it working with my WDTV G2 LX'ed with B-rad's latest version custom FW.(WDLXTV-G2-0.4.1.9)

Earlier I was not getting any response from my Belking adapter (LED constantly glowing).
But after loading your apps.bin,its blinking.So I think we've some progress here.

I'm posting the details from my Ubuntu.Does this work only with WDLXTV-G2-0.4.1.8 only?

This is the driver details (in ubuntu 10.04) for my Belkin adapter.
================================================
<snip>
root@aah-desktop:~# lsmod |grep -i zd12
zd1211rw 45983 0
mac80211 213439 1 zd1211rw
cfg80211 133664 2 zd1211rw,mac80211
root@aah-desktop:~# modinfo zd1211rw
filename: /lib/modules/2.6.33-02063303-generic/kernel/drivers/net/wireless/zd1211rw/zd1211rw.ko
firmware: zd1211/zd1211_uphr
firmware: zd1211/zd1211b_uphr
firmware: zd1211/zd1211_ub
firmware: zd1211/zd1211b_ub
firmware: zd1211/zd1211_ur
firmware: zd1211/zd1211b_ur
version: 1.0
author: Daniel Drake
author: Ulrich Kunitz
description: USB driver for devices with the ZD1211 chip.
license: GPL

dmesg:
[ 753.961907] usbcore: registered new interface driver zd1211rw

lsusb:
Bus 001 Device 002: ID 050d:705c Belkin Components 802.11bg
</snip>
=====================================================

IS there any log-saver app available for WDTV G2,so that I can get some clue about what wrong?

I've been struggling with another Linksys Wireless adapter.
Now the second (Belkin) too not working.

Details of Linksys WUSB54GC V3

=====================================================
root@aah-desktop:~# dmesg |grep -i rt2870
[ 2319.043696] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 2319.062304] usbcore: registered new interface driver rt2870
root@aah-desktop:~# lsusb|grep -i linksys
Bus 001 Device 004: ID 1737:0077 Linksys
root@aah-desktop:~# lsmod |grep -i rt2870
rt2870sta 412907 1
root@aah-desktop:~# modinfo rt2870sta
filename: /lib/modules/2.6.33-02063303-generic/kernel/drivers/staging/rt2870/rt2870sta.ko
version: 2.1.0.0
license: GPL
description: RT2870/RT3070 Wireless Lan Linux Driver
author: Paul Lin <paul_lin@ralinktech.com>

======================================================


Thanks in advance.

May 21, 2010, 01:46:05 AM
Reply #22

mankidavu

  • Newbie

  • Offline
  • *

  • 32
Just an update.

Tried by downgrading to old custom firmware.(WDLXTV-G2-0.4.1.8 -)

But still not getting any IP address.
From router side also, no new host appearing on DHCP. :(

Also tried with Open access and disabling the wpa related stuff.
No progress.

Still I can see the LED blinking on my Belkin 5D7050ak (ver 4122ak)
« Last Edit: May 21, 2010, 02:32:17 AM by mankidavu »

May 24, 2010, 08:33:49 AM
Reply #23

bahadirk

  • Newbie

  • Offline
  • *

  • 6
WDLXTV-G2-0.4.1.8 +zyxel g-202 (zydas 1211b)

not getting any ip address.
also  i checked from router side, no new mac adress

 of course tried with disabling security options !!!


just blinking led on my zyxel g202 wifi stick...pls help me

May 24, 2010, 10:51:09 AM
Reply #24

bahadirk

  • Newbie

  • Offline
  • *

  • 6

my access point has two section

 1.arp ( connected device list)
 2.dhcp (given ip adress list and expires time (count down from 24 hours))

when i started wdtv gen 2 

i checked form access point-->DHCP and i saw my zyxel g-202 mac adres and ip and counting down from 24 hour..

but i couldnt see in   access point-->arp section (connected device list)

i think DHCP gives ip adress but it cant connect to ap

any idea ???

May 24, 2010, 10:55:24 AM
Reply #25

bahadirk

  • Newbie

  • Offline
  • *

  • 6
by the way

my net.config file

!#/bin/sh
/apps/d3udp_ZYDAS_Wireless/etc/init.d/./d3udpwifi
#sleep 5
#DHCP=yes
sleep 5
ifconfig eth0 up
sleep 5
iwconfig eth0 ap 00:xx:xx:xx:xx essid DLink
sleep 5
DHCP=yes
sleep 5


i tried original file but couldnt see progress..i have modified like  this and see some progress ....

May 27, 2010, 05:51:33 AM
Reply #26

mankidavu

  • Newbie

  • Offline
  • *

  • 32
by the way

my net.config file

!#/bin/sh
/apps/d3udp_ZYDAS_Wireless/etc/init.d/./d3udpwifi
#sleep 5
#DHCP=yes
sleep 5
ifconfig eth0 up
sleep 5
iwconfig eth0 ap 00:xx:xx:xx:xx essid DLink
sleep 5
DHCP=yes
sleep 5


i tried original file but couldnt see progress..i have modified like  this and see some progress ....

Thanks a lot Bahadirk.
this new net.config helped me to login to my wdtv.

 :o

Code: [Select]
# uname -a
Linux 000000000000 2.6.22.19-19-4 #3 PREEMPT Tue Nov 10 20:04:25 CST 2009 mips GNU/Linux


df -k:
=====
Filesystem                Size      Used Available Use% Mounted on
/dev/sigmblockh          96.6M     96.6M         0 100% /
mdev                     47.3M         0     47.3M   0% /dev
none                     47.3M      1.1M     46.2M   2% /tmp
none                     47.3M      1.1M     46.2M   2% /etc/mdev.conf
/dev/loop0              122.0K      2.0K    120.0K   2% /tmp/static_config
none                     47.3M      1.1M     46.2M   2% /apps
/dev/sda1                 7.5G      3.2G      4.2G  43% /tmp/mnt/403B-B130
/dev/loop1                3.9M      1.3M      2.4M  35% /apps/d3udp_ZYDAS_Wireless
/dev/sigmblockh          96.6M     96.6M         0 100% /osd/image/villa_bg.jpg
/dev/sigmblockh          96.6M     96.6M         0 100% /osd/basic_browse_thumb_video.xml
/dev/sigmblockh          96.6M     96.6M         0 100% /osd/basic_browse.xml
/dev/sda1                 7.5G      3.2G      4.2G  43% /tmp/media/usb/USB2/403B-B130
#

in case if it helps anyone.

USB adapter-- Belkin 5D7050ak (ver 4122ak)
WDTV Gen 2 - Custom firmwared to B-rad's WDLXTV-G2-0.4.1.8

files on usb stick:
=============

1.net.config as above.
2.d3udp_ZYDAS_Wireless.app.bin

At present I connected with open security.
Will try WPA2 and other options and update here.

Thanks a lot for everyone helped me out.

I was almost going to give up after trying with 2 usb wireless adapters (RT2870 based+ zd1211 based belkin) +1 wired (DM9601 chipset based).



« Last Edit: May 27, 2010, 06:03:17 AM by mankidavu »

May 27, 2010, 09:29:33 AM
Reply #27

mankidavu

  • Newbie

  • Offline
  • *

  • 32
Here are my initial test results.

Windows CIFS working damn slow. I can see thumbnails,but once I try to open/play the file, wdtv gets non-responsive.(kind of hung,but I can access through telnet). I tried with movies,audio files, and even pics. Not working.

So didn't waste time on CIFS.

Started my ubuntu machine and setup NFS server.

Everything works excellent.
Tested audio,video xvid +AC3 files.

Now tested one full HD .m2ts file.
Its taking lots of time to start,and plays.
But there is a kind of buffering issue.(like online videos :) on slow speed) 

Will fine tune NFS to maximum performance soon.




May 28, 2010, 07:56:57 AM
Reply #28

mankidavu

  • Newbie

  • Offline
  • *

  • 32
Couldn't get WPA/WPA2 working yet.

Open+WEP working fine.

Tried WPA /WPA2 with follwing wpa_supplicant file:

Code: [Select]
#WPA-PSK

network={
ssid="my ssid"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk=""my key""
}

and a line to get it loaded,in net.config ,as:

wpa_supplicant -Dwext -ieth0 -c /tmp/mnt/FC1F-B05E/wpa_supplicant.conf

FC1F-B05E=usb stick sr. number.

May 31, 2010, 12:19:19 AM
Reply #29

mankidavu

  • Newbie

  • Offline
  • *

  • 32

my access point has two section

 1.arp ( connected device list)
 2.dhcp (given ip adress list and expires time (count down from 24 hours))

when i started wdtv gen 2 

i checked form access point-->DHCP and i saw my zyxel g-202 mac adres and ip and counting down from 24 hour..

but i couldnt see in   access point-->arp section (connected device list)

i think DHCP gives ip adress but it cant connect to ap

any idea ???

check the station info section on wireless (if your router gives details)

first it will show your wireless adapter's MAC there in associated section.
then there is one authenticated section..

first wdtv has to appear on that section correctly.
then only DHCP and arp come to picture.