Author Topic: Best format for home videos  (Read 11910 times)

March 13, 2010, 01:48:17 PM
Reply #15

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
I just noticed that the width and height of this final output file is 720x480. Shouldn't it be HD?

March 13, 2010, 02:02:12 PM
Reply #16

jayallan

  • Administrator
  • Hero Member

  • Offline
  • *****

  • 1175
    • Jay Allan Photo
Yeah, you are making standard def files.  

You want your output dimensions to be 1920x1080

MOD: Fixed the typo.  Forgot to take my meds!   :D
« Last Edit: March 13, 2010, 02:37:51 PM by jayallan »
WDTV LIVE with current official FW > HDMI > DVDO > Sony CRT Projector 150" 16/9 screen.  Toslink audio to Yamaha DTS receiver. No Network set up yet.

March 13, 2010, 02:46:18 PM
Reply #17

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
LOL! I thought I was seriously missing something for a second.

Just FYI, since my source material is m2t and is 1440x1080, how do I get it to output to 1920x1080? It won't let me resize it in meGUI. I'm pretty sure it's supposed to stretch properly when viewed on the TV (the source m2t file stretches and plays just fine) but the final mp4 file does not play correctly.

March 13, 2010, 02:58:58 PM
Reply #18

jayallan

  • Administrator
  • Hero Member

  • Offline
  • *****

  • 1175
    • Jay Allan Photo
It may not let you size up. That's weird though. Is it anamorphic 2.35 stretched up to 16/9?   Try resizing it to 1440x???  You will have to do the math but that will probably work.  Make sure you have no more than 4 ref frames. 

WDTV LIVE with current official FW > HDMI > DVDO > Sony CRT Projector 150" 16/9 screen.  Toslink audio to Yamaha DTS receiver. No Network set up yet.

March 13, 2010, 06:22:41 PM
Reply #19

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
I don't know. I might have to take a different route other than meGUI to make the file. I've rendered so many times the past 48 hour that I've lost count! I've tried many different settings and profiles and can't seem to shake either the non-stretched issue or the jumpy issue. The only other option is to just wrap up the uncompressed file, but then I'm looking at about 12GB per hour of video by my calculations, which is alot! But, I can't have the choppy, jumpy video!

March 14, 2010, 05:00:21 AM
Reply #20

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
OK, some small good news! I did finally find a profile to render the video so that it plays quite well! I used the "x264: Unrestricted 2pass HQ" as a base, and changed only the bitrate (to 8000) and the reference frames (to 7... per this thread: http://wdtvforum.com/main/index.php?topic=151.msg972#msg972 based on the 1440 settings). No stuttering and smooth playback.

However, still having the problem with the video not stretching to fit the screen. I can only guess this is a tagging issue? It is supposed to be putting it at 16:9, but instead it puts it at 4:3. Funny thing is, on a few of the settings if I set it to 16:9, then in the preview window I checkmark the 'show DAR' box it stretches it properly, but the final output does not produce this.

I thought someone might want to have a crack at this to see if they can figure out what I'm doing wrong. I've uploaded a 30 sec sample of the source file here:

http://www.jeditemplewarroom.com/videos/test30.m2t

March 14, 2010, 06:24:58 AM
Reply #21

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
Just an additional follow-up to this problem:

comparing the media info for the source file and the rendered mp4 file:

source:
Width                            : 1 440 pixels
Height                           : 1 080 pixels
Display aspect ratio             : 16:9

output:
Width                            : 1 424 pixels
Height                           : 1 072 pixels
Display aspect ratio             : 4:3

So, why in the heck is it changing this??? How can I get the output file to have the DAR of 16:9??

By the way, I manually edited the script file to resize to 1920 (the script editor keeps changing it back) and received a rendered file with this info:

Width                            : 1 920 pixels
Height                           : 1 080 pixels
Display aspect ratio             : 16:9

It 'fixes' the problem, but I'm physically resizing my pixels and I don't think I want to do that. I want it to stretch them naturally.

March 14, 2010, 10:06:51 AM
Reply #22

AyDee

  • Sr. Member

  • Offline
  • ****

  • 251
Hi, Chuck-
Have you switched to mp4 for rendering now? AC3 doesn't 'play nicely' with MP4 so you'll have to encode to AAC- 2ch or 6ch - 6ch is not supported by WDTV and with 2ch you lose 'surround'.  Can you use that profile with mkv?

Would you mind posting a small clip of the resulting file you are happiest with? I'm thinking there may be a fix...

March 14, 2010, 11:36:49 AM
Reply #23

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
I'm not sure what you mean by play nicely, but when I have muxed the mp4 and ac3 into an MKV they seem to play OK on the WD.

March 14, 2010, 01:47:25 PM
Reply #24

AyDee

  • Sr. Member

  • Offline
  • ****

  • 251
Wait, we aren't talking about the same thing... when I said "AC3 doesn't 'play nicely' with MP4" I was referring to h.264 video and AC3 audio in an MP4 container.

You "have muxed the mp4 and ac3 into an MKV" so by muxing to MKV it's no longer in an MP4 container hence no problems.
Are you now encoding to Mpeg-4 video or were you referring to h.264 inside an MP4 container?

Anyway, if you are using MKVmerge to mux to the final product, select your video stream and then open the "Format specific options" tab. There is an option to set 'Aspect ratio' and even 'Display width/height'. That's what I was going to suggest but the MP4 thing threw me off.

March 15, 2010, 07:02:50 PM
Reply #25

Chuck

  • Jr. Member

  • Offline
  • **

  • 82
I took AyDee's advice and muxed with MKVmerge since I can add the 16:9 flag. That fixed the AR problem. I've also decided to go with my uncompress files. I still was not completely happy with the compression. Still had a very slight jitter/stutter that my eye was just not happy with. I would watch the original, then watch the compressed and see it quite clearly.