Author Topic: Bug v1.03 Walle ISO video skipping  (Read 4269 times)

February 25, 2010, 04:46:52 PM
Read 4269 times

gravelrash

  • Newbie

  • Offline
  • *

  • 2
I have a video skipping issue with WALL E. I am trying to back up our kids DVD collection to avoid any further coasters. It skips forward about 10 seconds at approx 4 minutes into the movie. I have also noted several other points in the movie where it does this also. It is when WALL E get to the top of the stairs on the monorail.

I have used combinations of DVD FAB, ANY DVD, DVD Shrink, IMGBURN to ISO format all with the same result. Even playing the VOB's directly has the same result. The only way I got it to work was to convert it to MPG with VOB2MPG, but this involves another step which my aging computer finds it tough! I have also use MakeMKV but this also skips and has numerous audio skips throughout the movie. The ripped VOB's (which ever way I create them) play correctly on my computer.

Has anyone had the same issue or success with this backup ? I have noted on other forums people have had the same issue. Not sure if this is a WD problem or a ripping problem. Just thought I would start here.

March 05, 2010, 07:34:13 PM
Reply #1

tonycooper

  • Newbie

  • Offline
  • *

  • 3
I just played through the first 5.5 minutes and Wall-E played fine.  I played well past the scene where Wall-E replaced his tracks.  I use the same tools as you do although if I have trouble with DVDShrink I also use RipIt4Me and FixVTS.  I created a standard ISO file.  I am running FW version 1.02.07.  Just getting ready to update to 1.03.01 if it is sound... validating that now.

I think your problem is in your ripping process.  Try running RipIt4Me, then FixVTS.  When FixVTS advises you not to fix problems, fix them anyway.  Then run DVDShrink to make the ISO file.

If that process fails run DVDFAb to rip the movie and then run DVDShrink to build the ISO.

Good Luck.  And report back!

Tony

----------------------------------

Just updated to 01.03.01 from 01.02.07 and both firmwares played Wall-E without errors. I watched the entire movie.
« Last Edit: March 05, 2010, 09:49:14 PM by tonycooper »

March 23, 2010, 02:28:40 AM
Reply #2

gravelrash

  • Newbie

  • Offline
  • *

  • 2
Thanks for the reply and detailed investigation.
I did what you said using ripit4me, fixVTS and DVD shrink. The ISO still has the skip in the same place I mentioned when played on the WD media player.

Extract from DVDDecrypter.log:
W 20:16:38 288 areas have been marked as 'suspect'.
W 20:16:38 Dummy sectors will be inserted where necessary.
.........
I 20:16:45 Copying VIDEO_TS.IFO... (LBA: 445 - 470) - KEY: N/A
I 20:16:45 Copying VTS_08_0.IFO... (LBA: 1261 - 1300) - KEY: N/A
I 20:16:45 Decrypting VTS_08_1.VOB... (LBA: 1573 - 525859) - KEY: C2 95 9E 40 FD
W 20:16:52 Inserting Dummy Sectors... (LBA: 2224 - 2916)
I 20:16:52 Extracting Sectors...
W 20:16:59 Inserting Dummy Sectors... (LBA: 3616 - 4308)
I 20:16:59 Extracting Sectors...
I 20:19:02 Decrypting VTS_08_2.VOB... (LBA: 525860 - 1050146) - KEY: C2 95 9E 40 FD
I 20:20:32 Decrypting VTS_08_3.VOB... (LBA: 1050147 - 1574433) - KEY: C2 95 9E 40 FD
I 20:21:46 Decrypting VTS_08_4.VOB... (LBA: 1574434 - 2098720) - KEY: C2 95 9E 40 FD
I 20:22:51 Decrypting VTS_08_5.VOB... (LBA: 2098721 - 2623007) - KEY: C2 95 9E 40 FD
I 20:23:57 Decrypting VTS_08_6.VOB... (LBA: 2623008 - 2848022) - KEY: C2 95 9E 40 FD
I 20:24:28 Copying VTS_08_0.BUP... (LBA: 2848615 - 2848654) - KEY: N/A
I 20:24:29 Operation Successfully Completed! - Duration: 00:07:44
I 20:24:29 Average Read Rate: 12,269 KB/s (8.9x) - Maximum Read Rate: 17,352 KB/s (12.5x)
I 20:24:29 Close Request Acknowledged
I 20:24:29 Closing Down...
I 20:24:29 Shutting down SPTI...
I 20:24:29 DVD Decrypter closed!

Extract from RipIt4me.log:
I 20:24:47: VTS 8 PGC 1 Cell 4 is protected
I 20:24:47: Found 1 protected cell
I 20:24:47: Checking for potential read errors caused by scratches on the disc.
I 20:24:47: WARNING: Possible scratch/dirt on VTS 8 PGC 1 (missing 328 sec.)
I 20:25:02: Removing protected cells and cleaning up cell commands
I 20:25:02: Found at least 1 unreferenced cell in VTS 8 Title Domain
I 20:25:02: VTS 8 PGC 1 Cell 128 removed (protected or tiny) -- Duration 2 s.
I 20:25:02: VTS 8 PGC 1 Cell 31 removed (protected or tiny) -- Duration 2 s.
I 20:25:02: VTS 8 PGC 1 Cell 8 removed (protected or tiny) -- Duration 0 s.
I 20:25:02: VTS 8 PGC 1 Cell 7 removed (protected or tiny) -- Duration 1 s.
I 20:25:02: VTS 8 PGC 1 Cell 6 removed (protected or tiny) -- Duration 1 s.
I 20:25:02: VTS 8 PGC 1 Cell 5 removed (protected or tiny) -- Duration 0 s.
I 20:25:02: VTS 8 PGC 1 Cell 3 removed (protected or tiny) -- Duration 0 s.
I 20:25:02: VTS 8 PGC 1 Cell 2 removed (protected or tiny) -- Duration 0 s.
I 20:25:02: VTS 8 PGC 1 Cell 1 removed (protected or tiny) -- Duration 0 s.

Odly enough though the "fixed" VOB file (after using fixVTS) doesn't skip on my computer but at the time when the skip it supposed to occur it inserts about 3 second of video that you have already seen. eg it shows Walle going up the ramp twice !!
But as I mentioned above, when played on the WD it skips foward. WTF ??? Are these cells being removed legitimate pieces of the movie and being mistaken for something else ???

If you would like to see all the log files let me know (I could email if you prefer). Please let me know what else I can do or try.

Thanks

April 20, 2010, 09:46:44 PM
Reply #3

tonycooper

  • Newbie

  • Offline
  • *

  • 3
Use DVDFAB6 (it's free) and use the DVD to DVD option.  I use version 6.1.2.5  Anything later then this should work.

It will rip the file into a DVDFAB directory in My Documents.  

When prompted to insert the blank DVD, exit DVDFAB6 and open DVDShrink.  

In DVDShrink use "Open Files" instead of "Open Disk", then look in My Document\DVDFAB\Temp\FullDisc\"Wall-E"\ or the "Unfinished" folder.  The "Video_TS" and Audio_TS folders will be there.  Point to the Video_TS folder and click OK.
If you look you can find it.  

Note that the DVD label may not be exactly "Wall-E", but you will see either an folder named "Unfinished" or a Movie specific folder in the FullDisc folder.  The video_ts folder will be in those folders.

Once you Click OK on the folder of choice you'll recognize where you are in DVDShrink.

From here proceed like you normally would and let DVDShrink make the ISO file for the WDTV.

BTW, I have WDTV HD Version 1 - the original model

Tony
 
« Last Edit: April 20, 2010, 09:56:17 PM by tonycooper »

March 05, 2011, 01:42:56 PM
Reply #4

myncaminy

  • Newbie

  • Offline
  • *

  • 1
Ok. Ive reproduced the problem. It looks like it occurs when one field is long and has spaces and another field is long but does not have spaces. Here is the code to reproduce it:

Code:
_________________   
Happy were men if they but understood There is no safety but in doing good.
http://www.ps2netdrivers.net/manual/aeg-electrolux.ehl1n-3gmx/