Author Topic: [APP] MSheet.app.bin (NEW Release 2.2.0) : WDTV Osd experience  (Read 78557 times)

September 20, 2010, 06:20:17 PM
Reply #240

RoofingGuy

  • Full Member

  • Offline
  • ***

  • 157
Ok, can someone please explain what I'm doing wrong?

I downloaded WDLXTV 0.5.8.1.  I unzipped.  I copied the 9 files to a USB root.  I connected the USB.  I turned on the WDTV (Gen1).  It detected the new firmware and flashed.  I now get the WDLXTV boot screen instead of the stock WD screen, so I'm thinking "so far, so good."

I then downloaded MSheet.app.2.2.0.  I unzipped.  I copied the 4 files over to USB root.  I edited the MSheet.app.conf and changed the thumb values from "STD" to "SHEET".  I saved the new .conf file back to USB.

I then downloaded ThumbGen and created some sheets.  I thought I'd test a couple of folders before I started sheeting the whole 2TB.

My USB device looks like:

Code: [Select]
Movies [root]
    Genre 1
        Movie 1.mkv
        Movie 1.jpg
        Movie 1.mkv_sheet.jpg
        Movie 2.mkv
        Movie 2.jpg
        Movie 2.mkv_sheet.jpg
        ...
    Genre 2
        Movie 1.mkv
        Movie 1.jpg
        Movie 1.mkv_sheet.jpg
        Movie 2.mkv
        Movie 2.jpg
        Movie 2.mkv_sheet.jpg
        ...
    ...
    Genre 1_sheet.jpg
    Genre 2_sheet.jpg
    ...
    4 WDLXTV files        [I realize it isn't required to keep them once flashed, but that shouldn't matter]
    9 MSheet files


No matter how much plugging and unplugging I do, and powering on and off, I never get to the point where the sheets show up.

I browse each folder, and wait for the thumbs to load, as per the MSheet instructions, and then I power off.
When I power back on, I'm still browsing in WDXLTV (i.e. 3 lines of 7 instead of 2 lines of 5)... it hasn't "switched" over to the sheet view.

So I browse again through all thumbnails and power off and on... still no joy... so I bang my head on the desk and unplug the WDTV.

I then plug it back in and after ages of initializing, the browser finally comes up.  So I browse all the folders to load the thumbs, then power off, then...

I've been trying this for 8 hours and I can't get MSheet to switch to sheet browsing instead of the standard WDXLTV browse.

What is it that I'm doing wrong, or not doing?


Update:

Went out and bought a memory stick.  Memory stick contains the TEST folder unzipped from MSheet_Test.zip, and the 4 MSheet core files.

Started with an unplugged WDTV... no drive attached.  Attached mem stick and plugged WDTV in.

WDTV Power light comes on, and lots of USB activity, but screen remains turned off for an extended time... same as my previous trials.

When WDTV comes up, I browse and the sheets are showing up fine. ???

So I eject the memory stick and connect USB drive with sheets on it.

WDTV hangs... the USB drive scans and shows up, but it's just sitting there... I don't have the light blue selection box around it to select it... WDTV seems unresponsive to remote and there is no activity on the USB drive.

I turn the unit off and on and it's back to no sheets.

So, what step am I missing?
« Last Edit: September 21, 2010, 12:08:29 PM by RoofingGuy »

September 22, 2010, 07:00:52 PM
Reply #241

AyDee

  • Sr. Member

  • Offline
  • ****

  • 251
Quote
Update:

Went out and bought a memory stick.  Memory stick contains the TEST folder unzipped from MSheet_Test.zip, and the 4 MSheet core files.

Started with an unplugged WDTV... no drive attached.  Attached mem stick and plugged WDTV in.

WDTV Power light comes on, and lots of USB activity, but screen remains turned off for an extended time... same as my previous trials.

When WDTV comes up, I browse and the sheets are showing up fine. Huh

So I eject the memory stick and connect USB drive with sheets on it.
MSheet is not installed onto the WDTV itself. WDLXTV reads it from the drive it's on and if that drive is removed it becomes unstable (like you describe in your next comment).
WDTV hangs... the USB drive scans and shows up, but it's just sitting there... I don't have the light blue selection box around it to select it... WDTV seems unresponsive to remote and there is no activity on the USB drive.

I turn the unit off and on and it's back to no sheets.
Because the MSheet files are no longer present.
So, what step am I missing?
The solution is to have the MSheet files on your 'memory stick' attached at boot(which always takes a while for me too), then once you make it to the screen where you can select movies,music, etc., plug in your other drive (turning Media Library to off will cut down on the time spent scanning the drive) and when it shows up you should be able to view your sheets on it. Also, deleting the .wdtv folder on both drives beforehand is a good idea.
Hope that helps

September 23, 2010, 06:48:07 AM
Reply #242

RoofingGuy

  • Full Member

  • Offline
  • ***

  • 157
But the MSheet files are present on the USB HD.

Quote
My USB device looks like:

Code: [Select]
Movies [root]
    Genre 1
        Movie 1.mkv
        Movie 1.jpg
        Movie 1.mkv_sheet.jpg
    ...
    Genre 1_sheet.jpg
    Genre 2_sheet.jpg
    ...
    4 WDLXTV files        [I realize it isn't required to keep them once flashed, but that shouldn't matter]
    9 MSheet files

I'll try re-downloading, re-unzipping, and re-copying them over, because as far as I can tell, it should be working.

September 23, 2010, 08:08:31 AM
Reply #243

Ron[NL]

  • Sr. Member

  • Offline
  • ****

  • 425
    • WDTV Movie Sheet Generator
@ RoofingGuy,

let me guess: the USB stick is FAT(32) and the USB HDD is NTFS.
B-rad somewhere mentioned that app.bin's don't like NTFS drives sometimes.

So what I do is keep all app.bins on a 4GB fat32 formatted USB stick and leave it connected all the time.
My movies, tv series, music, photo's are streamed via network or I use an NTFS formatted external USB drive for them.
WDLXTV 0.5.8.1 + Showcase v2 OSD Mod

Philips 40PFL8605H, Sitecom WL-351

Trust HU-5440 USB Hub
WDTV MSG 1.7.0,  TheTvDBv3.0 TVSheetGenerator - rev 5.4.1

September 23, 2010, 08:18:08 PM
Reply #244

shasha

  • Newbie

  • Offline
  • *

  • 1
Hello all,

I have been using Msheet (2.2.0) for several months for movies
and this is great.
Now I want to add tv series and here comes the problem.
I want to use the wide wall mode
and I when I enter a serie season folder I dont get what I am expecting:
(http://titi.wdtv.free.fr/Screenshots/MSheet_wwall_sheet.jpg)
instead the sheet is displayed twice  on the left hand side and on the right hand side.
the thumbnail are displayed in 180*240 boxes on one line in the bottom.

Am I doing something wrong?
The test pack from titi is displayed properly.


My config:
WDLXTV 0.5.8.1
Msheet 2.2.0 files on a usb key on USB1
movies on HDD on USB2

The files on the HDD are organized the following way:
genre1/
folder.jpg             # folder picture  180*240
movie1.mpg
movie1.jpg             # thumbail  180*240
movie1.mpg_sheet.jpg   # sheet     1280*720
movie2.ts
movie2.jpg
movie2.ts_sheet.jpg
...
genre2/
...
genre3/
...
tv-shows/
_wwall
folder.jpg                  # thumbail  180*240
serie1/
_wwall
folder.jpg
serie1 saison1_sheet.jpg    # sheet     500*720
serie1 saison2_sheet.jpg    # sheet     500*720
serie1 saison1/
_wwall
folder.jpg                  # thumbnail 140*79
serie1 1x1.ts
serie1 1x1.jpg             # thumbnail 140*79
serie1 1x1.ts_sheet.jpg    # sheet 500*720
serie1 1x2.ts
serie1 1x2.jpg             # thumbnail 140*79
serie1 1x2.ts_sheet.jpg    # sheet 500*720
...
serie1 saison2/
_wwall
folder.jpg                  # thumbnail 140*79
serie1 2x1.ts
serie1 2x1.jpg             # thumbnail 140*79
serie1 2x1.ts_sheet.jpg    # sheet 500*720
serie1 2x2.ts
serie1 2x2.jpg             # thumbnail 140*79
serie1 2x2.ts_sheet.jpg    # sheet 500*720
....
serie2/
_wwall
folder.jpg
serie2 saison1_sheet.jpg    # sheet     500*720
serie2 saison2_sheet.jpg    # sheet     500*720
serie2 saison1/
...

Any clue for this strange behavior?

thanks a lot for you help I have been struggling for many days without any success.
Shasha

September 24, 2010, 12:08:01 PM
Reply #245

RoofingGuy

  • Full Member

  • Offline
  • ***

  • 157
let me guess: the USB stick is FAT(32) and the USB HDD is NTFS.
B-rad somewhere mentioned that app.bin's don't like NTFS drives sometimes.

Well, I don't know if it was the "sometimes" part, or whether a file got corrupted when expanding/transferring from the .zip file on the PC to the USB hard drive(s), but after a re-install of the MSheet files, I now have sheets working with both my externals.  I can boot with either external connected (or both), and my sheets are showing up now... at least the ones I've created.


I kinda feel dumb for not trying the re-install sooner, but oh well.

Thanks for the information and the suggestions.



:facepalm:  Turns out one of my issues was that one of the 2 USB drives had a space in the volume name and WDLXTV wouldn't load MSheet's bin... that's why the sheets wouldn't work with the one drive, and as for the other drive, either it was a corrupt file or being tempermental about NTFS, who knows... but it seems to all be working now.
« Last Edit: September 28, 2010, 07:10:22 AM by RoofingGuy »

December 11, 2010, 02:26:33 AM
Reply #246

xwishmasterx

  • Jr. Member

  • Offline
  • **

  • 50
Is it still possible to get support for msheet? Most threads for the Gen1 are dead :(