Author Topic: AAC audio in MP4 silent when digital (through toslink)  (Read 2011 times)

April 25, 2009, 04:18:50 AM
Read 2011 times

kwaazaar

  • Newbie

  • Offline
  • *

  • 9
When audio is set to Digital, my amp recognises a DD-signal, but plays no sound. When audio is set to stereo, it's still sent through the toslink, my amp switches to ProLogicII (thus recognizes 2-channel audio) and plays it fine.

It looks like my amp is the problem, however it's a brand new Onkyo, so I find it pretty hard to believe. Especially since it has no problem with any other movies containing AC3-audio. Should my amp be able to handle AAC (do these amps exist?) or should the WDTV convert it to 6-channel PCM/AC3?

This is what MediaInfo reports:
ID                               : 2
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : No
Codec ID                         : 40
Duration                         : 2h 46mn
Bit rate mode                    : Variable
Bit rate                         : 281 Kbps
Maximum bit rate                 : 426 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Rear: L R, LFE
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Stream size                      : 333 MiB (23%)
Encoded date                     : UTC 2009-04-17 23:10:19
Tagged date                      : UTC 2009-04-17 23:10:55

Edit: Probably same issue as this one: http://wdtvforum.com/main/index.php?topic=354.msg2207#msg2207
« Last Edit: April 25, 2009, 04:31:21 AM by kwaazaar »

April 25, 2009, 05:55:59 AM
Reply #1

high_definitely

  • Jr. Member

  • Offline
  • **

  • 54
You better start to believe, because very few, if any, receivers / amps have AAC decoders. Your player needs to decode the AAC stream. The WD TV-HD can decode stereo AAC streams, multi-channel AAC streams are downmixed to stereo, if output is set to 'stereo' in the settings.

No bug, can be moved.
« Last Edit: April 25, 2009, 12:35:18 PM by jayallan »