Author Topic: Network disconnect after 3 minutes of video  (Read 9892 times)

January 20, 2010, 10:43:37 AM
Read 9892 times

adrian142

  • Newbie

  • Offline
  • *

  • 1
Hello,

I am experiencing network disconnects when watching videos, that reside on my Windows 7 pc network shares.

When I switch on my WDTV Live I am able to browse the network shares, select a video and start playing.
But after about 3-5 minutes of watching I get disconnected.

All my network shares from my Windows 7 pcs are then not visible anymore.
My Brother Network printer share is still visible.

What causes this?
How can I resolve the problem?

Best regards,
-Adrian

January 20, 2010, 03:34:32 PM
Reply #1

paulg1981

  • Newbie

  • Offline
  • *

  • 5
Hello,
I have the exact same problem on my setup as well. Windows 7 32-bit can see shares and browse them as well as see and access media server via win7.  Video plays for a few minutes and starts lagging out (very slo-mo) and eventually stops. After this I cannot see the shares or connect to them again until a restart.

I found out that if you turn the wdtv on and let it connect to the wireless network then go into wireless favorites and select your network and 'connect' again this doesn't happen.  I can stream anything consistently after that.  Leads me to believe it has to do with the wireless connection startup script or something but I am no network engineer so i will let someone else pontificate :-)

At least I don't have to keep power cycling my wdtv after discover the workaround.

BTW I register JUST to reply to this post, I am glad the issue is not just my setup :-)

January 20, 2010, 06:47:42 PM
Reply #2

colbertnotion

  • Jr. Member

  • Offline
  • **

  • 69
    • Welcome to COLBERTNOTION.COM
This may be a stupid question but knowing how MicroSoft loves to mess with people...have you checked to see if PowerSaver settings in Win7 are turning off your HDD or network port(s)?  It probably can't be THAT simple but maybe.  Also check your router setups for timeouts, etc.  I do know from what I've seen with my WDTV Live that it does not access network resources in the same manner as one might expect meaning while I'm watching a movie from my laptop through the network share, it does NOT show as "traffic" across the network itself and the port(s) it uses are constantly changing for some reason (so far without causing any lag in my case).

January 20, 2010, 08:42:41 PM
Reply #3

paulg1981

  • Newbie

  • Offline
  • *

  • 5
My power saving setting are for maximum performance, my disks never spin down, and hibernate is disabled so i am pretty sure it is the computer itself. As for the router I am using a wrt54g with dd-wrt on it so I assume the router isn't to blame either.  I just finished watching a 3.5 hour movie (seven samurai) in 1080p with no issues, paused it for  bit even. I really feel it is on the wdtv end though unfortunately I have no idea how to check my theory :(

Hopefully many of our network issues will be resolved through firmware updates soon.


fwiw I am using a wusb600n adapter v2

January 21, 2010, 02:21:52 PM
Reply #4

Dion

  • Newbie

  • Offline
  • *

  • 42
Reboot your routers.  And Make sure the master browser PC isn't turned off during playback.

January 23, 2010, 09:57:22 PM
Reply #5

synaptic

  • Newbie

  • Offline
  • *

  • 42
My Brother Network printer share is still visible.

Can you please right-click on 'Computer' and go to Properties. In the box check that the field 'Workgroup' (below Computer Name, Description etc) is WORKGROUP (or Workgroup). That is the first thing you can try.

January 26, 2010, 11:30:41 PM
Reply #6

Bullet

  • Newbie

  • Offline
  • *

  • 16
I had the same issue and solved it. In my case, after properly setting all security and sharing permissions, it was an ip conflict that was my last road-block. I always use static ip's for all my stationary internet connected devices in my home. I forgot that my WII was set up on the same ip I gave to my WD Live. Easy fix and no more disconnects.
Bullet
« Last Edit: January 29, 2010, 10:57:51 PM by Bullet »

January 29, 2010, 04:27:48 PM
Reply #7

paulg1981

  • Newbie

  • Offline
  • *

  • 5
I appreciate the suggestions :-)

I have unique ips assigned for all my devices..no conflicts
I have the workgroup set as 'WORKGROUP'

Any others ideas would be appreciated as it is frustrating to have to connect manually everytime I start the media player. Just and extra step and it confuses the wife :-)

January 29, 2010, 07:14:58 PM
Reply #8

XBoNeSX

  • Newbie

  • Offline
  • *

  • 20
Mine does same thing .. through networks share ...plays movie for 5 - 10 mins .. then looses connection ... check network that PC disappeared from shares ..others still there .. so I usaully go to Media Servers (no rebooting) and WHAM ! media servers works ! .... so I thinking something to do with there WDTV live network shares

January 29, 2010, 09:21:17 PM
Reply #9

Bullet

  • Newbie

  • Offline
  • *

  • 16
I appreciate the suggestions :-)

I have unique ips assigned for all my devices..no conflicts
I have the workgroup set as 'WORKGROUP'

Any others ideas would be appreciated.....
I went through all the same aggravation. I finally got mine working perfect....I'll try to explain what worked for me...other than resolving my ip conflict. I have read many posts about others network shares permission settings in Windows 7....but this is what finally worked.
1. Set security settings on all shared folders....(not whole drives) like this: Set owner as "you" (logged in user name) with full control. Add "Everyone" with all boxes checked EXCEPT "full control". Delete everything else including administrator. (2 entries only)
2. Set share settings on all shared folders like this: "you" (logged in user name) with full control. Add "Everyone" with all boxes checked EXCEPT "full control". Delete everything else including administrator. (2 entries only).
3. In advanced network sharing, disable all streaming devices (Block All) (including Media Live Player). Do not password protect. Turn ON discovery and file/printer sharing. Use 128 bit encryption. Do not let Windows manage homegroup. Click "Turn ON sharing so anyone with network access can read/write. And make sure your network is named "WORKGROUP"
4. After you complete all these steps, go back and double check that "you" (logged in user) are the OWNER and have full control in security and shared advanced permissions, and that "Everyone" does not have full control checked. And that there are no other user entries.
And in your "WD Media Player" network settings, "Share WD with Network" and "Auto login to network shares" are ON.
Just a side note: My Windows user account is password protected. Not sure if that matters, but I log into Windows by entering my password.
If you have tried everything else...like I did with no luck, follow this tutorial. I am thrilled to have mine working perfect and I know you can too.
Here is a pic of Security setting window: HERE
Here's a pic of Shared advanced window: HERE
Bullet
« Last Edit: February 10, 2010, 01:45:49 AM by Bullet »

January 29, 2010, 09:48:25 PM
Reply #10

Bullet

  • Newbie

  • Offline
  • *

  • 16
I realize now how complicated...but very important these security and advanced permission settings are. I was about to give up and trade my WD in and give Asus a try, but after getting this set up correctly, it really does work perfect.
I understand some may not easily be able to follow my method above. It requires you to have the "know-how" to properly add "your logged in user name", and use that when you "take ownership" of shared folders.
Just a note to beginners: You only need to take control and ownership of each "main" shared folder. For example: I have a Movies Folder with about 10 different folders in it,  and a Music Folder with 25 other folders in it. So I only needed to set Security and Shared permissions on these 2 main folders.
Give feedback if you try my method...thanks,
Bullet
« Last Edit: January 29, 2010, 11:30:34 PM by Bullet »

January 30, 2010, 12:57:24 AM
Reply #11

paulg1981

  • Newbie

  • Offline
  • *

  • 5
Followed your guide to the letter but I am getting incorrect username/pass when attempting to login to the shares.  I am also using windows 7.  Did you by chance do the registry tweak also?

Thanks for some glimmer of hope :-)

January 30, 2010, 02:05:24 AM
Reply #12

Bullet

  • Newbie

  • Offline
  • *

  • 16
Followed your guide to the letter but I am getting incorrect username/pass when attempting to login to the shares.  I am also using windows 7.  Did you by chance do the registry tweak also?

Thanks for some glimmer of hope :-)
Make sure when adding "you" as the logged in user for ownership/permissions you enter this way: In the advanced window where you add names or groups, type your user login name only in the blank white feild...then hit "Check Names". That will automatically format it correctly (it adds your computer name). I hope you get what I'm trying to say because I'm not an expert in describing fairly complex networking tasks...LOL Now, in WD network setting...choose "Clear login info". Unplug WD...plug in and try logging in again. Obviously, login is case sensitive and must match Windows login exactly. It doesn't make sense to me if it still rejects your login info. If you can unravel that mystery, you will be set with no more disconnects 5 minutes into movies. BTW, I didn't need to do the registry hack. After I got my security and permissions set right, and my ip conflict resolved it has been flawless. Dedicated ip's (static) are a must with multiple internet devices in the home...like you have done.
Side note: Not sure that it is a big deal....just sayin' what works for me, I set my share computer ip as 192.168.1.104, and WD Live as 192.168.1.105 and other stationary devices follow in sequence... xxx.xxx.x.106, 107, and so on. Good luck.
Bullet
« Last Edit: January 30, 2010, 02:17:37 PM by Bullet »

January 30, 2010, 10:35:13 AM
Reply #13

paulg1981

  • Newbie

  • Offline
  • *

  • 5
Tried your suggestions and unfortunately they didn't work for me (win7 32bit).  I always get incorrect username/pass error when trying to access shares :-(   


This is such an issue for so many I am hopeful that a new firmware update will make it easier.  There is a 15+ page thread on the official wdtv forum about this issue as well.

January 30, 2010, 12:04:01 PM
Reply #14

cgmark

  • Full Member

  • Offline
  • ***

  • 107
It really isn't hard to set up once you do it once or twice.
The settings I have:
Network discovery ON
File and print sharing ON
Public Folders OFF
Media Streaming OFF
File Sharing Use 128 Bit
Password Protected Sharing ON
HomeGroup Connections Let windows manage

Set the WORKGROUP to WORKGROUP no other name will work.
Under user accounts , set up a new account with all lower case name no numbers. Do the same for password, keep it all lower case.
Click the folders you want to share and pick share with, specific people. Choose the account you just created.
On the WDLive under network share put the username and password you just created , all lowercase
Watch your files :)

I am right now streaming a 1920x1080, 60fps 89Mbit/sec video file over the network share in win7, no dropouts, stutters, or any problems whatsoever.