Author Topic: 1.01.17 - how to get 0.3.3.1 working?  (Read 3572 times)

January 12, 2010, 03:07:59 PM
Read 3572 times

turbopirk

  • Newbie

  • Offline
  • *

  • 1
Hi,

did anyone manage to get 0.3.3.1 on its machine starting from a 1.01.17 WD firmware?
I'm really curious to play around further with my new WD TV live, but so far no way to success.

I've tried 4 different USB sticks, 3 different file systems and numerous file variations on the sticks, but a "Firmware Upgrade" Icon appears only with the original 1.01.17 files (and a modified .ver file). Swapping just the .bin file with the b-rad one removes this option again from the menu.

Does the new Upgrade Manager from 1.01.17 check more things than the .ver file? Did I miss the right combination of hard- and software? Any hint is appreciated...

Thanks!

January 12, 2010, 03:58:02 PM
Reply #1

rokr

  • Full Member

  • Offline
  • ***

  • 120
I second that. I also tried the 1.10.17 and couldn't install the 0.3.3.1 afterwards.

Downgrade to 1.01.11. Problem solved

January 13, 2010, 07:41:34 AM
Reply #2

cgmark

  • Full Member

  • Offline
  • ***

  • 107
I would wait for Brad to update his firmware to the new official version before trying any custom flashing with the current official firmware.

January 13, 2010, 08:02:28 AM
Reply #3

b-rad.cc

  • Hero Member

  • Offline
  • *****

  • 833
  • Personal Text
    FW Hacker
    • B-RAD
I would wait for Brad to update his firmware to the new official version before trying any custom flashing with the current official firmware.

well I won't be because the only thing thats added is safer online upgrading, which i don't offer.

January 13, 2010, 08:27:59 AM
Reply #4

zoster

  • Full Member

  • Offline
  • ***

  • 154
Quote
well I won't be because the only thing thats added is safer online upgrading, which i don't offer.
A lot of users are reporting quicker boot times and faster menus. Are those just psychosomatic symptoms or could there be some real differences? Could you do a quick binary comparison of the main files?

January 13, 2010, 08:56:51 AM
Reply #5

cgmark

  • Full Member

  • Offline
  • ***

  • 107
Quote
well I won't be because the only thing thats added is safer online upgrading, which i don't offer.
A lot of users are reporting quicker boot times and faster menus. Are those just psychosomatic symptoms or could there be some real differences? Could you do a quick binary comparison of the main files?


I would like to know this as well. If there is no change other than safer updating then I will just downgrade units and go back to the previous custom firmware.

January 13, 2010, 05:24:03 PM
Reply #6

Whoheart

  • Hero Member

  • Offline
  • *****

  • 756
Well, I think its booting slower...

If you think there is something wrong with your WD device contact them and then act upon that: Either wait or move on - don't whine here - this is not WD's board. If you have a problem, start a thread and ask - perhaps someone knows the answer.

January 13, 2010, 06:54:20 PM
Reply #7

ChrisWhite

  • Newbie

  • Offline
  • *

  • 6
Trying the same thing here.  Downloaded 01.01.11 from the link B-Rad provided.  Used notepad to change the ver to 01.01.19 so that it is recognized by WDTV Live.  When I put the USB thumbdrive in the player, it shows new firmware found and when I opt to update, it is indeed showing version 01.01.19, HOWEVER, after selecting ok to proceed, my box reboots and when it comes back up, it shows new firmware found and nothing has changed.  I have gone over and over.  I have reformatted my USB drive a couple of times but no luck.  I am kicking myself now for upgrading to 17 two days before deciding to upgrade to B-Rad's FW!!  I am not giving up.  Any ideas how to get this working.  Am I correct in that the only thing that needs to be in the root of my thumb drive is .ver, .bin and .fff files?  Am I also correct in that I only need to open the .ver file (in notepad) to change the ver to something higher than .17?  I am not connected to the internet.  I am also at a loss.  Thanks all.

January 13, 2010, 08:46:16 PM
Reply #8

brikelly

  • Newbie

  • Offline
  • *

  • 5
Trying the same thing here.  Downloaded 01.01.11 from the link B-Rad provided.  Used notepad to change the ver to 01.01.19 so that it is recognized by WDTV Live.  When I put the USB thumbdrive in the player, it shows new firmware found and when I opt to update, it is indeed showing version 01.01.19, HOWEVER, after selecting ok to proceed, my box reboots and when it comes back up, it shows new firmware found and nothing has changed.  I have gone over and over.  I have reformatted my USB drive a couple of times but no luck.  I am kicking myself now for upgrading to 17 two days before deciding to upgrade to B-Rad's FW!!  I am not giving up.  Any ideas how to get this working.  Am I correct in that the only thing that needs to be in the root of my thumb drive is .ver, .bin and .fff files?  Am I also correct in that I only need to open the .ver file (in notepad) to change the ver to something higher than .17?  I am not connected to the internet.  I am also at a loss.  Thanks all.

Welcome to my world! I'm having the exact same experience. Here's hoping there's way out of Groundhog Day.

January 13, 2010, 10:19:49 PM
Reply #9

zoster

  • Full Member

  • Offline
  • ***

  • 154
Used notepad to change the ver to 01.01.19
That might be the problem. Notepad messes up the line endings of a linux text file. Not 100% sure but would be nice to know if it matters in this case. Try Notepad2 and make sure it says "LF" and not "CR+LF" in the status bar.

January 14, 2010, 06:49:03 AM
Reply #10

sirbolacus

  • Newbie

  • Offline
  • *

  • 1
WDTV Live will not recognize older versions of firmware. If you put 1.01.17 thats all you can do. Putting this firmware on WILL disable your Movie Sheets which it has done to me. I have spent 2 days trying everything to roll back the firmware....no luck.  :-\ The option to install older firmware does not even show up. THIS IS A BUG IN MY BOOK. Until WD or someone comes up with new firmware for this problem we are stuck. Im going to take mine back to the store as a defective item because of this firmware problem, and get another unit with 1.01.11 on it.

Let me know if you guys find anything else out there.

January 15, 2010, 01:29:02 PM
Reply #11

ChrisWhite

  • Newbie

  • Offline
  • *

  • 6
I got everything working.  It took some doing.  I ended up abandoning the thumb drive and formating and 500gig I had lying around to FAT32 and changed the ver number in the ver file to a 1.20.04, I believe.  Updated or rather downgraded to 1.01.11 successfully.  Then I reformatted my drive and dragged b-rad's bin and ver files to the root and plugger it in.  Found the firmware, updated, running smoothly now.  It take some trial and error but it is good.  I haven't worked up the courage to mess around with the background and other images.  That is something I want to do but I need to read up a lot more.

January 16, 2010, 01:14:49 AM
Reply #12

nicval

  • Newbie

  • Offline
  • *

  • 2
The new wdtvlive.ver file has changed here what it looks like in it in this new version

VERSION='1.01.17'
LOCATION='wdtvlive.bin'
PKG_LOCATION='wdtvlive.pkg'

January 16, 2010, 07:26:34 AM
Reply #13

aced088

  • Newbie

  • Offline
  • *

  • 16
Can you tell me how to Downgrade to 1.01.11.  ???
thank you

January 16, 2010, 07:28:16 AM
Reply #14

aced088

  • Newbie

  • Offline
  • *

  • 16
I got everything working.  It took some doing.  I ended up abandoning the thumb drive and formating and 500gig I had lying around to FAT32 and changed the ver number in the ver file to a 1.20.04, I believe.  Updated or rather downgraded to 1.01.11 successfully.  Then I reformatted my drive and dragged b-rad's bin and ver files to the root and plugger it in.  Found the firmware, updated, running smoothly now.  It take some trial and error but it is good.  I haven't worked up the courage to mess around with the background and other images.  That is something I want to do but I need to read up a lot more.

Can you tell me how to Downgrade to 1.01.11.  ???
thank you