Author Topic: [APP] Webserver Addons version 0.3  (Read 39963 times)

January 02, 2010, 01:01:13 PM
Reply #15

daskino

  • Newbie

  • Offline
  • *

  • 44
@dasinko: little bit more info please. does it happen for all movies?

are your movies on an external hard disk connected to the wdtv? in that case try setting the 'save info' path to empty to disable it and write the info to your movie directories.

and are you using the 'rename folders' option? it seems the error is 'rename folders' related. but can't understand what the error is yet.

hey again Red. after having disabled the folder as you said, the movieinfo app now saves the correct files and info in the moives own dir. but still cant see the movie sheets on the wdtv
« Last Edit: January 02, 2010, 01:22:31 PM by daskino »

January 02, 2010, 07:52:35 PM
Reply #16

Francis29

  • Full Member

  • Offline
  • ***

  • 238
    • WDTV GUIDE

On my end I tried this for movies on the 1 Usb key (Fat32) and 2 Drive (HFS+, which is not writable).  Keep in mind my library is off at all times.

I need to hard-code the USB key address for all drives;  Since I do not know Linux at all, what would be the correct path style to the drive in the config?
WDTV GUIDE http://wdtvforum.com/main/index.php?topic=5118.0 -WDLXTV-0.5.8.1+Ext 3 Boot 0.9.2+optware v0.2+UPnP-djmount-0.2.2+Samba 0.2+eventOSD+ appletrailersfs 3.3.1+Showcase OSDMod(MSheet)+Webserver addons 0.3+AeonBasicInfo&Flags+MSG 1.6.8+TVSG3.0-5.4+WDTV CoverFinder

January 03, 2010, 01:38:33 AM
Reply #17

redindian

  • Hero Member

  • Offline
  • *****

  • 643
    • True Font Family - Any font, any website, any browser
MOVIE/MUSIC INFO

1. For the info to work you only need the files from the webserver-addons full version.
2. Make sure event-osd is working. For instance by going to the Webserver Addons folder where you can do configuration.

When saving info on boot usb device:

3.a. Go through /USB1/ or /USB2/ when you navigate to your movies and then process

When saving info within movie directory:

3.b. Make sure the folder is writable.

If you choose 3.b. you need to disable the 'save info' path by setting it to empty.


I'll maybe add an option to view the event-osd log. Or create a page to do a simple test for the movie info.

1. If you have movie info in the web interface then it is saved correctly.
2. If you also have the Webserver on screen config working then event-osd is working.
3. If it then still doesn't work it cannot find the info. Meaning you should try to fix the previous 3.a or 3.b.

ACTORS/IMAGES

For this to work you need to have your movie folders writable also. It needs to create sub directories within the movie directories called 'Actors' and 'Images' and mount these temporarily.

The unrar and trailer options are available in the webserver addons config. There is a config button in the main screen in the upper right corner. Just next to the donate button. :-)

January 03, 2010, 01:43:43 AM
Reply #18

redindian

  • Hero Member

  • Offline
  • *****

  • 643
    • True Font Family - Any font, any website, any browser
@daskino: for web control it should mount the movie/music you want to play directly under ' Webcontrol' to prevent endless navigation. do you have media library on or off?

for the movie info, does event-osd work? have you tried a reboot? sometimes here event-osd won't work at first. can you use the on screen config?

@francis29: you shouldn't have to know the exact path. just use /boot/ in the path which is converted to /tmp/mnt/sda1/ or sda2/ which is where your boot usb drive should be. if you want to use info in the movie directory then remove/empty the 'save info' path completely.

January 03, 2010, 01:42:05 PM
Reply #19

dancytron

  • Jr. Member

  • Offline
  • **

  • 58
Thanks for all your work.

Can you give us some things to try if our event-osd isn't loading (don't see web-addons folder in video or any new on screen functions). 

Below is the detail of what I've observed/done (probably TMI).

The web control, clock and weather apps work.

I have reflashed firmware and reformatted my usb stick.  I've rebooted several times.  I've turned off all the nfs shares via by renaming my net.mounts file.

I am using b-rad's latest.  I've turned off the movie and music addons.  I got an error for the disable apps path, so I created a directory and set disabled apps path to /tmp/media/usb/MEMORYSTICKNAME/apps-disabled, which got rid of the error message.



My messages file below

Code: [Select]
**stuff deleted** [/home/andy/WDTV/house_1.03.01/src/libs/2.8.3.0/mrua_SMP8634_2.8.3.0_GCC4_dev.mips/MRUA_src/rua/emhwlib_kernel/kernel_src/krua.c:1463] init_module: begun
Jan  1 00:00:18 WDTV-18b89 user.warn kernel: em8xxx0 [/home/andy/WDTV/house_1.03.01/src/libs/2.8.3.0/mrua_SMP8634_2.8.3.0_GCC4_dev.mips/MRUA_src/rua/emhwlib_kernel/kernel_src/krua.c:1346] identify: board as unknown subid
Jan  1 00:00:18 WDTV-18b89 user.warn kernel: em8xxx [/home/andy/WDTV/house_1.03.01/src/libs/2.8.3.0/mrua_SMP8634_2.8.3.0_GCC4_dev.mips/MRUA_src/rua/emhwlib_kernel/kernel_src/krua.c:1449] identify: device 0x8635 0x86 accepted with software tango2revC
Jan  1 00:00:18 WDTV-18b89 user.warn kernel: mumk_register_tasklet: (0) tasklet c403f000 status @c938aa24
Jan  1 00:00:18 WDTV-18b89 user.warn kernel: em8xxx [/home/andy/WDTV/house_1.03.01/src/libs/2.8.3.0/mrua_SMP8634_2.8.3.0_GCC4_dev.mips/MRUA_src/rua/emhwlib_kernel/kernel_src/krua.c:1581] init_module: done. Found 1 em8xxx
Jan  1 00:00:18 WDTV-18b89 user.warn kernel: loop: No versions for exported symbols. Tainting kernel.
Jan  1 00:00:18 WDTV-18b89 user.info kernel: loop: loaded (max 24 devices)
Jan  1 00:00:43 WDTV-18b89 user.notice crazyboot: /dev/mtdblock2: LABEL="PRIMARY_SYSTEM" TYPE="romfs"
Jan  1 00:00:43 WDTV-18b89 user.notice crazyboot: /dev/mtdblock3: LABEL="WDLXTV-0.5.8.1" TYPE="cramfs"
Jan  1 00:00:43 WDTV-18b89 user.notice crazyboot: /dev/sda1: SEC_TYPE="msdos" LABEL="WDTVBOOT" UUID="C8E0-047A" TYPE="vfat"
Jan  1 00:00:44 WDTV-18b89 user.notice xmount: xmounted /dev/sda1
Jan  1 00:00:44 WDTV-18b89 user.notice crazyboot: mounting app binaries...
Jan  1 00:00:44 WDTV-18b89 user.notice crazyboot: core-extras found, initializing before continuing...
Jan  1 00:00:45 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:46 WDTV-18b89 user.warn xmount: partition with label (WDTVBOOT) already mounted!
Jan  1 00:00:46 WDTV-18b89 user.notice crazyboot: checking DEVICE /dev/sda1 for app.bins
Jan  1 00:00:46 WDTV-18b89 user.notice crazyboot: eiri app found
Jan  1 00:00:46 WDTV-18b89 user.notice crazyboot: Mounting eiri.app.bin at /apps/eiri
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=68, limit=56
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=1028, limit=56
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=60, limit=56
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=1028, limit=56
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=60, limit=56
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=1252, limit=56
Jan  1 00:00:46 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:46 WDTV-18b89 user.info kernel: loop1: rw=0, want=1028, limit=56
Jan  1 00:00:46 WDTV-18b89 user.warn kernel: UDF-fs: No partition found (1)
Jan  1 00:00:47 WDTV-18b89 user.notice crazyboot: event-osd app found
Jan  1 00:00:47 WDTV-18b89 user.notice crazyboot: Mounting event-osd.app.bin at /apps/event-osd
Jan  1 00:00:47 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:47 WDTV-18b89 user.info kernel: kjournald starting.  Commit interval 5 seconds
Jan  1 00:00:47 WDTV-18b89 user.info kernel: EXT3 FS on loop2,
Jan  1 00:00:47 WDTV-18b89 user.info kernel: internal journal
Jan  1 00:00:47 WDTV-18b89 user.info kernel: EXT3-fs: recovery complete.
Jan  1 00:00:47 WDTV-18b89 user.info kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jan  1 00:00:47 WDTV-18b89 user.notice crazyboot: nfs app found
Jan  1 00:00:47 WDTV-18b89 user.notice crazyboot: Mounting nfs.app.bin at /apps/nfs
Jan  1 00:00:47 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:47 WDTV-18b89 user.info kernel: loop3: rw=0, want=820, limit=816
Jan  1 00:00:47 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:48 WDTV-18b89 user.notice crazyboot: Mounting Optware
Jan  1 00:00:48 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:48 WDTV-18b89 user.info kernel: kjournald starting.  Commit interval 5 seconds
Jan  1 00:00:48 WDTV-18b89 user.warn kernel: EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
Jan  1 00:00:48 WDTV-18b89 user.info kernel: EXT3 FS on loop4,
Jan  1 00:00:48 WDTV-18b89 user.info kernel: internal journal
Jan  1 00:00:48 WDTV-18b89 user.info kernel: EXT3-fs: recovery complete.
Jan  1 00:00:48 WDTV-18b89 user.info kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jan  1 00:00:48 WDTV-18b89 user.notice crazyboot: pure-ftpd app found
Jan  1 00:00:48 WDTV-18b89 user.notice crazyboot: Mounting pure-ftpd.app.bin at /apps/pure-ftpd
Jan  1 00:00:48 WDTV-18b89 user.info kernel: attempt to access beyond end of device
Jan  1 00:00:48 WDTV-18b89 user.info kernel: loop5: rw=0, want=140, limit=136
Jan  1 00:00:48 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:48 WDTV-18b89 user.notice crazyboot: samba app found
Jan  1 00:00:48 WDTV-18b89 user.notice crazyboot: Mounting samba.app.bin at /apps/samba
Jan  1 00:00:48 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:49 WDTV-18b89 user.warn kernel: EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
Jan  1 00:00:49 WDTV-18b89 user.notice crazyboot: webserver-addons app found
Jan  1 00:00:49 WDTV-18b89 user.notice crazyboot: Mounting webserver-addons.app.bin at /apps/webserver-addons
Jan  1 00:00:49 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:49 WDTV-18b89 user.info kernel: kjournald starting.  Commit interval 5 seconds
Jan  1 00:00:49 WDTV-18b89 user.info kernel: EXT3 FS on loop7,
Jan  1 00:00:49 WDTV-18b89 user.info kernel: internal journal
Jan  1 00:00:49 WDTV-18b89 user.info kernel: EXT3-fs: recovery complete.
Jan  1 00:00:49 WDTV-18b89 user.info kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jan  1 00:00:49 WDTV-18b89 user.notice crazyboot: webserver app found
Jan  1 00:00:49 WDTV-18b89 user.notice crazyboot: Mounting webserver.app.bin at /apps/webserver
Jan  1 00:00:49 WDTV-18b89 user.warn kernel: UDF-fs: No VRS found
Jan  1 00:00:49 WDTV-18b89 user.info kernel: kjournald starting.  Commit interval 5 seconds
Jan  1 00:00:49 WDTV-18b89 user.warn kernel: EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
Jan  1 00:00:49 WDTV-18b89 user.info kernel: EXT3 FS on loop8,
Jan  1 00:00:49 WDTV-18b89 user.info kernel: internal journal
Jan  1 00:00:49 WDTV-18b89 user.info kernel: EXT3-fs: recovery complete.
Jan  1 00:00:49 WDTV-18b89 user.info kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jan  1 00:00:50 WDTV-18b89 user.notice crazyboot: extension[s] found on /dev/sda1 - do not remove device from wdtv
Jan  1 00:00:57 WDTV-18b89 user.notice crazyboot: adjusting LIBPATH
Jan  1 00:01:01 WDTV-18b89 user.notice root: adjusting PATH
Jan  1 00:01:01 WDTV-18b89 user.notice crazyboot: Path set to /opt/sbin:/opt/bin:/apps/webserver/bin:/apps/webserver-addons/bin:/apps/samba/bin:/apps/pure-ftpd/bin:/apps/nfs/bin:/apps/event-osd/bin:/apps/eiri/bin:/apps/core-extras/sbin:/apps/core-extras/bin:/apps/core-extra
Jan  1 00:01:02 WDTV-18b89 user.notice mount.watch: starting
**stuff deleted**
Jan  1 00:01:16 WDTV-18b89 user.notice net.agent: net.agent: Using  to set system time
Jan  1 00:01:17 WDTV-18b89 user.notice root: Device eth0 configged as 192.168.0.12/192.168.0.1/255.255.255.0
Jan  1 00:01:18 WDTV-18b89 user.notice root: net.mounts: loading /conf/net.mounts
Jan  1 00:01:18 WDTV-18b89 user.notice net.agent: net.mounts: loading /conf/net.mounts
Jan  3 19:16:24 WDTV-18b89 user.notice root: WSAO: Event OSD, use osd-backup
Jan  3 19:16:36 WDTV-18b89 daemon.info utelnetd[1677]: utelnetd (port: 23, ifname: any, login: /bin/login) startup succeeded
Jan  3 19:17:04 WDTV-18b89 user.notice mount.watch: Unmounting official device /tmp/media/usb/WDTVBOOT
Jan  3 19:17:10 WDTV-18b89 user.notice mount.watch: Unmounting official device /tmp/media/usb/WDTVBOOT
Jan  3 19:17:14 WDTV-18b89 user.warn kernel: program dmaosd is using a deprecated SCSI ioctl, please convert it to SG_IO
Jan  3 19:17:16 WDTV-18b89 user.notice mount.watch: Unmounting official device /tmp/media/usb/WDTVBOOT
**last line repeats many times until end, deleted**

I am using core extras, samba, nfs, and ftp applications.  I disabled all of these and tried again. (rebooting a couple of times)

Any help is appreciated.

Thanks,


Dan

January 03, 2010, 02:28:24 PM
Reply #20

Francis29

  • Full Member

  • Offline
  • ***

  • 238
    • WDTV GUIDE
@redindian:

I set the path to /boot/ on both counts.  I am testing on the boot fat 32 stick.  This is a resulting line:

resize /tmp/mnt/sda2/tmp/media/usb/USB2/29A5-1713/xtW/D] Gabriele Muccino/2008] Seven Pounds [HD AVC]/Images/10.jpg, aspect: 0, quality: 75

It says done at the end.  For some reason, now I do not see the info nor actors on the browser, nor on the stick (and would they be in the same folder?)

I must be missing something...
WDTV GUIDE http://wdtvforum.com/main/index.php?topic=5118.0 -WDLXTV-0.5.8.1+Ext 3 Boot 0.9.2+optware v0.2+UPnP-djmount-0.2.2+Samba 0.2+eventOSD+ appletrailersfs 3.3.1+Showcase OSDMod(MSheet)+Webserver addons 0.3+AeonBasicInfo&Flags+MSG 1.6.8+TVSG3.0-5.4+WDTV CoverFinder

January 04, 2010, 07:53:47 AM
Reply #21

redindian

  • Hero Member

  • Offline
  • *****

  • 643
    • True Font Family - Any font, any website, any browser
@Francis29: Have you tried a title without the [ and ] character? These are likely causing the problem.

@all:

After movie info runs, the info should be in "/usb1/webserver-addons/movie/tmp/media/.../Movie name". This should remain after a reboot. (Can't image how it could disappear, there is no delete code to my knowledge)

If you leave 'safe info' empty then it should be inside the movie directory in a hidden dir called .wdtv.

Then you should have movie info in the web interface.

I'll try the new firmware and see if it has anything to do with that.

January 05, 2010, 12:29:54 AM
Reply #22

Francis29

  • Full Member

  • Offline
  • ***

  • 238
    • WDTV GUIDE
I must have spent 5 hours on this  ;D

I have gone back to the default configurations.  I am still testing just the fat32 key.  The folder name seems to have no effect ( the [] brackets).

What I have found is that on the browser everything works, even though I do not see the sheet on the tv (I do see the sheets I have created manually).  Also, when I reboot the browser loses all info.

Testing 4 folders:

resize /tmp/mnt/sda2/webserver-addons/movie/tmp/media/usb/USB1/29A5-1713/xtW/Before the Devil Knows You're Dead/Images/02.jpg, aspect: 0, quality: 75

- resize /tmp/mnt/sda2/webserver-addons/movie/tmp/media/usb/USB1/29A5-1713/xtW/2009] Public Enemies [HD AVC]/Images/09.jpg, aspect: 0, quality: 75

Same.

My question is how do you name your trigger sheet, would this have any bearing?

« Last Edit: January 05, 2010, 12:41:15 AM by Francis29 »
WDTV GUIDE http://wdtvforum.com/main/index.php?topic=5118.0 -WDLXTV-0.5.8.1+Ext 3 Boot 0.9.2+optware v0.2+UPnP-djmount-0.2.2+Samba 0.2+eventOSD+ appletrailersfs 3.3.1+Showcase OSDMod(MSheet)+Webserver addons 0.3+AeonBasicInfo&Flags+MSG 1.6.8+TVSG3.0-5.4+WDTV CoverFinder

January 05, 2010, 10:14:21 AM
Reply #23

daskino

  • Newbie

  • Offline
  • *

  • 44
@daskino do you have media library on or off?

for the movie info, does event-osd work? have you tried a reboot? sometimes here event-osd won't work at first. can you use the on screen config?

I have had and have media lib on.

I guess event-osd works. I can navigate to webcontrol and see movieinfo. I can get the settings next to paypal without problems.
but still i dont see any movieinfo on the wdtv.

what can I check?

January 06, 2010, 05:06:13 PM
Reply #24

Rev Drew

  • DeSpammer
  • Sr. Member

  • Offline
  • ****

  • 383
I figured I'd give this a try too, I extracted the files onto my working setup and it doesn't work..

IF the wdtv boots, it wont play any video, I get a server reset error when trying to connect to the webserver.
I can browse all the videos and see my background sheets, it just never starts playing any files.


does anyone have this working with ext3boot based on 1.03.10 by dexter?


thanks.
You laugh because Im different, I laugh because youre all the same.

namaste

www.supernews.com/super-special/?i=ZxJfObJynPQ=

January 06, 2010, 09:23:38 PM
Reply #25

mrcdsouza

  • Newbie

  • Offline
  • *

  • 33
I've managed to install v0.3 with ext3boot based on 1.03.10 FIX root bin. I am able to browse to my movies/music etc, config the weather/clock etc. However, my wdtv chokes when trying to get a movieinfo and then it gets unresponsive even with a hard reboot. In order to get it to work properly, I have to remove v0.3 addon, and reboot.

I blanked out the Safe Dir, and my Movie directory is /tmp/media/usb/Movies which is NFS mounted.

@redindian: Thanks for any help


January 07, 2010, 12:26:32 PM
Reply #26

killy

  • Newbie

  • Offline
  • *

  • 4
Please please, please can anybody tell me how can I use this Webserver addons v3.

I use the wdtvlive box with original firmware 1.01.11 and B-rad custom firmware 0.3.2.

Extract webserver files to the root of USB stick and press the red button of the wdtvlive remote control.

In firefox browsing to http://my wdtvlive-lan-ip/addons/ ad\nd receive the 404-Not found page.

Thank you very very much.

January 07, 2010, 04:31:19 PM
Reply #27

dancytron

  • Jr. Member

  • Offline
  • **

  • 58
Killy,

This is for the old WDTV version 1, not the WDTV live. 

You need to go to the other thread and see if they have something similar yet for the WDTV live http://wdtvforum.com/main/index.php?board=14.0

January 08, 2010, 07:29:47 AM
Reply #28

redindian

  • Hero Member

  • Offline
  • *****

  • 643
    • True Font Family - Any font, any website, any browser
I'll try it with the latest firmware this weekend. You should be able to use live info to see the info. This is disabled by default because it takes some time. But this should work always...

January 08, 2010, 03:33:28 PM
Reply #29

Francis29

  • Full Member

  • Offline
  • ***

  • 238
    • WDTV GUIDE
WDTV GUIDE http://wdtvforum.com/main/index.php?topic=5118.0 -WDLXTV-0.5.8.1+Ext 3 Boot 0.9.2+optware v0.2+UPnP-djmount-0.2.2+Samba 0.2+eventOSD+ appletrailersfs 3.3.1+Showcase OSDMod(MSheet)+Webserver addons 0.3+AeonBasicInfo&Flags+MSG 1.6.8+TVSG3.0-5.4+WDTV CoverFinder