Author Topic: WDTV Software Update 1.02.04  (Read 6251 times)

April 13, 2009, 12:37:55 PM
Read 6251 times

jayallan

  • Administrator
  • Hero Member

  • Offline
  • *****

  • 1175
    • Jay Allan Photo
Time for a new update.    :)

As with 1.02.02 and .03 this is a PRE RELEASE which means it is not necessarily bug less.   

It is however an OFFICIAL RELEASE from WD.

Here is the direct link  http://support.wdc.com/download/wdtv/WDTV_FW_1_02_04.zip

This is a pre-release version of the firmware. Feel free to install it but be aware this is beta firmware so use it at your own risk.
If you are not comfortable with this, please wait for the final version.

What's New?

Prerelease 1.02.04 (includes all previously released updates)

    * Enhanced cover art, album art, and thumbnail support for media files and folders
    * Additional subtitle languages and decoding support
    * Improved media playback and navigation
    * More audio formats for MKV container
    * Fixed bugs reported by the WD TV user community

-23.976 FPS video playback in 24Hz should be much better now.
-The issue where the last subtitle in each movie didn't show up should be fixed.
-Some .avi files were still loading slowly. This should be improved.

Enjoy!
« Last Edit: April 17, 2009, 03:24:08 PM by jayallan »
WDTV LIVE with current official FW > HDMI > DVDO > Sony CRT Projector 150" 16/9 screen.  Toslink audio to Yamaha DTS receiver. No Network set up yet.

April 14, 2009, 03:50:37 AM
Reply #1

schlotz

  • Newbie

  • Offline
  • *

  • 35
    • OneShotsphoto
Sure wish they would provide some details around just what was "enhanced" instead of having to go fumble through to discover what has changed/improved.   :-\

April 14, 2009, 11:02:57 AM
Reply #2

jakmal

  • Newbie

  • Offline
  • *

  • 1
Hi,

Does this update enable playback of files ending with .264 extension?

I think the .h264 extension is supported, but .264 streams don't seem to show up in WDTV media player.

Thanks
Ganesh

April 17, 2009, 01:34:44 AM
Reply #3

hungi

  • Newbie

  • Offline
  • *

  • 11
My experiences:
  • I had problems of playback some of my MKV files with DTS sound (the sound played with pauses). Now its flawless!
  • The subtitle outline rendering is fixed, so it have again black border (its a bit thin, but readable again on white background).

April 17, 2009, 08:26:13 AM
Reply #4

rataweb

  • Newbie

  • Offline
  • *

  • 42
Quote
- The issue where the last subtitle in each movie didn't show up should be fixed.

In a MKV is not fixed!!!!!!!!!

Thanks!!!


« Last Edit: April 17, 2009, 11:53:03 AM by rataweb »