Author Topic: BUG v1.01.00 Some Shared folders are not shown on the WD TV Live  (Read 2068 times)

November 14, 2009, 05:42:44 AM
Read 2068 times

100octane

  • Newbie

  • Offline
  • *

  • 8
Hi,

I have about 10 shared directories (win xp).

Not all of them are accessible from the wd tv live, some are not listed I do not know the reason why.

regards 100octane

November 17, 2009, 11:34:01 PM
Reply #1

DSanai

  • Newbie

  • Offline
  • *

  • 1
There is a bug (and I see no mention of a fix in the new firmware, sigh) that only allows up to 5 initial letters in your network shares.

Once it reaches this limit, it ignores any additional shared folders that have a *different* initial letter than the 5 it first saw.

So for instance, if you have the following shares:
Apple Banana Cheese Duck Elephant Funky Ghost Animal

The WD TV Live will list Apple (A), Banana (B), Cheese (C), Duck (D), Elephant (E) -- and then ignore any other initial letters (so it ignores Funky and Ghost) but WILL show Animal, since A is one of the "allowed" letters.

If you rename your shared folders so they have names that start with the same letter or up to five identical letters, you'll see all of them.

On my setup, on advice from another person who figured out this problem, I renamed all of my shared folders to start with an exclamation point, and now I can see all of my shares. From my example, this means you would now have: !Apple, !Banana, !Cheese, and so on -- and it will show them all since they all start with the same character.

Hope this helps.

November 22, 2009, 08:15:32 PM
Reply #2

Stumpy

  • Newbie

  • Offline
  • *

  • 18
It's strange, I got my WD TV Live on Friday and it worked great out of the box. I could see my network shares and I had no trouble. Saturday morning I powered it back on and it was all good again. I was praising how it worked out of the box without any issues and that it was great...

...its dumb to taunt the technology gods. Sunday, it couldnt see my network shares. None of them. They were all the same names as before. They start with different letters (F, M and Z) but all within those 3. I have 5 shares in total. When trying to connect, I get "The media server cannot be accessed.".

The only potential clue could be we had a power outage this morning and the PC and WD TV Live were rebooted. I cannot remember if I rebooted the PC before. I had rebooted the WD TV Live.

My guess is that this is a fairly common firmware issue (and hopefully it will be resolved soon). In the meantime, I can plug the drive in directly (and I can still share out from the WD TV Live) so its not a show stopper (assuming it gets fixed).

The other approach is going with b-rad, and that was my original intent when I bought the box (in fact, I think thats still where I might end up), but for now, just trying to avoid biting off any potential technology headaches and going with the flow for now.

Anyone else see similiar behaviour with the v1.01.11 firmware?

I tried using a variety of fixes posted here (re-naming my share with !, ensuring me DDE services were running, updating registry settings for anonymous logon (although it worked before entering my username and password, but, hey, anything's worth a try). All to no avail.
« Last Edit: November 22, 2009, 08:53:15 PM by Stumpy »