Author Topic: [BUG?] Windows 7 Play To feature and WD TV Live  (Read 11671 times)

November 02, 2009, 06:35:50 PM
Read 11671 times

vavtnen

  • Newbie

  • Offline
  • *

  • 3
When I tried to use Play To feature to play a video file, only the audio works. The video does stream but it just doesn't show on WD TV Live (when I tried to start a video with WD TV Live I can see the stream video flashing for a second). Anyone know how to fix this?

November 02, 2009, 09:10:10 PM
Reply #1

synaptic

  • Newbie

  • Offline
  • *

  • 42
You're lucky to get audio :)  I just get an error. I don't think that the WDTV will let you use the 'Play To' functionfor video - I was surprised that it worked for audio.

November 03, 2009, 02:04:55 PM
Reply #2

KinisonKhan

  • Newbie

  • Offline
  • *

  • 31
So instead of pulling video from a Windows7 PC to the WDTV Live you are pushing video from Windows7 to the WDTV?

Not sure if thats going to work. So to push a stream to another device, it needs to be compatible with whatever protocol its using to push the a/v stream.  Me thinks if you have an XBOX360 of another Win7 PC (running Windows Media Center), it will work, but may not work for WDTV Live.

November 03, 2009, 06:08:10 PM
Reply #3

vavtnen

  • Newbie

  • Offline
  • *

  • 3
It does work, but I think the firmware need to be fix to be able to show video. Here are the steps that I do it

1. Turn on WDTV Live
2. Use "Play to" to play a video or music file.
3. At this point the music will be play, but the WDTV Live's screen will stay the same instead of change to audio player's screen or video player's screen.
4. Try to play a video via Network Shared or Media Server, you can see the video (from Play to) flash for a second.

So I think WD just need to fix its firmware.

PS: I have lots of karaoke in Vob format and I need to be able to search then queue/de-queue a file to playlist. Since WDTV Live can't do it, I have to test out the Play To feature.

November 04, 2009, 08:01:32 AM
Reply #4

MitchDC

  • Newbie

  • Offline
  • *

  • 3
I noticed it too hope they come with a new fixed firmware soon. Now when I flashed the custom firmware from b-rad the play to feature doesn't work anymore :(.

November 07, 2009, 12:21:57 PM
Reply #5

skesler

  • Newbie

  • Offline
  • *

  • 5
@vavtnen

I am experiencing the same issue (sound but no video when pushing a video via the 'Play To' function of WMP 12), and can duplicate your symptoms. 

I agree the video is making it to the player, it's just the player is not 'rendering' the video to the screen.  I've actually seen it playing (ghosted) in the background behind some menu screen but haven't been able to get back to that (maybe just before switching to network share video).

I suspect it is the WDTV Live firmware implementation of DLNA (DMR) Digitial Media Renderer. 

My WDTV Live seems to work great for pushed audio (mp3).  It should work for video and reportedly was demonstrated with video using WDTV Live by Microsoft at the Windows 7 launch event.



November 09, 2009, 08:12:00 AM
Reply #6

skesler

  • Newbie

  • Offline
  • *

  • 5
I figured out where I saw the 'Play To' pushed video being played in the background (ghosted).

If you send a video from a Win 7 WMP 12 'Play To' function to the WDTV Live, you hear the audio, but do not see the video.  If you launch a YouTube video from WDTV Live YouTube menu, and then 'Stop' that video, the video you sent (pushed) via the 'Play To' function will be playing in the background of the YouTube menu screen.

So we know the video is getting to the WDTV Live, it seems it fails to display the video from the main menu screen - They need a 'Playing Now' function from the main menu so you can switch to the video that is being pushed (DLNA - 'Digital Media Renderer' function).

« Last Edit: November 24, 2009, 06:01:05 AM by skesler »

November 25, 2009, 10:23:46 PM
Reply #7

valid

  • Newbie

  • Offline
  • *

  • 10
Bumping this thread because I bought my WDTV specifically for the 'Play To' functionality (my TV natively supports DLNA, but didn't have a "play to" functionality)

December 09, 2009, 03:14:18 PM
Reply #8

valid

  • Newbie

  • Offline
  • *

  • 10
Any chance we can get an official statment from WD on this? I would have expected an update by now.

If you take a look at this windows 7 demo using WDTV, at 29:15, it seems to be working perfectly fine for them:
http://www.microsoft.com/presspass/presskits/windows7/

December 21, 2009, 11:50:59 AM
Reply #9

ceez

  • Newbie

  • Offline
  • *

  • 4
When I use the "Play to" function it plays the audio and the video in the background behind the dash board and I can't seem to get to it. If you try to play another video file using your remote it will pause the "Play to" video currently playing and ask to resume or cancel you will see a flash of the video. So it does work but there something sort of a bug with the menu.

December 21, 2009, 01:04:20 PM
Reply #10

ceez

  • Newbie

  • Offline
  • *

  • 4
Ok.. This is how you play videos on this thing using the "play to" feature on WMP... Using your remote select any picture to view. This puts the device in display mode.. once it's open got to WMP and select your video and "Play to" the WD TV Live.. You should be able to control it from your computer and watch it on your tv...


90% of this "Play to" feature already works, WD needs to get to it and fix the 10% that's not working.

December 23, 2009, 07:54:13 PM
Reply #11

valid

  • Newbie

  • Offline
  • *

  • 10
Thanks for that tip!  Hopefully WD will fix this soon, it's a major flaw in my opinion.

February 11, 2010, 10:46:19 AM
Reply #12

valid

  • Newbie

  • Offline
  • *

  • 10
Two months later -- any update on this, WD?

February 21, 2010, 11:26:07 PM
Reply #13

NoSubstitute

  • Full Member

  • Offline
  • ***

  • 150
    • No Substitute
On b-rad's 0.3.4.5 ceez' trick is still needed to make it work.
There is No Substitute!

February 22, 2010, 01:58:14 AM
Reply #14

Ralfioni

  • Newbie

  • Offline
  • *

  • 6
I like WMP's play-to / control-point feature for streaming audio to my stereo very much. Are you guys aware of other software besides WMP, that supports this feature? Is there built-in support or are there plugins for Winamp, Songbird, Mediamonkey, Rhythmbox, etc.?