Author Topic: Can't log in to Windows 7 network shares  (Read 4864 times)

November 01, 2009, 06:41:28 PM
Read 4864 times

lindsrj

  • Newbie

  • Offline
  • *

  • 3
I can't find the secret sauce on how to set up the WD TV Live to connect to my shared folders that are on a Windows 7 PC. Every time I try to connect I get the error message "Failed to connect file server, the account/password may be changed. please check it." Doesn't matter what Windows account name I choose. I even tried setting up a new account just for WDTVLIVE and nothing changes.

I tried changing the account name in the logon screen to one that is fully qualified (\\PCNAME\accountname) and the behavior changed. There was a pause and then it popped up the error message "this media server cannot be accessed." From this point I'm back to the original error about failing to connect.

I've read various forum messages here and on AVS and tried every suggestion. Some people seem to have gotten further (only to be stymied by other anomalies). Does anyone have any idea how to make this work? I only bought this thing to stream MKV files which requires accessing network shares. I have never had so much difficulty doing something this simple. Thanks in advance. BTW, media sharing (via WMP) works find, just not for MKV).

November 01, 2009, 07:22:50 PM
Reply #1

synaptic

  • Newbie

  • Offline
  • *

  • 42
The WDTV doesn't need to have the domain name (the \\PCNAME) added to be able to login, but it appears to need a password to work correctly.

Can you please create a 'test' user using this process and see if you can login again? This process avoids the cutesy Windows new user process.

Press (Windows Key)+R and type in 'lusrmgr.msc' (without quotes)
When this page opens, right click on users and select 'New User.'
When the prompt appears, create a username and a password for the user, ensuring that the username is one word (without spaces). Uncheck 'Must Change Password at Next Logon'
For example, you might create the username 'wdtv' and the password 'wdtv_password'

Can you also please check to ensure that you have the permissions to access the shared folder?

Right click on the folder you want to share, and select 'Properties'
Navigate to the 'Sharing' Tab
Click on 'Advanced Sharing'
If you already have the folder shared, you should see the share name there. If not, click 'Share this folder' and choose a name to share it as.
Press the 'Permissions' button
Press the 'Add' Button
Type in the username (e.g. wdtv)
Press 'OK'
When that user is highlighted, change the checkboxes to 'Full Control' (not just 'Read')


On the WDTV, clear the login information by going to Settings - System - Clear Login Information.
Attempt to open the network drive again.
At the prompt, enter 'wdtv' as the username and 'wdtv_password' as the password. You shouldn't need to add anything else.

Can you give this a go and report back?

November 01, 2009, 08:19:06 PM
Reply #2

lindsrj

  • Newbie

  • Offline
  • *

  • 3
Followed the steps exactly. Same result: "Failed to connect file server, the account/password may be changed. please check it."

November 04, 2009, 09:51:57 PM
Reply #3

lindsrj

  • Newbie

  • Offline
  • *

  • 3
Hi synaptic,

Any follow-up thoughts after doing the test you suggested?

Does anyone else have a problem with basic logging into your Windows 7 system that is sharing some folders? I can't get past this to see if I have any of the other problems people are seeing, like only certain shares showing up, drops, etc.

Thanks.

November 10, 2009, 08:08:37 AM
Reply #4

ReinholD

  • Newbie

  • Offline
  • *

  • 14
Have you tried editing these registry entries?
      1. Navigate to the following location in the registry editor.
              MACHINE\System\CurrentControlSet\Control\Lsa\
      2. On the right side, double-click on 'everyoneincludesanonymous' and change the 'Value data' from '0' to '1'
      3. Double-click on 'NoLmHash' and change the 'Value data' from '1' to '0'
      4. Navigate to the following location in the registry editor:
              MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters
      5. Double-click on 'restrictnullsessaccess' and change the 'Value data' from '1' to '0'
      6. Close the registry editor


By looking at the entries' names, it seems that by default, anonymous login is not included in the "everyone" security group, which is required for the WD to connect (or at least the permissions is). And I'm pretty sure that not entering anything when loging in with the WD is anonymous.

SO. I suggest you try to edit that registry, and turn off password protected sharing in the network and sharing center.


That doesn't explayn why it doesn't work with a seperate account though.