Author Topic: Fix for Network Shares folders not showing up in wdtv Live Network Sharing  (Read 60309 times)

October 20, 2009, 10:38:18 AM
Read 60309 times

bennyismyname

  • Newbie

  • Offline
  • *

  • 4
*updated a little to make a little more sense and less attitude, kinda in a hurry... sorry for the mess*

This kinda solves SMB shares if you are using Vista as file host... didn't test this out on other OSes or NAS's but i'm sure it's similar...

Bought the WD TV Live... booted it and didn't get all my network shares showing up.  After some experimenting and searching I found out from another forum that if you modified/added a shared named for a folder in advanced sharing properties it will show up, but it only worked some of the time.   After more experimenting(hours worth of running back and forth from TV to computer sadly) I found out that certain names used for shared folders were causing the problem.  You have to add a new shared folder name for it to show up I think I got a decent set of rules and instructions for you to see your network shares in WD TV Live.

Assumptions:  You have file sharing and your network folders setup in Vista already.  You kinda know the difference between SMB(the file sharing protocol used by windows) and HTTP/UPnP(Ie. Media sharing by WMP or Tversity).  I haven't tested this out on any NAS's or other OSes using samba.  

First a check of what should be enabled...

In control panel:
*Network and Sharing Center options*  
Network discovery: On
File Sharing: On
Public folder sharing: Off
Printer sharing: On(not sure it matters)
Password Protected sharing: off
Media sharing: Off(Can be on I believe, try them both to make sure)


*Add another share name to a folder*
First, to add another(you can have multiple share names for the same folder so make sure you remove any names you aren't using or they will ALL show up in the network share list) shared name to a folder go into the Advanced Sharing properties window==>  Run Windows Explorer --> right click on the folder which you are sharing ie. (D:\Movies) --> Click 'Properties' --> Click 'Sharing' tab --> Click 'Advanced Sharing...' button --> Click 'Add' button --> Add/Remove a name to/from the pulldown box(Don't forget to check the pulldown box for extraneous names) --> Click 'Ok'

*Name Rules!*
1.  Folder names can't be a major media type name ie.  "Movies" "Sports" "TV" "TV shows" etc...
- it just won't work.  I didn't try any other major types other than ones listed above.
2.  Some symbols can't be used in the name ie.  '#' and ''' won't work but '!' will work.
3.  Only 4-5 different letters/symbols are allowed for the first letter in shared folder names and they are picked by symbol/alphabetical order!
Ie. if you had a list of shared folders of:

Anime
!Anime
!TV Shows
#TV Shows
Movies
!Movies
Sports
!Sports
T1
U2
V3
W4
X5

The folders that will be(should be... I might be off by one or 2) shown in the WD TV Live network share will be in order:
  • !Anime
    !Movies
    !Sports
    !TV Shows
    Anime
    T1
    U2
    V3

'Movies', 'TV shows' won't be shown because they are major media types.
W4, X5 won't show because they are the 6th and 7th different first character(characters 1-5 were: ! A T U V)



*Conclusion*
So pretty much add '!' to every shared folder name.  There ya go!  Now somebody tell WD to fix this sh...tuff and get me some friggin cheesy poofs.
« Last Edit: October 20, 2009, 06:59:55 PM by bennyismyname »

October 20, 2009, 10:45:01 AM
Reply #1

matt314159

  • Full Member

  • Offline
  • ***

  • 140
interesting read.  I expect one of the first firmware upgrades from WD will be to fix their massively broken networking implementation on this thing.  Im' messing around with b-rad's new homebrew right now but later if/when I'm re-messing with stock firmwre I'll try out the ! thing just for kicks and see what it does.

October 20, 2009, 11:33:17 AM
Reply #2

savant

  • Full Member

  • Offline
  • ***

  • 105
Small note, more of a nitpick really,

Samba is a *nix specific name for an implementation of Microsoft's SMB protocol.

In short:

Windows = SMB (Server Message Block)
BSD/Linux/Unix = Samba (Play on the acronym SMB, but decidedly separate implementation than Microsoft's)

October 20, 2009, 11:38:49 AM
Reply #3

matt314159

  • Full Member

  • Offline
  • ***

  • 140
so how does that relate to CIFS shares?  I don't quite understand all this....windows 7, right click, "share"....gives you....SMB?  or is that something related specifically to the server version of windows?   Sorry dumb question, I know. 

October 20, 2009, 12:13:48 PM
Reply #4

bennyismyname

  • Newbie

  • Offline
  • *

  • 4
Whoops! You're right, i just got so used to saying samba instead of S-M-B that I didn't even notice doing that.  I'm sure people get the picture... I kinda wrote it in a tone so that anybody using Vista could fix it step by step.  As to the other question, this is for the problem of certain network share folders not showing up in the WD TV Live Network share section.  I'm running a vista 64 desktop and used the basic file sharing setup there(SMB/CIFS).  I'm sharing the media on my HD here across the network.  No NAS or windows server box.  My instructions are for setting up another shared name for an already active shared folder.  I listed in the assumptions that folder shares should already be setup before doing these.  I haven't run windows 7 yet, but I assumed that their network file sharing setup should be pretty  similar and probably have the same problem.  If i'm wrong lemme know.  Hope this helps someone! 

October 20, 2009, 08:04:45 PM
Reply #5

matt314159

  • Full Member

  • Offline
  • ***

  • 140
changed all my shares to include a !prefix and they all showed up!  Fn magic man!


October 20, 2009, 10:22:01 PM
Reply #6

pagercam

  • Newbie

  • Offline
  • *

  • 7
so how does that relate to CIFS shares?  I don't quite understand all this....windows 7, right click, "share"....gives you....SMB?  or is that something related specifically to the server version of windows?   Sorry dumb question, I know. 
CIFS is the new name for SMB

October 20, 2009, 11:49:55 PM
Reply #7

matt314159

  • Full Member

  • Offline
  • ***

  • 140
Thanks, I was getting the idea they were probably the same but wasn't sure, thanks for the tip on that.   I'm still freaking amazed that adding a ! in front of my shares made them magically appear out of nowhere.   Weird weird, weird.  Haven't seen anything this weird since 1997 when I had a computer in high school whose 56k modem only worked so long as I kept wiggling the mouse.