Author Topic: Connection dies every few minutes  (Read 3162 times)

October 17, 2009, 09:34:22 AM
Read 3162 times

Headcase_Fargone

  • Jr. Member

  • Offline
  • **

  • 74
I recently picked up a WDTV Live and am enjoying it so far, but I'm having some problems with the wifi connection.

The setup:
Media is on a Windows 7 box wired to a 2Wire DSL modem/802.11g AP.
WDTV is wired to a Linksys WRT54G V5 running DD-WRT firmware set up as a bridge.
Linksys router in bridge mode is connected wirelessly to 2Wire modem/AP.

The issue:
Every 3-4 minutes the media stops playing and I get "There was a problem connecting to the network.  The device could not connect to the network."  I then have to power cycle the WDTV just to get it to see my shares again.  It makes playing anything over the wifi connection impossible, from a 2gb matroska to a 700mb avi.

I would say it's bandwidth, but I have a Roku device sitting right next to it connected wirelessly to the 2wire AP and it has always (and continues to) work flawlessly.

Any ideas?

Edit:  It seems that the 700mb avi will play about twice as long between lost connection as the 2gb mkvs.  Not sure if that's relevant or not.


Edit 2: It does the same thing streaming from an XP machine.
« Last Edit: October 17, 2009, 10:06:51 AM by Headcase_Fargone »

October 17, 2009, 04:24:48 PM
Reply #1

zetaprime

  • Newbie

  • Offline
  • *

  • 15
I recently picked up a WDTV Live and am enjoying it so far, but I'm having some problems with the wifi connection.

The setup:
Media is on a Windows 7 box wired to a 2Wire DSL modem/802.11g AP.
WDTV is wired to a Linksys WRT54G V5 running DD-WRT firmware set up as a bridge.
Linksys router in bridge mode is connected wirelessly to 2Wire modem/AP.

The issue:
Every 3-4 minutes the media stops playing and I get "There was a problem connecting to the network.  The device could not connect to the network."  I then have to power cycle the WDTV just to get it to see my shares again.  It makes playing anything over the wifi connection impossible, from a 2gb matroska to a 700mb avi.

I would say it's bandwidth, but I have a Roku device sitting right next to it connected wirelessly to the 2wire AP and it has always (and continues to) work flawlessly.

Any ideas?

Edit:  It seems that the 700mb avi will play about twice as long between lost connection as the 2gb mkvs.  Not sure if that's relevant or not.


Edit 2: It does the same thing streaming from an XP machine.

Same problem here. Using Windows 7 x64.

October 18, 2009, 08:20:37 AM
Reply #2

Headcase_Fargone

  • Jr. Member

  • Offline
  • **

  • 74
Update for those having the same problem:

I tried the registry changes in the Windows 7 thread and was able to watch about two hours of media last night (various file types) with zero problems.  And that's on a crappy 802.11g connection.

October 18, 2009, 02:56:23 PM
Reply #3

zetaprime

  • Newbie

  • Offline
  • *

  • 15
Update for those having the same problem:

I tried the registry changes in the Windows 7 thread and was able to watch about two hours of media last night (various file types) with zero problems.  And that's on a crappy 802.11g connection.

I tried these registry edits and they didn't do a thing for me...


Here are some further registry 'tweaks' if this doesn't work:

WARNING: This requires editing your PC's registry which, if edited incorrectly, can cause Windows systems to become unstable and unusable. So, follow the instructions below at your own risk. - we are not responsible for any damage caused by following these steps.

      1. Navigate to the following location in the registry editor.
              MACHINE\System\CurrentControlSet\Control\Lsa\
      2. On the right side, double-click on 'everyoneincludesanonymous' and change the 'Value data' from '0' to '1'
      3. Double-click on 'NoLmHash' and change the 'Value data' from '1' to '0'
      4. Navigate to the following location in the registry editor:
              MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters
      5. Double-click on 'restrictnullsessaccess' and change the 'Value data' from '1' to '0'
      6. Close the registry editor


Finally, restart your PC.


Are these the ones you tried? I have a feeling you did something else that actually fixed it, not the reg edits.


October 18, 2009, 03:39:54 PM
Reply #4

Headcase_Fargone

  • Jr. Member

  • Offline
  • **

  • 74
That's the only thing I changed.  It's possible there was a lot of wireless interference the first few times I used it, I suppose.

October 18, 2009, 04:00:39 PM
Reply #5

zetaprime

  • Newbie

  • Offline
  • *

  • 15
That's the only thing I changed.  It's possible there was a lot of wireless interference the first few times I used it, I suppose.

I'm using a wired connection to the router. Oddly enough the connection is fine when accessing the hard drive attached to the WDTV Live from the computer. I'm downloading files to that drive as I type this.

October 23, 2009, 06:21:46 AM
Reply #6

RhodeNet

  • Newbie

  • Offline
  • *

  • 5
I had the same issue using my NetGear ReadyNas Duo. Netgear has update to the firmware "noSMBdisconnect" so you might check to see if there is a similar update for your NAS

October 23, 2009, 06:29:32 AM
Reply #7

RhodeNet

  • Newbie

  • Offline
  • *

  • 5
I had the same issue here, no problems on connecting and maintaining smb shares on my network, but my NetGear ReadyNAS Duo kept disconnecting every few minutes. Found an update to the NAS firmware, "noSMBdisconnect" on the netgear site and fixed everything. You might want to see if your NAS has updates available to the embedded linux firmware

October 23, 2009, 07:33:26 AM
Reply #8

subslug

  • Newbie

  • Offline
  • *

  • 12
I have a similar setup to the OP, a WRT54G router with modified firmware setup as a wired/wireless bridge.
Originally everything went fine but after a while the WD would not connect. so I just went through the manual setup on the WD box and set everything up as Static. No problems since.
If you do it though, make sure to input everything including the DNS or else no internet. I don't have any Win 7 in the mix though. Still XP