Author Topic: MKV subtitles always appearing  (Read 5929 times)

April 20, 2009, 10:16:44 AM
Read 5929 times

AlunS

  • Newbie

  • Offline
  • *

  • 10
I've just downloaded an MKV file with a subtitle track, and the subtitles always appear when I first load the file, and I have to manually turn them off every time which is annoying.

I've tried modifying the header with the Header Editor function in mkvmerge, and I've tried all permutations of the three relevant flags for the subtitle track ('default track', 'track enabled' and 'force display') I can think of that make sense and all to no avail. The settings for these flags in the original file are no, yes and no. Even setting 'track enabled' to no doesn't have any effect.

Any ideas? Or is it a bug?

April 20, 2009, 10:40:24 AM
Reply #1

AlunS

  • Newbie

  • Offline
  • *

  • 10
Replying to my own post here :)

I've managed to get rid of them by creating an additional empty subtitle stream and making that the default, but it's not really very pretty.

April 20, 2009, 02:07:27 PM
Reply #2

Rev Drew

  • DeSpammer
  • Sr. Member

  • Offline
  • ****

  • 351
I always thought having them pop up was a good thing, that way you know it actually has subtitles if you want them. Although scrolling through 12 of them to get them off is a bit of a chore..
You laugh because Iím different, I laugh because youíre all the same.

namaste

www.supernews.com/super-special/?i=ZxJfObJynPQ=

June 14, 2009, 01:33:24 PM
Reply #3

bobosquishy

  • Full Member

  • Offline
  • ***

  • 202
Uh... just turn off subtitles in the settings menu.  Then subtities will not be shown by default when you start playback; they will only be shown if you bring up the playback menu and activate them.
I reserve the right to ignore you for any reason.

August 15, 2012, 07:18:56 PM
Reply #4

brill

  • Newbie

  • Offline
  • *

  • 43
Sorry to revive an old thread. I'm having the same issue. From other posts I've been able to get mkvmerge going and mux the "srt" file. The end result is one file now with the embedded subtitles.....great. The issue is that if I keep Subtitles=on in the menu they are always on, as in every spoken word. Was hoping to just see the translated text but it shows it all. Yes I can set subtitles=off but then I get nothing.

One way I see is to manually edit the subtitle file and just leaves the portions that require translation but that seems painful. As another posted mentioned he created an empty stream. Could anyone elaborate on that a bit. Is it just an empty SRT file or something else ?

This is on a Gen1 WDTV running b-rad 5.8.1

thanks,
brill

August 16, 2012, 01:24:18 PM
Reply #5

RavRob

  • DeSpammer
  • Hero Member

  • Offline
  • ****

  • 1723
If you do some digging you might be able to find a subtitle that only has the translation words but this is hit and miss.  Maybe by looking at the size of the SRT file....the smaller one may only have the translated words.  Although mine are not embedded it is very similar...some do all words spoken while others only do translation words.
Windows 7 Ultimate with SP1
WDTV Live
1.02.21 WDLXTV 0.5.1.4 (Beta)
Linksys - WUSB600N USB Adapter
DLink - Dir-655 Router
Atheros - AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
XBMC - The Future of Television

August 16, 2012, 03:27:13 PM
Reply #6

brill

  • Newbie

  • Offline
  • *

  • 43
If you do some digging you might be able to find a subtitle that only has the translation words but this is hit and miss.  Maybe by looking at the size of the SRT file....the smaller one may only have the translated words.  Although mine are not embedded it is very similar...some do all words spoken while others only do translation words.

Thanks for the reply RavRob, that makes sense. I'll take a look around, worst case I get to brush up on subtitle editing I guess  :D I just wasn't sure if that was the normal behaviour but it appears so. Thanks again.

brill