Author Topic: Subtitles Color  (Read 6042 times)

January 26, 2009, 04:00:55 PM
Read 6042 times

Flash216

  • Newbie

  • Offline
  • *

  • 6
Hi.
any chance in the future firmware to change the color of sub.
y tried all without luck.

   
thanks lot

Sorry for my bad English ;)

February 09, 2009, 04:40:32 AM
Reply #1

Flash216

  • Newbie

  • Offline
  • *

  • 6

February 10, 2009, 04:46:26 AM
Reply #2

jayallan

  • Administrator
  • Hero Member

  • Offline
  • *****

  • 1175
    • Jay Allan Photo
You would have to contact them directly.  As far as I know this is not likely to happen anytime soon.   :(
WDTV LIVE with current official FW > HDMI > DVDO > Sony CRT Projector 150" 16/9 screen.  Toslink audio to Yamaha DTS receiver. No Network set up yet.

February 13, 2009, 03:57:50 AM
Reply #3

Flash216

  • Newbie

  • Offline
  • *

  • 6
thanks!!!!! ;D

April 10, 2009, 01:51:53 PM
Reply #4

bahoiz

  • Newbie

  • Offline
  • *

  • 26
Hi b-rad,
I downloaded and installed your 0.4.3.2 version. and I saw that a strange thing:
when I want to change subtitle font size (settings -video- subtitle font size) I saw a demostration of subtitle font size ,it is normal but its color is YELLOW. but in original firmware and zoranders version it is White.
Please share us how did you do that?

PS: only demo subtitle in settings-video is yellow but when you watch a movie with subtitle is is white.

Thanks.

April 10, 2009, 02:00:43 PM
Reply #5

b-rad.cc

  • Hero Member

  • Offline
  • *****

  • 833
  • Personal Text
    FW Hacker
    • B-RAD
Hi b-rad,
I downloaded and installed your 0.4.3.2 version. and I saw that a strange thing:
when I want to change subtitle font size (settings -video- subtitle font size) I saw a demostration of subtitle font size ,it is normal but its color is YELLOW. but in original firmware and zoranders version it is White.
Please share us how did you do that?

PS: only demo subtitle in settings-video is yellow but when you watch a movie with subtitle is is white.

Thanks.

Doesn't really matter how I did it because it only displays in the area you found apparently...I changed it and never saw a difference with subs and therefore forgot about it. Consider it a pointless easter egg. ;)

April 10, 2009, 02:02:39 PM
Reply #6

bahoiz

  • Newbie

  • Offline
  • *

  • 26
Hi b-rad,
I downloaded and installed your 0.4.3.2 version. and I saw that a strange thing:
when I want to change subtitle font size (settings -video- subtitle font size) I saw a demostration of subtitle font size ,it is normal but its color is YELLOW. but in original firmware and zoranders version it is White.
Please share us how did you do that?

PS: only demo subtitle in settings-video is yellow but when you watch a movie with subtitle is is white.

Thanks.

Doesn't really matter how I did it because it only displays in the area you found apparently...I changed it and never saw a difference with subs and therefore forgot about it. Consider it a pointless easter egg. ;)


thats mean is it can not  be applicable to the subtitles? , isn't it?
thanks for your fast reply
« Last Edit: April 10, 2009, 02:03:41 PM by b-rad.cc »

April 10, 2009, 02:08:00 PM
Reply #7

b-rad.cc

  • Hero Member

  • Offline
  • *****

  • 833
  • Personal Text
    FW Hacker
    • B-RAD
I've tried to find where to change them, but thats all I could come up with, and you're the first person to tell me it had any effect as I thought it didn't do anything. Maybe sometime when i'm bored and have lots of time to piddle I'll start lookin into it again, because its not obvious.

April 10, 2009, 02:10:48 PM
Reply #8

bahoiz

  • Newbie

  • Offline
  • *

  • 26
thanks, if it is possible to change the color it will be very welcome.
thanks again.

April 11, 2009, 02:33:07 AM
Reply #9

jayjay77

  • Newbie

  • Offline
  • *

  • 5
i have found the subtitle.xml in the folder osd
i trying to change the color, but it does not work with vi.
now i have tranfer it to my pc and change the color, but i can't
send it back,--no permission.

here the data in the file
Code: [Select]
<?xml version="1.0"?>
<wrapper>
  <table x="50" y="330" w="1180" h="360" fontsize="@@subtitle_font_size" cols="1" rows="1" auto_translate="1">
    <text text="@@subtitle0" textbgcolor="0x000001" textcolor="0xF7FE24" numlines="8" align="bottom,hcenter,raws_bottom"/>
  </table>
  <image image="@@subtitle_image" x="0" y="0" w="1280" h="720" x_offset="@@x_offset" y_offset="@@y_offset" scale_type="" scale="@@scale" align="left,top" />
</wrapper>

April 11, 2009, 09:23:56 AM
Reply #10

b-rad.cc

  • Hero Member

  • Offline
  • *****

  • 833
  • Personal Text
    FW Hacker
    • B-RAD
i have found the subtitle.xml in the folder osd
i trying to change the color, but it does not work with vi.
now i have tranfer it to my pc and change the color, but i can't
send it back,--no permission.

here the data in the file
Code: [Select]
<?xml version="1.0"?>
<wrapper>
  <table x="50" y="330" w="1180" h="360" fontsize="@@subtitle_font_size" cols="1" rows="1" auto_translate="1">
    <text text="@@subtitle0" textbgcolor="0x000001" textcolor="0xF7FE24" numlines="8" align="bottom,hcenter,raws_bottom"/>
  </table>
  <image image="@@subtitle_image" x="0" y="0" w="1280" h="720" x_offset="@@x_offset" y_offset="@@y_offset" scale_type="" scale="@@scale" align="left,top" />
</wrapper>

doesn't matter what you change it to. the only place you'll see it is in the subtitle conf, like is pointed out above. In case you haven't noticed that color in subtitle.xml is yellow and the subs are definitely not yellow.