Author Topic: Help needed writing files to WDTV HDD  (Read 9067 times)

July 28, 2009, 08:21:53 AM
Read 9067 times

wooly

  • Newbie

  • Offline
  • *

  • 12
Hi,
Having spent the last three days playing with this beast , and searching the forum I am still stumped :'(

I am using

ext3-boot release 0.9.2 with a D-Link WUA1340 wifi dongle and a 320Gb USB Drive

The HDD has 2 partitions, a 1Gb FAT32 with the boot software and the rest is NTFS (have also tried ext3). There is no hub. The WiFi connection is good and remains connected for at least 24 hours, probably longer if I stopped playing and resetting the box! (with the exception mentioned in FTP below). I have also tried a wired connection with a Nexxtech USB - Ethernet connection with the same results)

Boot Drive Files:
 
www
.wd_tv
wdtv.bin
wdtv.ver
wireless-mod-rt.app.bin
rt73sta.dat
root.bin
opt.bin
wdtv.bin
wdtv.ver
wireless-mod-rt.app.bin
rt73sta.dat
root.bin
opt.bin


FTP
I can FTP into WDTV using Filezilla, when I navigate to /tmp/media/usb there are two sub-directories UPnP and USB2

USB2 has further sub-directories:

AC43-5142 which contains the data on the boot partition of the HDD,

E2E85F8EE85F6039 which contains files from the other partition of the HDD (I put these files in the partion by direct USB transfer from my PC)

UPnP which appears to be the same as the UPnP sub directory of ...../usb

The file attribute for AC43-5142 is 755 and for E2E85F8EE85F6039 is 500
I can FTP small files, up to about 30Mb  to AC43-5142 albeit slooooowly - 350KBs, above that I get a connection timed out message

Any attempt to write any size file or change permission of E2E85F8EE85F6039 results in messages similar to:

Response:   553-Can't open that file: Read-only file system
Response:   553 Rename/move failure: No such file or directory or
Response:  550 Could not change perms on devices: Read-only file system

TELNET
I can telnet in to WDTV and perform numerous commands

NETWORK ACCESS from VISTA
From Vista on the home network I map  /tmp/media/usb to a network drive (Y:) which shows 1 folder USB2, which in turn has 2 sub-folders: AC43-5142 and E2E85F8EE85F6039 I can files in both of these sub folders, but any attempt to write to them results in an error:
There is not enough space on usb(\\192.168.1.102\media)You need an additional xxx (where xxx is the size of the file I am trying to copy) to copy these files.
usb(\\192.168.1.102\media)
Space Free = 0 bytes
Total size =20.0MB

So far all I have managed to do is determine (probably incorrectly) that ALL I need to do is change the permissions on the directories in WDTV, if I try to change the permissions though I get an error:
Code: [Select]
# chmod a=rw E2E85F8EE85F6039/
chmod: E2E85F8EE85F6039/: Read-only file system

Any suggestions as to how I can set up the system to send files from my PC to WDTV, as I said earlier I have searched the forum, and have found snippets of info that have got me this far but I can't seem to get any further

Thanks

Wooly


July 28, 2009, 09:41:48 AM
Reply #1

phatoshwest

  • Full Member

  • Offline
  • ***

  • 105
In the "Server" tab of the Filezilla menu there is a setting "Show hidden files" or something like this. Enable it.

Then connect to WDTV again. There must be a folder whose name is .E2E85F8EE85F6039/ (starts with dot). You can write to that folder.

NTFS folders are mounted read-only, but they are mounted writable to the folder with the same name started with dot.
WDTV <- USB1 <- 500GB HDD (EXT2)
WDTV <- USB2 <- Powered HUB <- Airties WUS-201 Wifi <- Internet
WDTV <- USB2 <- Powered HUB <- 2GB Boot Flash-disk

July 28, 2009, 10:21:46 AM
Reply #2

wooly

  • Newbie

  • Offline
  • *

  • 12
Aha, there in lies (one of) the problems. There is no hidden directory. Filezilla has Show Hidden Files selected and there are none. This was confirmed by telnetting in checking that way as well.

May go and reformat the large partition to ext3

Wooly

July 28, 2009, 03:59:38 PM
Reply #3

wooly

  • Newbie

  • Offline
  • *

  • 12
A little progress :)

I reformatted the larger partition as ext3, I can now ftp files of any size to the WDTV HDD. I can map the \tmp\media\usb\ to a vista drive (U:) and can see files on the HDD. I can create new directories and move files between directories. I still cannot write to those directories (even tho I can ftp to them) or copy files from one directory to another. I get the same message as before:

There is not enough space on usb(\\192.168.1.102\media)You need an additional xxx (where xxx is the size of the file I am trying to copy) to copy these files.
usb(\\192.168.1.102\media)
Space Free = 0 bytes
Total size =20.0MB

Which doesn't appear to be a permissions issue  ???

Any one have any thoughts, is there something else that needs setting up on WDTV e.g SMB?

Wooly
« Last Edit: July 28, 2009, 06:33:09 PM by wooly »

July 28, 2009, 09:14:35 PM
Reply #4

TON

  • Jr. Member

  • Offline
  • **

  • 87
Someone reported a solution to this issue some time ago. It is related to an incorrectly reported share size. I do not remember the details though but it should be somewhere in this forum.

July 29, 2009, 09:21:02 PM
Reply #5

TON

  • Jr. Member

  • Offline
  • **

  • 87
Here is the reference to that solution:

http://wdtvforum.com/main/index.php?topic=247.msg2508#msg2508

Try it and report please if it helped.

July 31, 2009, 07:12:55 AM
Reply #6

wooly

  • Newbie

  • Offline
  • *

  • 12
OK, finally got around to playing with this again and two changes got it working.

Ask4help's solution pointed me in the correct direction with the change to the smb.conf file, I changed the original entry to point directly at the drive:

path = /tmp/media/usb/sdb2

Initially this did not appear to work, but Ask4helps solution also mentioned there being 2 copies of smb.conf so I started looking around. What I found was that /etc/samba/lib/smb.conf was being rewritten every time the system boots (kinda makes sense on reflection) however I could not find a second copy anywhere (maybe a difference between ext3-boot release 0.9.2 and WDLXTV?) so I copied my new smb.conf onto the boot usb stick and created a short file to put in /etc/init.d called s99smb.conf:

Code: [Select]
#!/bin/sh
cp /tmp/media/usb/USB2/F823-9E40/smb.conf /etc/samba/lib/

Now on reboot my smb.conf is copied over from the stick and the system works. I can map the media drive to a windows drive letter and copy files across.

Thanks to all for their help.

Wooly

July 31, 2009, 11:49:35 AM
Reply #7

TON

  • Jr. Member

  • Offline
  • **

  • 87
Did you try using 'find' command when looking for the other copy of smb.conf? It should have been able to find it :)

July 31, 2009, 03:07:24 PM
Reply #8

wooly

  • Newbie

  • Offline
  • *

  • 12
Yup, thats how I went looking for it  :)

Here's what I found:

Code: [Select]
# find / -name smb.conf
/tmp/samba/lib/smb.conf
#
#

Now maybe for the challenge of playing with OSD's  :-\
Wooly