Author Topic: UPnP - Problems ext3-0.9.2  (Read 8647 times)

July 11, 2009, 02:42:55 PM
Read 8647 times

xtal

  • Newbie

  • Offline
  • *

  • 48
I have tried Tversity, Twonky, Dlink media Lounge and Dlink Active tv......[ they display corectly on DSM520]

I see the shared folders ok,,,,
All my movies end with .mpg
BUT THEN ,,,UPnP is adding .m3u      which then becomes a bad file name    ie    movie.mpg.m3u

What do I need to do to correct this.... 


July 11, 2009, 03:01:31 PM
Reply #1

swixtwix

  • Newbie

  • Offline
  • *

  • 5
I'm having the same problem with UPnP servers showing up on my WDTV running ext3-0.9.2.  I can't see TVersity or my PlayOn server... I have two WDTV units (running the same code) and I recall watching Hulu via the PlayOn server in the bedroom.  So maybe its some sort of intermittent issue.

July 11, 2009, 04:25:18 PM
Reply #2

xtal

  • Newbie

  • Offline
  • *

  • 48
I tried Playon ,,,I could see no shares and trying to play CBS was very slow,,could not start anything in hulu but could see
several catagories etc....
 
I just loaded up WDLXTV 5.5
net.mounts works from net.config [ this was a first]

HOWEVER uPnP gets empty folders ........
I noticed folder ID is /tmp/media/usb/uPnP       whereas ext3-0092  is UPnP   
don't know if its something that simple ???

July 11, 2009, 08:56:53 PM
Reply #3

cow

  • Newbie

  • Offline
  • *

  • 17
I don't know about the other issues, but for things showing up as *.m3u, try this:

http://wdtvforum.com/main/index.php?topic=1308.0

I've updated it to work with Tversity. But tbh, I had problems with Tversity itself so I don't really use it myself.


PlayOn seems to be having some problems with Hulu right now:
http://www.themediamall.com/forum/help/playback-problems-amp-error-messages/hulu-broken
« Last Edit: July 11, 2009, 09:12:28 PM by cow »

July 12, 2009, 04:32:02 AM
Reply #4

xtal

  • Newbie

  • Offline
  • *

  • 48
Thx

Already tried the 2gb > 4gb change...was no help

July 12, 2009, 01:00:00 PM
Reply #5

richardjb

  • Newbie

  • Offline
  • *

  • 33
Thx

Already tried the 2gb > 4gb change...was no help

Xtal,

I'm running 0.9.2 with Cow's new djmount, and before Hulu started misbehaving with PlayOn earlier this week, I was able to play all the full-length movies I tried.  Same for Netflix.  (Previously, with the old djmount, everything >2GB showed up as an m3u.)  So maybe you should try again with Cow's new djmount and his instructions for installing it by Telnet-ing into your WDTV.  Once it's done, it survives a reboot.  

Having said that, today I tried the new Crackle plugin for Playon, and some of the movies are showing up as m3u's.  But I'm guessing that's because they are >4GB in size.  

So Cow, is there any chance of fixing djmount for >4GB files?

Thanks,

Richard
« Last Edit: July 12, 2009, 01:09:37 PM by richardjb »
ext3-boot 0.9.2, Airlink 10/100 Ethernet adapter, SFU 3.5 NFS Server, PlayOn UPnP Server

July 12, 2009, 01:07:23 PM
Reply #6

richardjb

  • Newbie

  • Offline
  • *

  • 33
BTW Xtal, I seem to recall that many people have had problems trying to get UPnP working using WDLXTV (empty folders, like you reported).

I recommend using ext3-0.9.2 and Cow's modified djmount.  PlayOn works well for me (other than the recent Hulu glitches), but it does need a pretty powerful CPU.  I had to run it on a new laptop to get it to work, since my old PC was too slow.  Also, after selecting a movie, you sometimes need to wait up to 30 secs for it to start playing.

Richard
ext3-boot 0.9.2, Airlink 10/100 Ethernet adapter, SFU 3.5 NFS Server, PlayOn UPnP Server

July 12, 2009, 03:17:10 PM
Reply #7

cow

  • Newbie

  • Offline
  • *

  • 17
So Cow, is there any chance of fixing djmount for >4GB files?

I've updated it here -- http://www.mediafire.com/file/43iti210ene/djmount-large-4.zip. I haven't really tested it, but did peek on some >4GB crackle movies and it appears to be ok. :)
« Last Edit: July 12, 2009, 03:35:43 PM by cow »

July 12, 2009, 04:17:28 PM
Reply #8

richardjb

  • Newbie

  • Offline
  • *

  • 33
So Cow, is there any chance of fixing djmount for >4GB files?

I've updated it here -- http://www.mediafire.com/file/43iti210ene/djmount-large-4.zip. I haven't really tested it, but did peek on some >4GB crackle movies and it appears to be ok. :)


Wow -- you are fast!  Thanks a bunch! I'll give it a try later today and let you know.

Richard
ext3-boot 0.9.2, Airlink 10/100 Ethernet adapter, SFU 3.5 NFS Server, PlayOn UPnP Server

July 13, 2009, 06:09:40 AM
Reply #9

xtal

  • Newbie

  • Offline
  • *

  • 48
I just telneted in and installed DJlarge#4   
I can't see any difference from telnet ?????
Is there anyway I can use telnet to display directory of the UPnP stuff
the normal ls -l /tmp/media/usb/UPnP  and /tmp/media/usb/USB1/UPnP
shows 
-r--r--r--  1 root  root  0 Jan 1  2000 Devices

I know little about Linux.......

July 13, 2009, 08:50:03 AM
Reply #10

richardjb

  • Newbie

  • Offline
  • *

  • 33
@cow: Thanks once again for djmount-large-4.  I tried it last night, and it seems to work fine (all the m3u files on Crackle have now turned into mpg's).  I only had time to play a little of one movie, but so far, so good!  Somehow we need to make sure your version of djmount gets into any subsequent "unofficial" FW releases.  Can you put your patches on SourceForge and update the version, for example?

@xtal:  After installing djmount-large-4, I had to pull the power on the WDTV and do a reboot before anything showed up in the UPnP folder.

Richard
ext3-boot 0.9.2, Airlink 10/100 Ethernet adapter, SFU 3.5 NFS Server, PlayOn UPnP Server

July 13, 2009, 11:22:09 AM
Reply #11

xtal

  • Newbie

  • Offline
  • *

  • 48
@cow: djmount-large-4

This has cured my problem also

Thx to all

July 13, 2009, 12:12:22 PM
Reply #12

cow

  • Newbie

  • Offline
  • *

  • 17
Cool, good to hear. :D

The patches are here: http://www.mediafire.com/file/miwjj0x0wwy/djmount-large-4-patch.zip. It's against djmount 0.71 and libupnp 1.6.6. Feel free to use, change, fix, etc. :)

July 13, 2009, 10:53:22 PM
Reply #13

richardjb

  • Newbie

  • Offline
  • *

  • 33
Cool, good to hear. :D

The patches are here: http://www.mediafire.com/file/miwjj0x0wwy/djmount-large-4-patch.zip. It's against djmount 0.71 and libupnp 1.6.6. Feel free to use, change, fix, etc. :)


Thanks Cow!  You are truly a star!
ext3-boot 0.9.2, Airlink 10/100 Ethernet adapter, SFU 3.5 NFS Server, PlayOn UPnP Server

July 14, 2009, 01:53:33 PM
Reply #14

xtal

  • Newbie

  • Offline
  • *

  • 48
there still appears to be a prob
my movies folder has all movies.mpg  EXCEPT for 2 movies.vob
 
the movies.vob    become     movies.vob.m3u 
the net.mounts share shows them as movies.vob

I will try to check [MediaediaMall-Dlink-active server] and [Tversity server]
to try to determine what else exists....
at first QUICK look it appears to react differently / server