Author Topic: Installing Debian Squeeze - My Experience  (Read 474 times)

October 31, 2016, 10:42:11 AM
Read 474 times


  • Newbie

  • Offline
  • *

  • 1
Ive just started playing with a WDTV Live box I found at the dump a couple of years ago. I thought Id document what I did to get a working GCC system on my WDTV.

1) Flashing 1.05.04_V_WDLXTV.COM_WDLXTV_LIVE- went pretty smoothly

2) I started to look for a C/C++ compiler. I downloaded wdtvtools. Its a emulated Linux system which runs in VMWare/VirtualBox. After changing the keyboard to English-US, I found it doesn't suit what I want todo. I couldn't work out an easy way to get the bin onto the WDTV for testing.

3) I downloaded sourcery codebench, which is a cross compiler, but I haven't tried it yet, since I want to compile on the WDTV.

4) I then found debian squeeze on this thread:

A working link is here:

The startup script is perfect. Ive attached it to this post because there is a CRLF issue with entering the script in using NotePad/WordPad. (Rename it to

EDIT: I have a second script which runs Debian Squeeze:

sh debian-squeeze.img /tmp/squeeze

The next task is to install GCC. Debian Squeeze is not longer supported, and it seems Debian moves packages to a archive repository.

So, I needed to edit /etc/apt/sources.list (using nano). I commented out the old repositories, and replaced them with:

deb squeeze main contrib non-free
deb-src squeeze main contrib non-free

Now, these commands worked:

apt-get update
apt-get install debian-archive-keyring
apt-get install build-essential

I then entered a simple "hello world" program, and compiled using gcc test.c
I entered "./a.out", and bingo! A program compiled on my WDTV.

Anyway, I hope that info helps people.
« Last Edit: October 31, 2016, 10:48:25 AM by geepster »