Author Topic: [Solved] Netflix stopped working after password change  (Read 1058 times)

November 04, 2015, 09:43:37 AM
Read 1058 times


  • Newbie

  • Offline
  • *

  • 1

For security reasons, I changed my Netflix password today, and also selected the option for signing-out of any devices.

Back to my WD TV Live 3rd gen (latest firmware), I tried to login to Netflix.

That didn't go so well, with the message: "We're unable to connect you to Netflix. Please try again or visit for guidance."
I've tried the "up, up, down, down..." trick, but it does not give me any options except "back".
The information displayed on this menu is:

Software version: 2.02.32/3.1-3-release-907160
Netflix version: Netflix SDK 3.1.3-release-907160 - Built 13:06:54 Aug 4 2014
ESN: WDBHG followed by a long string og numbers and letters
Last Error: Network / 2 / Connection closed /

So far I have tried the following remedies, without success:

1. Setup -> System -> Device Reset -> "Reset All Online Service Accounts" and "Reset Web Interface Login"
2. Setup -> System -> Device Reset -> "Reset All Settings Back To Factory Default"
3. Multiple Restarts of the WD TV

I have tried searching the forum, but haven't found a clear solution.

Any idea for a fix or why this might be happening?

Kind of dead forum, but I solved this myself.
In case anyone has similar troubles, this was probably caused by DNS acting up (Unblockus in this case).

Remedies tried:
1. Downgraded firmware to 1.06, no effect
2. Upgraded back to newest firmware, changed DNS to ISP default. This let me enter the Netflix login again
3. Changed DNS back to Unblockus, and Netflix was still working.

« Last Edit: November 09, 2015, 04:47:08 AM by oldjohn »