Author Topic: Some Mp4 movie files showing up as audio files  (Read 1250 times)

October 21, 2014, 07:14:25 AM
Read 1250 times

Chuffy

  • Newbie

  • Offline
  • *

  • 4
Hi folks
Not sure which section to put this in so here is as good as any.

I am having a weird issue with a couple of Mp4 files I have created with Handbrake on a Mac.

I am putting them on a USB hard drive connected to a WDTV Live Streaming Media Player connected to my TV. The weird thing is that some of them don't show up as movie files on the player but audio files. If I put them in the Movie folder they can't be seen, but using the Folder browser view they then show up but they have audio file icons and play as audio with no picture. Other mp4s converted with the same settings are fine though. I can't see anything different about them in media info or their metatags.

BTW they play fine in VLC on the Mac.

What could be causing this?

October 21, 2014, 08:28:58 AM
Reply #1

Chuffy

  • Newbie

  • Offline
  • *

  • 4
Well, I have just found a fix for this but it still doesn't explain why it's happening.

On the offending files I simply changed the file extension to .mkv and now they are recognised as movies and play fine, even weirder!


October 21, 2014, 10:28:47 PM
Reply #3

Chuffy

  • Newbie

  • Offline
  • *

  • 4
Thanks for that I'll have a good read later.

In the meantime, I have found that if I want to keep encoding them as Mp4's, if I un-tick the 'Large File' box in handbrake they then seem to be ok??

October 22, 2014, 03:07:41 AM
Reply #4

Chuffy

  • Newbie

  • Offline
  • *

  • 4
Thanks Techflaws, just read that thread. Seems like this has been driving everybody bonkers for some time. I don't think I'll bother downgrading the firmware just yet, annoying though it is.

I only noticed it since encoding with Handbrake, was never an issue with Avidemux. The fix I found was to either just change the file extension to .mkv, no remuxing required or in Handbrake, I found that if using the High Profile you have to untick the 'Large File' box, files then play fine.

This is something to do with 64bit support by the player maybe.