Author Topic: can't play mkv files over NFS share. Get spinning arrow forever  (Read 2108 times)

February 08, 2014, 07:46:54 AM
Read 2108 times


  • Newbie

  • Offline
  • *

  • 2
I enabled NFS on my NAS and WDTVLive and like magic, Avatar streamed buffering of any kind.

My other two issues went away as well. I can stop playing movies and if I reboot my wdtvlive I don't lose my connection with my NAS.


now some movies wont play at all....ARGHH. I can browse my share, select the movie and all I get is the wdtvlive spinning arrow...forever. I tried playing the same movie with my windows laptop over wireless with VLC and worked immediately.

April 30, 2015, 09:36:55 PM
Reply #1


  • Newbie

  • Offline
  • *

  • 2
yeah i get this too. I've been told that it depends on the format of the data inside the MKV file, some formats will hang/crash the hardware, and some will work, but nobody's zeroed in on this as far as I know. have you figured anything out?

February 27, 2016, 06:21:27 PM
Reply #2


  • Full Member

  • Offline
  • ***

  • 117
What version are you using ? Is it because of mkv header compressor

February 27, 2016, 10:52:39 PM
Reply #3


  • Jr. Member

  • Offline
  • **

  • 77
Use MediaInfo to check the video file type...MKV is just the file container.

There are h.265 MKVs available now...which the WDTV will never play.

Convert with Handbrake if you really need to...