Author Topic: WDTV Software Update 1.02.10  (Read 103995 times)

June 17, 2009, 05:57:06 PM
Reply #15

ascherjim

  • Newbie

  • Offline
  • *

  • 16
I got excited when I read about the attention paid to music and playlists.  However, this FW did not fix the fact that the filename is displayed instead of the title tag. 

Does anyone else use this to play their music library as well as movies?  I have no issues with my movies, just the title tag during playback of my FLAC files.

I remain convinced that you really need a squeezebox for playing a music collection. :-)

-john

Wow!  I use a Squeezebox for my primary at-home music listening, and I am a great fan of it.  I acquired the WDTV specifically for use on those occasions when I didn't want to be tied to my computer for feeding the Squeezebox, but to be independent of my computer for listening to my music in other locations.  With both the Squeezebox and WDTV my music source is the same WD Passport external drive.  So, I am very disappointed that nothing yet has been done to give me the same gapless playing in WDTV that I enjoy with my Squeezebox, and the fact that with WDTV the screenlisting typefaces of my music titles are so tiny on the screen of my portable DVD player as to be almost indecipherable.  Can't we at last have a fix of those two problems?  It shouldn't be that difficult.

June 17, 2009, 05:57:29 PM
Reply #16

~ kyogoku ~

  • Sr. Member

  • Offline
  • ****

  • 259
  • Personal Text
    ♫..♪♫ One more time, One more chance ♪♫..♪
i already try this version last night and so far so good :)
it finally plays the sound in all the mkv i've got... :)

June 17, 2009, 06:19:53 PM
Reply #17

bobosquishy

  • Full Member

  • Offline
  • ***

  • 202
Quote from: ascherjim
with WDTV the screenlisting typefaces of my music titles are so tiny on the screen of my portable DVD player as to be almost indecipherable.

What do you expect?  Portable DVD player screens are tiny.  I don't think you have any rational reason to complain about that.  It's not the fault of WD that you are using their product with a microscopic screen.

Quote from: chauncey
I got excited when I read about the attention paid to music and playlists.  However, this FW did not fix the fact that the filename is displayed instead of the title tag.

One is left to wonder why, since this is such a big issue for you, that you haven't been using more descriptive file names to begin with.  But to address the way you put forward the idea, how can you expect someone to fix something that hasn't been even been officially presented as a problem or a complaint before?  The playlist functionality in this firmware release was in direct response to a feature request.  Obviously you are talking about an additional and separate feature request and I think you ought to make that request in a more constructive manner instead of insisting that it is due to a fault that doesn't exist in the first place.
I reserve the right to ignore you for any reason.

June 18, 2009, 12:44:04 AM
Reply #18

Lister of Smeg

  • Full Member

  • Offline
  • ***

  • 111
This is really annoying. Over a month since the last firmware and all thats been done really is some subtitle tweeks.

The only thing WD should be working on in my opinion should be the mkv sound bug. 95% of my 720p mkv's all have sound sync issues and almost make the player un-usable. I can't bring myself to revert back to .03 because i like the thumbnails and other little features that have been added....

Please WD, will you either fix this MAJOR bug or add a lipsync option to +/- the sound manually.

thats odd, I get nothing of the sort with my 400+ mkv collection? not that I have completely tested everyone but the many I have tested passed....

The sound sync is about 200 - 500ms on most of my mkv's. Which for me is very noticable. I read somewhere that it could be related to the software used to encode the mkv's in the first place but the sound bug doesn't exist on my PC and nither does it prior and including firmware 1.02.03.

I'm sure its not just me as there are many people experiencing the same thing.
WDLXTV 0.5.8.1
Titi MSheet Mod v2.1.0
Lilibabe Simple & Unadorned v3 OSD Mod

June 18, 2009, 08:24:23 AM
Reply #19

AlunS

  • Newbie

  • Offline
  • *

  • 10
Time for another release!

Prerelease 1.02.10 Here http://support.wdc.com/download/wdtv/WDTV_FW_1_02_10.zip

    * Playlists play in the correct order. Previously they played files in alphabetical order.

 Added feature:

    * Metadata support for music improved over previous releases. For example, browsing by genre is broken down into artists, then albums, then tracks.

.. which is much better, BUT ...

I don't use playlists so can't comment on that aspect, but if I select an album, it still displays the tracks in alphabetical order, ignoring track numbering and the embedded track number I put in front of all track titles in my file names.

Also Folder.jpg still isn't displayed in anything other than Folder view if I select a whole album.

Also, why can't I just select an album and press Play and get it to play all the tracks in that album in order?

June 18, 2009, 10:27:48 AM
Reply #20

fabri22

  • Newbie

  • Offline
  • *

  • 9

thats odd, I get nothing of the sort with my 400+ mkv collection? not that I have completely tested everyone but the many I have tested passed....

...odd report.
I confirm that the sync issue still remains the most annoying and relevant firmware bug (since 1.02.04) .

June 18, 2009, 10:46:49 AM
Reply #21

mr.nice53

  • Newbie

  • Offline
  • *

  • 1
Hello, I've ne wonder there are already a Freware update for the Western Digital HD where the HDMI output also because ton is transferred from my Blu rey disc because I have only one LCD TV with an HDMI input and it gives me a ton because not because yes it is digital

June 18, 2009, 11:12:19 AM
Reply #22

jabster

  • Jr. Member

  • Offline
  • **

  • 77

Quote from: chauncey
I got excited when I read about the attention paid to music and playlists.  However, this FW did not fix the fact that the filename is displayed instead of the title tag.

One is left to wonder why, since this is such a big issue for you, that you haven't been using more descriptive file names to begin with.  But to address the way you put forward the idea, how can you expect someone to fix something that hasn't been even been officially presented as a problem or a complaint before?  The playlist functionality in this firmware release was in direct response to a feature request.  Obviously you are talking about an additional and separate feature request and I think you ought to make that request in a more constructive manner instead of insisting that it is due to a fault that doesn't exist in the first place.

In chauncey's defense, ANY music player should be reading ID3 tags at this point. I've stopped grouping all my mp3/flac/ogg by artist, etc, and now just sort them by the date I got them (makes backing up easier) because I know my music players (squeezebox and amarok) will ignore the filename and path, and automagically sort them by artist, album, etc. Asking him to rename all his files now is kind of ridiculous. We really shouldn't have to ask WD to use the id3 tags; they should have done it from the start.

that being said, I still think that anyone getting  the WDTV for anything other than movie playback is bound to be a little disappointed in the other functionality. I honestly hate using the wdtv for a music player. It just can't compare to my squeezebox. For pictures it's adequate; there are things I wish it'd do, but I don't have anything else to really compare it to, so it's fine. And, as they expand the functionality of pictures and music, you increase the chance of introducing more bugs in the video playback, and then they have to debug and troubleshoot 3 major functions instead of just one primary function (movie playback).

Except for the occasional and intermittent MKV audio sync issues (which likely explains why it is so hard to nail down and fix), I've had zero problems with movie playback and really can't complain about the box at all. Except for maybe making ethernet support official so that I can get all my movies in the collection instead of having to go thru folder view. :)

-john

June 18, 2009, 12:04:16 PM
Reply #23

chauncey

  • Newbie

  • Offline
  • *

  • 5

Quote from: chauncey
I got excited when I read about the attention paid to music and playlists.  However, this FW did not fix the fact that the filename is displayed instead of the title tag.

One is left to wonder why, since this is such a big issue for you, that you haven't been using more descriptive file names to begin with.  But to address the way you put forward the idea, how can you expect someone to fix something that hasn't been even been officially presented as a problem or a complaint before?  The playlist functionality in this firmware release was in direct response to a feature request.  Obviously you are talking about an additional and separate feature request and I think you ought to make that request in a more constructive manner instead of insisting that it is due to a fault that doesn't exist in the first place.

In chauncey's defense, ANY music player should be reading ID3 tags at this point. I've stopped grouping all my mp3/flac/ogg by artist, etc, and now just sort them by the date I got them (makes backing up easier) because I know my music players (squeezebox and amarok) will ignore the filename and path, and automagically sort them by artist, album, etc. Asking him to rename all his files now is kind of ridiculous. We really shouldn't have to ask WD to use the id3 tags; they should have done it from the start.

that being said, I still think that anyone getting  the WDTV for anything other than movie playback is bound to be a little disappointed in the other functionality. I honestly hate using the wdtv for a music player. It just can't compare to my squeezebox. For pictures it's adequate; there are things I wish it'd do, but I don't have anything else to really compare it to, so it's fine. And, as they expand the functionality of pictures and music, you increase the chance of introducing more bugs in the video playback, and then they have to debug and troubleshoot 3 major functions instead of just one primary function (movie playback).

Except for the occasional and intermittent MKV audio sync issues (which likely explains why it is so hard to nail down and fix), I've had zero problems with movie playback and really can't complain about the box at all. Except for maybe making ethernet support official so that I can get all my movies in the collection instead of having to go thru folder view. :)

-john

Thanks John.  I appreciate your response to bobosquishy's post.  The player SHOULD fully support ID3 tags, especially because it boasts .m3u and .pls playlist support.  I have reported the issue on three separate occassions to WD support and it has not been addressed in FW updates.  Is there a more constructive manner to make the request?

My music files are in the "Track# - Song Title" format.  If I make them "more descriptive" then there will be more crap that WDTV will display instead of just displayng the title tag.  The artist and album tags are displayed without a problem.  However, instead of displaying the song title tag, the WDTV shows the file name.  So there's no point in renaming the files.

June 18, 2009, 02:01:51 PM
Reply #24

hacksrus

  • Newbie

  • Offline
  • *

  • 41

thats odd, I get nothing of the sort with my 400+ mkv collection? not that I have completely tested everyone but the many I have tested passed....

...odd report.
I confirm that the sync issue still remains the most annoying and relevant firmware bug (since 1.02.04) .

I am on the same side as comp56 - none of the movies on my two 500GBs My Passports (mostly *.mkv movies in 720p/1080p, TV series in *.avi, and some SD ones) show similiar audio bug - everything plays smoothly, no delay etc etc. I am using regular HDMI connection. Or maybe I am deaf/blind, and can't see the 200-500ms delay ;)

June 19, 2009, 01:39:56 AM
Reply #25

Lister of Smeg

  • Full Member

  • Offline
  • ***

  • 111

thats odd, I get nothing of the sort with my 400+ mkv collection? not that I have completely tested everyone but the many I have tested passed....

...odd report.
I confirm that the sync issue still remains the most annoying and relevant firmware bug (since 1.02.04) .

I am on the same side as comp56 - none of the movies on my two 500GBs My Passports (mostly *.mkv movies in 720p/1080p, TV series in *.avi, and some SD ones) show similiar audio bug - everything plays smoothly, no delay etc etc. I am using regular HDMI connection. Or maybe I am deaf/blind, and can't see the 200-500ms delay ;)

hacksrus,

As i notice the 200-500ms sound bug on nearly all of my MKV files, i can only assume that the issue is present its just not everyone notices it. And to be fair to those people, it is very slight. I don't have any issues at all with avi files, just mkv....

Maybe it relates to the actual USB drives? I am using WD My Book Essentials (1x1Tb & 1x500Gb). I notice you (hacksrus) are using passport drives. Could that be the issue?
WDLXTV 0.5.8.1
Titi MSheet Mod v2.1.0
Lilibabe Simple & Unadorned v3 OSD Mod

June 19, 2009, 04:36:53 AM
Reply #26

jabster

  • Jr. Member

  • Offline
  • **

  • 77
Maybe it relates to the actual USB drives? I am using WD My Book Essentials (1x1Tb & 1x500Gb). I notice you (hacksrus) are using passport drives. Could that be the issue?

No, it's not drive related. I have the same problem over a network.

-john

June 19, 2009, 07:01:13 AM
Reply #27

veadtuck

  • Newbie

  • Offline
  • *

  • 17
no problems here... absolute sync... and i think i use the standard-config: wdtv-video>hdmi>tv and wdtv-audio>toslink>receiver

also new FW works like charme here.

June 19, 2009, 12:14:12 PM
Reply #28

activoice

  • Jr. Member

  • Offline
  • **

  • 59
Regarding the audio sync issue with MKV, I haven't tried the latest firmware, but in my experience this bug only happens on my player (1.02.07 firmware) after about the 90 minute mark in an MKV.

Once I hit the 90 minute mark the audio becomes very noticeable out of sync.  However I have found that once I hit Stop, then resume playback the audio is then in sync once again for the remainder of the video... .  However hitting pause and play does not resolve the audio sync issue.   

So for users that start and stop frequently during video playback or if most of what you watch is less than 90 minutes, then you probably never experience this sync problem.

June 19, 2009, 12:37:34 PM
Reply #29

jabster

  • Jr. Member

  • Offline
  • **

  • 77
So for users that start and stop frequently during video playback or if most of what you watch is less than 90 minutes, then you probably never experience this sync problem.

Oh no. Definately not. I first noticed it on Pixar's For The Birds, which is like 3 minutes long. The little bouncing lamp at the beginning is WAY out of sync.

-john