Author Topic: MKV Audio format for WDTV  (Read 1724 times)

November 27, 2012, 04:27:23 AM
Read 1724 times

hmdm

  • Jr. Member

  • Offline
  • **

  • 67
Hi guys,

I am a happy user of WDTV version 1.

I have been trying to archive my old DVD collection and am having problems with sound playing.

I tried dvdfab and handbrake. dvdfab seems to give good picture quality (I can set bitrate e.g. 2500 or 3000) and for audio I selected either copy source or AAC. Some files play on the wdtv audio+video ok, or picture only(no sound). When I use something like mkvtoolnix and mkvinfo I see the audio track as the same (for files that play compared to those that do not play).

When I try handbrake, some files play with video and sound, but some have audio synching issue. I sometimes see 2 tracks for audio and one I select AAC passthrough and one I select to downmix to dolby digital (not the Pro II). Then audio seems to play.

I have my wdtv set to digital audio, using toslink, connected to my onkyo amplifier TX-SR505E. The error message on wdtv when no sound is "undetermined audio".

Does anyone know what I am doing wrong, or can point me to settings in dvdfab or handbrake profile that will get this working? It takes hours to encode, and then luck if audio plays or not, which is annoying.

Thanks for your help

November 27, 2012, 06:14:06 AM
Reply #1

RavRob

  • DeSpammer
  • Hero Member

  • Offline
  • ****

  • 1728
First of all, posting the same question in 3 different sections doesn't help.  Please post your question once.

Now for your problem you might want and try ffmpeg.  Works great and I believe it will achieve what you need.  Best part is it's free.
Windows 7 Ultimate with SP1
WDTV Live
1.02.21 WDLXTV 0.5.1.4 (Beta)
Linksys - WUSB600N USB Adapter
DLink - Dir-655 Router
Atheros - AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
XBMC - The Future of Television