Author Topic: WD TV Live Hub 1TB Issues  (Read 1102 times)

April 15, 2015, 03:16:27 PM
Read 1102 times

Trilback

  • Newbie

  • Offline
  • *

  • 1
I have the old school WD TV Live Hub with the 1TB hard drive for a few years now. Today I was trying to watch something off a network share. I turned on the box and was getting a network connection and attempted to switch via the Red (B) button but it was not working but I was able to access other things like go to the home screen or access the setting page. At first I thought it was the remote so I put NEW batteries in it and it still did not work. So I thought to myself maybe its the remote so I download the WDTV remote app on my andriod phone and tried that but again everything worked but (A) (B) (C) (D) buttons. My thinking is that I might have to replace it and its not working like it should unless anybody has any ideas. I did have to do research for my uncle for something like I have but the newer models that have network access don't come with a Hard Drives. Any ideas would be great.