Author Topic: Yamaha Receiver only detecting Stereo when WDTV outputs DTS. Dolby works fine.  (Read 2518 times)

August 22, 2012, 06:28:28 PM
Read 2518 times

Skysync

  • Newbie

  • Offline
  • *

  • 2
Hi Guys,

I don't know if this is a WDTV issue or a Yamaha issue so I thought I would start here. I've tried a heap of different things that I've read from other peoples posts but can't seem to figure out whats happening. Any assistance or ideas that people could provide would be greatly appreciated as I'm stumpted. Below are details of my issue.

Problem
- When I play MKV files that are encoded with DTS, my Yamaha Receiver only detects stereo audio. I can tell its only detecting it as stereo this because it shows me which speakers are being used on the front of the receiver

Note
- Some of my MKV files have a second audio track in Dolby Digital and when I select that audio track, my receiver detects all the channels and surround sound works.

Equipment
- WDTV Live Hub w/Firmware 3.06.14
- Yamaha RX-V671 Receiver w/Firmware 1.18

Design
- WDTV Live Hub -> HDMI 1.4 Cable -> Yamaha Receiver HDMI Input #1 -> Yamaha Receiver HDMI Output #1 -> HDMI 1.4 Cable -> HDTV

Settings
- Digital Passthrough via HDMI Only - Enabled
- Yamaha Receiver DSP is set to "Straight"

Once again, any help would be appreciated because I really want to get DTS working.

Thanks,

August 22, 2012, 07:27:39 PM
Reply #1

Skysync

  • Newbie

  • Offline
  • *

  • 2
Sorted it. Found that the WDTV box hadn't auto detected which codecs my receiver could handle. Changed it to manual setup through the Digital Output via HDMI Only option.