Author Topic: My pack enhancing OSD  (Read 241874 times)

June 16, 2009, 10:07:05 AM
Reply #60

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
P.S: Blue background is the default screen.(like in the original firmware)

But that is not the usual screen that is displayed ? You get a different screen with a black box at the bottom of the screen and the file name inside that box ?

At the moment, I cannot explain myself how you could have my special screen + the default background.

June 16, 2009, 12:11:37 PM
Reply #61

bahoiz

  • Newbie

  • Offline
  • *

  • 26
@LaurentG
so sorry about my mistake I took your whole day, I just saw that movie sheet named wd_tv.jpg.jpg not wd_tv.jpg, renamed it and it works now, I can see movie sheet as expected.
but as I said in my previous message , thumbnail resizing doesn't work and no network sharing when media library off.
thanks


June 16, 2009, 12:40:49 PM
Reply #62

dcrutgers

  • Jr. Member

  • Offline
  • **

  • 90
bahoiz.. thanks for testing this.. I haven't had the time..

LaurentG, will you be able to fix these two issues with ext3-boot? I'm back to ext3 immediately if you can. :)

June 16, 2009, 01:00:26 PM
Reply #63

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
@LaurentG
so sorry about my mistake I took your whole day, I just saw that movie sheet named wd_tv.jpg.jpg not wd_tv.jpg, renamed it and it works now, I can see movie sheet as expected.

Ok, I was a little desesperate :)

Quote
but as I said in my previous message , thumbnail resizing doesn't work and no network sharing when media library off.

As I explained, thumbmail resizing cannot work with version 1.2 and ext3-boot. And configuration file cannot work too. Normally, I have done the required changes. That will be included in next release.

Regarding the network sharing when media library is off, I have to check how network shares are mounted in ext3-boot.
Do you see the new folder "OSD Settings" ?
What kind of network shares do you have ? CIFS, NFS, ... ?
What is the kind of your USB drive ? FAT32, NTFS, NFS, ... ?
Could you please execute the following commands:
Code: [Select]
ls -l /tmp/media/usb
ls -l /tmp/media/usb/USB1
ls -l /tmp/media/usb/USB2
ps | grep watch
and give me the results.

June 16, 2009, 01:14:21 PM
Reply #64

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
LaurentG, will you be able to fix these two issues with ext3-boot? I'm back to ext3 immediately if you can. :)

I should, yes :)

Normally, one of two issues (network shares) shoulld not exist. If it does not work for one guy, maybe he is in a particular case, a particular case that would lead to the same results with WDLXTV. But that is too early to say that. ;)

June 16, 2009, 03:27:56 PM
Reply #65

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
After reading few init scripts from ext3-boot, it looks like there was an attempt to manage mounting of network shares in such a way that it should work with or without the media library. But there are several stages. I am not sure to understand everything. The right file seems to be "/bin/xmounter".

Is it not working by default, meaning without any additional app.bin ?

June 16, 2009, 03:32:02 PM
Reply #66

dcrutgers

  • Jr. Member

  • Offline
  • **

  • 90
I hope I don't confuse things here, but I'm using WDLXTV with media library on, and I can see the network shares. However, when I turn off the media library I can't see my shares anymore.

June 16, 2009, 10:40:14 PM
Reply #67

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
Lot of confusion, yes.

So please answer to the same answer I asked to bahoiz two posts above.

June 16, 2009, 10:56:37 PM
Reply #68

craven

  • Guest
great job on this osd mod !!  i took screen grabs from the aeon skin in xbmc and used those jpgs for enhanced movie info.it looks great .

I dont know if its a bug or not but with the LaurentG files on my drive the eject (safely remove usb device) now
just hangs.. and doesent release the usb drive.

I have tried several drives and it does the same thing. (from 1gig to 500gig drives)

If i delete the LaurentG mod from the hdd and try again then the eject works fine.

thanks again for this fantastic mod keep up the great work !!

phil


June 17, 2009, 12:43:40 AM
Reply #69

bahoiz

  • Newbie

  • Offline
  • *

  • 26
Do you see the new folder "OSD Settings" ?

Yes I can see "OSD Settings" folder
Quote
What kind of network shares do you have ? CIFS, NFS, ... ?
I have both of them , NFS and CIFS.
Quote
What is the kind of your USB drive ? FAT32, NTFS, NFS, ... ?

USB Memory FAT32 , 2 HDD NTFS formatted.
Quote
Could you please execute the following commands:
Code: [Select]
ls -l /tmp/media/usb
ls -l /tmp/media/usb/USB1
ls -l /tmp/media/usb/USB2
ps | grep watch
and give me the results.

I am away from home now, when arrive I will execute commands.

« Last Edit: June 17, 2009, 12:00:03 PM by bahoiz »

June 17, 2009, 12:00:29 PM
Reply #70

bahoiz

  • Newbie

  • Offline
  • *

  • 26
wdtv login: root



BusyBox v1.10.0 (2009-02-15 05:09:42 CST) built-in shell (msh)
Enter 'help' for a list of built-in commands.

#
# ls -l /tmp/media/usb
drwxr-xr-x    2 root     root            0 Jan  1  1970 Apple Trailers
drwxr-xr-x    3 root     root            0 Jan  1  2000 OSD Settings
dr-xr-xr-x    4 root     root          512 Jan  1  2000 UPnP
drwxr-xr-x    4 root     root            0 Jun 17 19:19 USB1
drwxr-xr-x    2 root     root            0 Jun 16 18:56 WD1NFS
drwxr-xr-x   10 root     root         4096 Jun  4 12:09 dreamboxnfs
drwxr-xr-x   10 root     root            0 Jun  4 12:09 dreamsamba
dr-xr-xr-x    2 root     -2             64 Jun  9 20:37 tamamlananlar
#
# ls -l /tmp/media/usb/USB1
drwxr-xr-x   12 root     root        16384 Jun 17 15:51 58F7-8A90
drwxr-xr-x    2 root     root            0 Jun 16 18:56 WD1NFS
#
# ls -l /tmp/media/usb/USB2
ls: /tmp/media/usb/USB2: No such file or directory
#
# ps | grep watch
 1503 root      2636 S    /bin/sh /tmp/bin/mount.watch
 1909 root      2636 S    /bin/sh /apps/appletrailerfs/bin/atfs_wdtv_watchdog
14045 root      2524 S    grep watch
#
#


June 17, 2009, 03:33:54 PM
Reply #71

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
Ok

You were with media library off during a certain time when running the commands ?

With media library off

You should at least see your WD1NFS network share. Do you see it inside USB1 ?
But for all others including "Apple Trailers", the mountting in USB1 seems to not be done. So that means you have no access to "Apple Trailers" for example ?

June 17, 2009, 03:44:56 PM
Reply #72

hahaha

  • Full Member

  • Offline
  • ***

  • 101
An example of movie form generated with Movie GUI Builder:




How do you populate the video file info (i.e. Resoltion, Codec, Audio...) with MGB?  Can you share your MGB profile?

June 17, 2009, 10:16:39 PM
Reply #73

LaurentG

  • Full Member

  • Offline
  • ***

  • 175
How do you populate the video file info (i.e. Resoltion, Codec, Audio...) with MGB?  Can you share your MGB profile?

Manually...

But in the future, I will certainly include the possibility to display data (overriding the movie sheet) from a file. And of course, I will use that in combination of mediainfo exports.

June 18, 2009, 04:09:11 AM
Reply #74

bahoiz

  • Newbie

  • Offline
  • *

  • 26
Ok

You were with media library off during a certain time when running the commands ?

With media library off

You should at least see your WD1NFS network share. Do you see it inside USB1 ?
But for all others including "Apple Trailers", the mountting in USB1 seems to not be done. So that means you have no access to "Apple Trailers" for example ?

I don't know how it happened but now "media library off" and all my shares works  ??? , I did only unplug power of wdtv then plug it again. it works now  :o .