WDTV Forum - WDTV Media Player

WDTV v2 (non-networking) Groups => WDTV v2 General Discussion => Topic started by: smallclone on December 11, 2011, 11:05:59 AM

Title: Only some .mkv's work
Post by: smallclone on December 11, 2011, 11:05:59 AM
I downlaod mostly .mkvs and only 2 in every 3 work. Sometimes they fail to play and then the box crashes with nothing playing until you reseat all connections.

I have now checked that I am running the latest firmware and this seems to be the case.

Any ideas what I can do?

Thanks

example mkv that doesn't work:

VIDEO CODEC....: x264 (L4.1)
FRAMERATE......: 23.976 fps
Title: Re: Only some .mkv's work
Post by: RavRob on December 11, 2011, 11:41:46 AM
Not sure about the Gen 2 WDTV but for the live it is a problems with header compression on the MKVs.  Take one that won't work and remux it with MKVMerge making sure you disable header compression in both the video and audio.  Then try it again see if that works.

It only takes a minute or so to remux.

Here is something from ChompusRex

Quote
http://sourceforge.net/projects/matroska/files/mkclean/mkclean-win32.v0.5.7.zip/download

I've also updated the GUI (fixed a few bugs, added warning about dodgy mkwdclean, made it a bit slicker, rewrote large chunks of it).
www.chumpusrex.com/junk/MKVFix.exe

Here is the info he wrote on how to use it

Quote
Just an update here - But I've put together a small GUI for automating the remuxing process.

Just click on a directory - it scans it, identifies which files have header compression, and then remuxes them in the background (without having multiple console windows popping up).

It worked fine for me. Hopefully, some people will find it simpler than a batch file. As it really is a 2-click process.

It requires:
.NET framework v3.5 or v 4 (should be automatically installed by Windows update on XP and higher)
MKVToolNix v4.3.0 or newer.

Just pop the MKWDClean.exe file in the same directory as MKVFix.exe. If you don't, MKVFix will ask you where to find it.

You can download the GUI app from: www.chumpusrex.com/junk/MKVFix.exe

If you are worried about downloading exe files and would prefer to compile it yourself - then the source package is available from: www.chumpusrex.com/junk/MVVFix-src.rar
Please bear in mind that this was knocked up in a couple of hours and the code is seriously ugly. However, it seems to work with no glaring bugs.

Screenshots:
pic 1 (http://www.chumpusrex.com/junk/mkwdfix-1.png)
pic 2 (http://www.chumpusrex.com/junk/mkwdfix-2.png)

As I said though I am not sure about the Gen2 but my guess it that it's your problem.  Anyway, try one with MKVMerge and if that work then do this as shown.  It really cuts on the time to search for files and the remuxing.
Title: Re: Only some .mkv's work
Post by: smallclone on December 11, 2011, 03:46:17 PM
Thanks loads for this.

It is asking me to install "Toolnix" from the link in the program though. should I do that?
Title: Re: Only some .mkv's work
Post by: RavRob on December 11, 2011, 07:49:01 PM
Sure.  Nothing wrong with this.
Title: Re: Only some .mkv's work
Post by: smallclone on January 05, 2012, 02:46:36 AM
Thank you for this. It worked like a dream.
Title: Re: Only some .mkv's work
Post by: maddoctor on October 25, 2012, 11:23:53 PM
The other solution is to use a newer firmware. I had the same problem with some mkv and I found that the custom firmware of Padava (2.0.0), shows them with no problem.
Title: Re: Only some .mkv's work
Post by: sweetredlight on May 13, 2013, 05:22:36 AM
I have the same issues sometimes, some files are corrupted, there are software you could try to repair them, good luck!