WDTV Forum - WDTV Media Player

WDTV LIVE Groups => Bug Reports WDTV LIVE => Topic started by: knobber on July 04, 2010, 01:38:52 PM

Title: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: knobber on July 04, 2010, 01:38:52 PM
i have found this problem is due to this feature here: header_removal_compression

http://www.bunkus.org/videotools/mkvtoolnix/faq.html#header_removal_compression


seems WD needs to look at adding detection for this. or everyone will be stuck at v4.0.0

also muxing programs like makemkv etc will eventually update to use this version aswell
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: Darren on July 10, 2010, 11:44:47 PM
This is a serious problem for the WDTV product line. It needs to be addressed quickly before the problem starts to grow, as more people start using the new versions of mkv authoring programs, many of which are (based on) mkvtools.

It took a lot of troubleshooting and research to figure out why I suddenly had no audio on files I just created. MkvMerge now defaults to using this header compression feature, and you have to manually change the option to NO every time you use the program, otherwise the created file is incompatible with the WDTV players, at their latest (current) firmware levels.

This "new" feature is based on an existing mkv spec, but it just wasn't used much before. Now that its being used then the WDTV needs to properly support it, by following the existing spec.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: 47th_ronin on July 11, 2010, 12:50:33 AM
hi,

just found out about this feature, too. after i re-muxed a bunch of my files to get rid of russian audio tracks and save some gigs of space. hopefully wd will look into this and make the adjustments in firmware soon.
meanwhile, the workaround is to re-mux the files with no audio again, with audio track 'compression - none' option selected. in case you have deleted the original files as i have. this seems to work for me so far.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: mufc on July 16, 2010, 04:49:32 AM
"  Why does audio not play anymore since v4.1.0 (MP3, AC3, DTS audio tracks)?

The Matroska specifications know a feature called "header removal compression". This allows a muxer to keep a certain number of bytes that are identical for each frame in the track headers removing them from the individual frames. This reduces the size of the tracks significantly without altering the content as a demuxer can add the bytes found in the track headers to each frame during demuxing.

Starting with v4.1.0 mkvmerge uses header removal compression for a couple of track types by default. These include AC3, DTS and MP3 audio tracks as well as Dirac and MPEG-4 part 2 (aka. XviD/DivX) video tracks. The user muxing a file may disable it by explicitely selecting 'none' as the compression scheme for such a track.

This means when you add your movie , highlight the audio track and select "none" for compression.
This feature cannot be saved. You must do this every time you add a new file.


If your player has difficulties playing such files then it is a bug in that player or in the demuxer but not in mkvmerge. This feature has been part of the Matroska specification since more than six years, and there's no excuse for refusing to add support for it.

The rest of the thread is here for anyone interested.
http://forum.doom9.org/showthread.php?p=1416783
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: rodfeli on August 01, 2010, 11:39:08 AM
+1 for this!!!
Please WD includes in the next release!
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: RavRob on August 01, 2010, 01:56:08 PM
When you use MKVMerge, do not select audio compression.  Use Stream only.  It should fix your problem.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: rontokyo on August 04, 2010, 02:46:09 AM

+1 here as well. This has become a large problem with .mkv files I've downloaded in the last week or so.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: genotype on August 04, 2010, 09:21:53 PM
and here i thought i was the only one. +1
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: snarkle on August 05, 2010, 05:35:10 PM
Matroska has information about this issue here.
http://www.matroska.org/news/compressed-headers.html

For those using Windows, there is a tool called mkWDclean which is available from Matroska's site to fix these files for the WDTV.
http://www.matroska.org/downloads/mkclean.html

Here is a sample mkv file with the issue with compressed headers. This won't play on a WDTV, but does via numerous other media devices. Popcorn Hour, Egreat etc do not experience this issue.
http://www.megaupload.com/?d=E6YEJROR

There is a petition in place to request that WDTV fix this problem with a firmware update. Please add your name!
http://wdtv.uservoice.com/forums/17442-general/suggestions/944559-compressed-header-in-matroska
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: GuyWD on August 06, 2010, 02:53:01 PM
This is fixed in firmware that's currently in testing. I'm not sure when it'll make it into a firmware release, though.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: ElCapitano on August 06, 2010, 04:57:31 PM
Hopefully this will be addressed ASAP.
Big problem.....
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: alterego on August 07, 2010, 06:57:32 AM
can we get a date for when this firmware will be released?

its very frustrating having to remux audio for pretty much every show that comes out weekly
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: gab73 on August 09, 2010, 07:52:35 AM
+1

This is heavy - please fix it as soon as possible via small firmware update.

quote:
For those using Windows, there is a tool called mkWDclean which is available from Matroska's site to fix these files for the WDTV.
http://www.matroska.org/downloads/mkclean.html

This works for me and is relatively painless (simple and fast, just drop your mkv on mkWDclean.exe)
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: Surfer74 on August 10, 2010, 12:40:57 AM
Hopefully this will be addressed ASAP.
Big problem.....

indeed

If WD thinks they can take it slowly then they will risk their reputation regarding media players.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: markusb68 on September 08, 2010, 07:58:01 AM
Hi,

I have tried to fix several MKV files with mkWDclean v0.5.6. (Had video but no Sound on my WDTV)
and this ended up my WDTV not playing the Video and the sound either.

Tried mkWDclean without special options and also with "--optimize input.mkv output.mkv" as the command line.

Is there anybody who succeeded with mkWDclean ?

pls reveal the used command line options to us !

Thanks

Mark
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: marcelg on September 10, 2010, 04:11:32 PM
Now WD live plus, has a new update to arrange it,  but what happens with wd live users?, that problem is old, but noone from WD say anything, well, seems that we will try to find a better supported company for our HD media players.
I will never buy anything from WD, that's not fair!. 
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: MichaelW on September 12, 2010, 09:38:18 AM
WORKAROUND:
Please see MichaelW's workaround that will do the trick, until WD will release new FW for the WDTV Live model.
To my experience, the mkWDclean does NOT work. At best, it truncate the files to < 2 GB.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: markusb68 on September 12, 2010, 09:48:11 AM
Hi Michael,

can you pls explain your workaround? or post a link?
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: marcelg on September 13, 2010, 04:08:36 PM
WORKAROUND:
Please see MichaelW's workaround that will do the trick, until WD will release new FW for the WDTV Live model.
To my experience, the mkWDclean does NOT work. At best, it truncate the files to < 2 GB.

Hi MichaelW, i know it works!, but my complain is about the missing info about it.

Here is the page with the batch:

http://wdtvforum.com/main/index.php?topic=7073.msg56343#msg56343

Thanks a lot MichaelW for your help.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: RavRob on September 15, 2010, 06:56:13 AM
WORKAROUND:
Please see MichaelW's workaround that will do the trick, until WD will release new FW for the WDTV Live model.
To my experience, the mkWDclean does NOT work. At best, it truncate the files to < 2 GB.


What IS your work around?
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: sub0 on October 01, 2010, 04:11:06 AM

This is what I used and it takes about 45 seconds. All I did, was download and extract mkvclean from http://www.matroska.org/downloads/mkclean.html. Extract it into a folder, then dragged and dropped my movie file onto mkWDclean.exe and it took the file and removed the header. It put the 'cleaned' file into the original directory under the file clean.<movie.name>.mkv. Hope this helps anyone and is a quick fix for anyone frustrated or still annoyed by the whole header thing. I've tested it on multiple files of various sizes up to about 6.5gb and no issues (so far) :)
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: SchmuFoo on October 02, 2010, 02:41:27 AM


The WDTV Bug with no Audio on MKV files which was generated with the new compressed header flag in mkvmerge >= 4.1.0 is FIXED!!!

http://download.wdc.com/wdtv/wdtvlive_1.03.40_V.zip

This Version also bring DVD Menu Support to the WDTV Live :)
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: RoofingGuy on October 02, 2010, 09:44:17 AM
This Version also bring DVD Menu Support to the WDTV Live


It also still doesn't work with many HDMI devices.  It was a test to see if they'd fixed 1.03.39 which pretty-much wouldn't work with HDMI, which itself was also a test to see if they'd fixed what they broke with 1.03.38.
Title: Re: no audio if mkv made using new mkvmerge 4.1.0 or newer
Post by: RavRob on October 02, 2010, 02:11:00 PM
The new 1.03.41 supposedly has the HDMI issues fixed.  I can't test because I never had those issues with HDMI.